nvidia drivers for opensuse 11.0

when can we expect nvidia drivers for opensuse 11.0. I am stuck with VESA and its spoiling the desktop experience.

I followed the one-click installer for 10.3, and it worked. I booted into the new kernel, and bam! Nvidia and Compiz-fusion goodness.

Mind you, that installs an older 2.6.22 kernel, but it is worth it. Hopefully we’ll get a nice newer kernel package with Nvidia drivers for 11.0 at launch.


I manually installed the OEM NVIDIA-Linux-x86_64-173.14.05-pkg2.run
works for me in rc1:)

I bet the drivers’ link will be in Database error - openSUSE as soon as GM hits the street. Nvidia is good about that:)

I tried running the manual install driver from the Nvidia website but it kept telling me I didn’t have the required packages (gcc and make) even though the package management had them listed as installed. Hope they have a repo driver available soon.

Go into Yast > Patterns & select C/C++ & Kernel development

Then check to see if you have kernel-source & kernel-syms that match your running kernel "uname -a).

You need those to do serious compiling.

Should work:)

Has anyone managed to get that driver working with the desktop effects? (Compiz etc)

I did a build of the NVIDIA driver as mentioned above, but when I click to enable the desktop effects, the screen flashes, but I don’t get any wobbly windows.


I know I can install nvidia driver manually, but then it has to recompiled everytime there is a kernel update.:frowning: Waiting for the repo driver.

Do any of the effects work?

I’ve got them with KDE 4.1, if that helps.


I have yet to hear of anyone having any success with compiling Nvidia’s legacy drivers.

I have to do that with the ATI Catalysts for Linux, and it’s not that hard!

I’ve done three recompiles in the last week (two due to kernel upgrades; the last of those was earlier today). As long as you have had the kernel source for your previous kernel, whenever you get a new kernel via a repository-based update, you get the source to that kernel as well (the kernel source is in the same repository as the kernel itself). Same applies to the development tools.

Chances are, that 11.0 won’t be a listed build target when doing a driver build (no matter what driver we’re talking about). Instead, build for a 10.3 target (which should be supported, if the driver is new at all). It’s not that difficult, folks (and I normally put RPM-building up there with root-canal surgery).

Stefan Dirsch has them ready to go in the build service for the 11.0 release date. Alternatively you can go to the build service, download the files and build them locally on your machine.


The build service has a search function that you can use to find specific items (such as nVidia). When available, 1-click install links are included in the search results. Even better, you can search for a specific distribution (11.0, for example, is now directly searchable). I found the five packages needed to add XGL to my already solidly-working compiz-fusion setup (three in one 1-click installable, and two in the other); even better, the two 1-click installs handled KDE and GNOME at the same time (I have both installed, though GNOME is the default).

Why XGL, even though AIGLX support doesn’t require it?

Though most of compiz-fusion’s bag of GUI tricks doesn’t require XGL (DRI and AIGLX are enough), the fancier tricks of that bag are out of bounds unless you add XGL support to your arsenal. Even better, adding XGL lets you run those GL-accelerated games (such as openarena) without breaking compiz-fusion (let alone compiz itself).

Also, it doesn’t require powerful hardware (considering I have a several-year-old P4 Northwood-C, 1.5 GB of RAM, and a midrange ATI X1K series card, I’d say I’m still somewhere below the typical openSuSE user, at least in the US). You nV users actually have it easier, not harder.

The 96.xx version is available for 11.0.

what its the difference between

or what should i install for 7600Go (laptop)

No I haven’t had any success compiling Legacy drivers either. It doesn’t like my kernel modual it says.
And I thought it was matched with my kernel.

I installed 11.0 RC1 over the weekend.And played with GNome,both KDE desktops.
I think I could get use to KDE 4.0

I just don’t have enough hours this week to mess with trying to sort out the driver.

Version: 173.14.05 is a newer driver
* Added support for the following new GPUs:
o Quadro FX 3600M
o GeForce 9800 GX2
o GeForce 9800 GTX
o GeForce 9600 GT
o GeForce 9600 GSO
o GeForce 9500M GS
o GeForce 8400
o GeForce 8400 GS
* Added support for Quadro FX 5600/4600 SDI and Quadro G-Sync II.

I like to go to: Drivers - Download NVIDIA Drivers
plug in the info for my card & see what Nvidia says
and, with the repo up in Yast: ftp://download.nvidia.com/opensuse/11.0/
install the OEM recommended driver for my card:)

Just make sure the kernel extensions match, do “uname -a” in a terminal;
like – nvidia-gfx-kmp-default-96.43.05_2.6.25.5_1.1-6.1.x86_64.rpm is for running kernel.

If the kernel modules don’t match; you will have problems;)

Have fun:)

The x11-video-nvidia packages are the drivers themselves, and I think in openSUSE they will pull in the nvidia-gfx kernel package.

The 96.43 packages are the legacy drivers for older cards. You need the newer 173.14 driver.

My plugger machine has a TNT2 card.
And according to Nvidia site I need the.

Only reason I am running TNT card is. My geforce card died. And I’m not putting any money in this machine as it will soon be retired.
But it has been a good distro testing machine.:smiley:

Ok I got it all working. I don’t know much about the legacy drivers but here is a small guide to get things going.

  1. Make sure you have all the right build tools, to allow you to build a Kernel module. (Open Yast’s Software management, choose the patterns option and select Base Development, C/C++, and Kernel Development options).

  2. Download the latest NVIDIA Driver (NVIDIA-Linux-x86-173.14.05-pkg1.run) is the latest at the time of writing.

wget http://us.download.nvidia.com/XFree86/Linux-x86/173.14.05/NVIDIA-Linux-x86-173.14.05-pkg1.run
  1. Press Ctrl + Alt + F3 to switch to terminal running on run-level 3.

  2. Login as root.

  3. Stop any X servers

init 3
  1. At this point, press enter if there is no login prompt. Login once again as root.

  2. Now run the NVIDIA installer.

sh NVIDIA-Linux-x86-173.14.05-pkg1.run
  1. Follow the instructions, and everything should build :slight_smile:

  2. Reboot, and see if you can enable desktop effects in Yast. If not, then as root check the /etc/X11/xorg.conf

Under devices make sure it looks something like:

Section "Device"
    BoardName  "GeForce 7600 GT"
    BusID      "1:0:0"
    Driver     "nvidia"
    Identifier "Device[0]"
    VendorName "NVidia"

Note it’s the driver part that is important, if yours says NV or nv, change it to nvidia. Everything else will be similar, albeit specific to your board.

Hope I’ve got everything there, any problems compiling let me know. Before this driver was out, I had to patch the old driver’s code for the kernel.

Oh one last thing, you can either re-boot to get graphics running or type:

init 5



at this point, startx will login to KDE as root user.