Nvidia drivers cause boot to fail

I’m really sorry if this topic has been discussed hella lotta times here (and I’m pretty sure it has), but I’m seriously angry that the linux world turned against me these days like this. Switched to Tumbleweed couple days ago, and once I have Nvidia drivers installed on a shiny fresh machine it won’t proceed to a login screen (often), just a command prompt and the last entry I see is

 OK ] Started local services... (some more useless **** here)

Sometimes it will, a few minutes of eternal screen blinking later… but hell, I need to reboot my PC two or three times to get it work.
What exactly happens is that at the command prompt screen (or whatever screen’s called where you see all services running up before the DE launched) the screen goes blinking, like, it goes black for 2 secs, then the text gets back for a little moment, goes black again and so on.

How did I install drivers: yast → Software repositories → Add → Community repos → nVidia Graphics Drivers, then downloaded the ‘x11-video-nvidiaG05’ package in yast’s Software Management, reboot… welcome to hell.

My beast: Geforce 1070 Ti, Tumbleweed x64, Gnome 3.30.1 (pray for me, I can’t open Gnome’s settings for ‘God-knows’ reason, so I had to watch it in software management as well).

I have an idea that the drivers fail the module verification due to enabled secure boot in boot loader settings, but I would be very grateful for the help of yours too.

Okay, no, disabling secure boot didn’t do a thing, should be X stuff, maybe

If the previous kernel worked, boot that one from the GRUB Advanced options menu

Well, if I remembered what was the first kernel I had after the first Tumbleweed installation. It was replaced with new ones after each update (or something, at least the previous ones aren’t seen in the grub)

Which NVIDIA drivers? can you boot with nomodeset?? At grub boot screen press e find line starting linux or linuxefi go to true end (it wraps) add a space and nomodeset F10 continues boot

If that works go to Yast uninstall the nvidia driver and then reinstall should use the O5 flavor driver.

Also is this a laptop? If so you will need bumblebee

Sorry for being late. No, no Optimus thing, a desktop. Boot with nomodeset didn’t do a thing, same crazy blinking sequence.
Currently 410.78-6.1, which is the latest, and it’s from x11-video-nvidiaG05 package

Which NVIDIA drivers? can you boot from?

What do you mean “which drivers”? I mentioned it, like, twice in the whole thread

Think TechOne is spamming

Wow, I made it. I had to download kernel source and some devel packages listed here, and then, after booting to runlevel 3 with nomodeset, creating a conf file to blacklist nouveau (which was excessive, since the newly generated initrd already contained one (the conf file was probably generated after installing x11-video-nvidiaG05)) (also, I had to install dkms before doing anything else, thought it would solve all problems) and installing the driver from nvidia repo everything works like a charm.

But for how long? If something bad happens when a new kernel arrives, I’ll be back here

Random but thank you for this tidbit… this is such a vague problem that just happened to me and searching for grub on google took me several hours to find a tip on how to add the nomodeset command to get back into GUI version of KDE desktop… :’(:’(:’(