Nvidia Drivers and Kernel Updates

Hi, I am using openSUSE x86-64 13.2 with KDE desktop and an Nvidia G720 graphics adaptor and using …G04 drivers.

A while back I had a problem when a re-boot following a kernel update which left me with VGA resolution only. Others had the same problem. After a great deal of help from Wolfii and others on this forum I was able to restore required resolution.

The problem has just re-appeared and I revisited my old thread to remind myself how to solve the problem.

I have just reinstalled the driver:-

sudo zypper in -f nvidia-gfxG04-kmp-desktop

This seems to have fixed it although there were many warning messages in the process.
Am posting this just in case others have same problem.

It is unfortunate that those who work on the kernel updates do not appear to use Nvidia cards!!!

now and then the nvidia rpm will lag behind the MATCHING kernel by a day or 3

be warned

always CHECK!!! if there is ALSO a nvidia driver WITH a kernel update

if NOT
do not update yet

Sorry, but you are wrong on two points here:

  1. There is no need for a driver update whenever there is a kernel update. Existing kernel modules should just work with the new kernel too. (this only applies to stable openSUSE releases as long as you are using the shipped kernel though)
  2. The nvidia driver packages do not contain a pre-built kernel module, they compile the module when you install them.

Regarding 1: there was an incompatible kernel update which led to problems with the installed nvidia driver and therefore got retracted. If you installed that update and reinstalled the nvidia driver to fix it, you had to reinstall it again after the followup kernel update, because that one was compatible to the earlier kernels but incompatible to the incompatible update (by definition :wink: ).

But, this was a one-time mistake. This does not happen normally.

And, @Budgie2:
The above should answer your post too.
And you can also always boot the previous kernel in “Advanced Options” in the boot menu.

But I don’t understand why you had that problem now? What kernel update did you install? There was none recently.
Or did you wait with installing the followup update (which was released two weeks ago) until now?

If you complain that nobody tests kernel updates while using the proprietary nvidia driver, feel free to volunteer. The incompatible kernel update was available for more than a month in the publicly accessible update-test repo, and nobody reported a problem with it. (except for that X.509 certificate error message which is purely cosmetic)

Hi Wolfii,
Many thanks for your detailed explanation. I am returning to this thread because the problem has occurred again with the last update, although not I believe a Kernel update.

Confident that I knew all about it following your previous help I tried the fix which worked last time but loh and behold it didn’t work.

Tried going to Advanced options on reboot but they crashed and I am now back where I started.
Will post the results of the commands you asked for last time. This post is to highlight that again I see I am not the only one to have a problem with Nvidia after an update.
Best wishes,