Nvidia drivers / Alternatives (Acer Aspire V15 Nitro Black Edition) Laptop

Hello, I’m trying out different KDE Plasma supported linux distributions and I’m having a hard time finding any good support for nvidia drivers. My laptop run intel onbard video and a 860M (optimus) but I can’t seem to get any drivers to work. I’ve tried downloading them off Nvidia’s website (both 352* and 358*) but they either don’t install properly or don’t boot after installing. I’ve tired bumblebee with no success so far following this guide: https://en.opensuse.org/SDB:NVIDIA_Bumblebee I can get everything installed fine but after rebooting nouveau throws a million errors, flashes the three loading dots and reboots.

OpenSuse Version: Leap 42.1 (also tried tumbleweed)
Laptop: Acer Aspire V15 Nitro Black Edition
Secure boot: Yes
Fulled updated system before install: Yes

I found a few other posts about nvidia drivers but nothing has worked so far, and I’ve reinstalled at least 20 times by now. Are the drivers just not ready yet? Did I miss something important? So far the only distribution that nvidia drivers worked on was Linux Mint MATE using the “addition drivers” selection; everything else never got as far as a login screen.

Don’t know if there are specific issues with your Acer model, but I can confirm that https://en.opensuse.org/SDB:NVIDIA_Bumblebee works OK if followed thorougly on my ASUS.

A few hints:

  1. DON’T install Nvidia Drivers from Nvidia site on Optimus laptop (and be sure to remove everything if you did, before installing Bumblebee).
  2. Have “Install recommended” set before installing bumblebee and nvidia-bumblebee (otherwise you might miss some needed parts).
  3. Remember to blacklist Nouveau (if it is spitting errors, it seems that it is still engaging the Nvidia chip).
  4. Maybe try an extra “dracut --host-only --force” to rebuild the initrd after installation of bumblebee & nvidia-bumblebee.
  5. Try to disable secureboot if you can (at least until you have everything working), it has issues in Leap with some configurations.

This is just to avoid something trivial, report back if nothing still works.


I’ll give both of those a try, that link looks good and has a few steps I never tried. Thanks.

Can you please run

lspci -v

and see if nvidia is indeed running in your machine

This post should be in another thread, sorry for the inconvenience.