Nvidia Driver

When I attempt to open the XBMC player, it pops an error saying that it needs a hardware accelerated openGl driver. I went to the download page indicated in the sticky for configuring a graphics card, and ran the driver that appeared to be for my card (GTX 460 SC) with Kpackage, and it appeared to install properly, but XBMC continues to squawk as before. What do I need to do to fix this?

So I am thinking you need to read about the many ways one might load an nVIDIA video driver and the settings one must use for the driver to work. As you read, you will find links to loading the video driver, the hard way, which is how I do it. But, before you take any other steps, read the following guide.

SDB:NVIDIA drivers - openSUSE

There is the one click way, the repository way and the hard way. Here is a link for the hard way:

SDB:NVIDIA drivers - openSUSE The hard way

Please, I ask that you read through the three methods before you decide on the way you wish to use. While I use the hard way, if you stick with the current kernel version and only upgrade when there is a security update, I would look at using the repository method. Once you know what these methods are from reading, then ask more questions on the subject.

Thank You,

I would try to find out what “hardware accelerated openGL driver” means.

My experience is when playing a multimedia (video) file with a multimedia player, the ‘xv’ video output mode tends to work best. But there are typically other selections with most players.

As for hardware acceleration of video, it is possible with the proprietary nvidia video driver (and with certain applications) to offload the decoding of the video from the CPU to GPU using in Linux something referred to as ‘vdpau’. The GTX 460 SC you have definitely supports vdpau with the proprietary nvidia driver.

But your XBMC refers to an openGL accelerated driver, and I do not know what it is refering to. Definitely vdpau is NOT openGL. A surf on ‘xbmc’ and ‘accelerated openGL driver’ may be in order.

After using the “easy” method to install the driver, it seemed okay, except that XBMC didn’t like it any better, and when I rebooted, I can no longer reach desktop. It just displays the text mode, which I assume is called init 3, even though it says that it has reached init 5. I feel sure that the Nvidia driver is the cause of this, so how do I fix things now, without a totally new install of Suse? I tried to use the upgrade install, like I had done previously for a different problem, but that option is now grayed out.

Are you certain you are stuck in a text mode?

Did you try the boot code ‘x11failsafe’ or simply boot with the FailSafe boot mode option ?

If you are stuck in a ‘text’ mode you can still (with root permissions) run a text mode ‘yast’ and search for and uninstall any proprietary driver rpm. Typically they have the character sequence ‘rpm’ in the file name.

To list any installed rpms with nvidia in the rpm name simply type (as a regular user) :

rpm -qa '*vidia*' 

that will give you a list of rpms, most of which you can uninstall to remove the driver.

To see what rpms you installed in chronological order you can type as a regular user:

rpm -qa --last | less 

To restart from text mode you can type with root permissions:

shutdown -r now 

and to halt you can type with root permissions

shutdown -h now 

That was easy, as far as x11failsafe goes. I’m now at a windowed desktop. I have to confess that I’m pretty shy, when it comes to using text commands or terminals, so I tried to use YaST, but didn’t find anything that seemed to give me access to the Nvidia driver. I did try entering SAX2 in the terminal, but it didn’t seem to understand what I wanted. Since I am in a graphical environment, can you give me an easy method to proceed?

EDIT: I did get this:

wallwalker@linux:~> rpm -qa ‘vidia

But now that I got it, I don’t know what to do with it?

You are likely now running the incredibly low performance FBDEV graphic driver. Its main ‘claim to fame’ is it is very compatible, but its performance is low.

Presumeably you want to go back to the nv or nouveau graphic driver, and possibly try to get the proprietary video driver working on a 2nd attempt.

Then those are the three rpms you should remove.

Go to YaST > Software > Software management > search and type ‘nvidia’ and you should see the same 3 rpms. Mark them for de-installation and uninstall them.

When you reboot after this you should go to the nouveau or nv driver (dependant on what you did BEFORE you attempted the nvidia driver install).

You may wish to read some basic theory on graphic cards: openSUSE Graphic Card Practical Theory Guide for Users

and for openSUSE-11.4 graphic card install : SDB:Configuring graphics cards - openSUSE

Sax2 was removed from openSUSE some time back. SuSE-GmbH noted it was mostly broken in many parts and asked for community volunteers to maintain because they SuSE-GmbH could not maintain it. The community did not step up to the plate to take over the job. So Sax2 was dropped.

I did get what I think that is needed, but I’m still uncertain which to uninstall. I would have uploaded a screenshot, but I don’t see that option on the reply window.

Simply post the image on ImageBam - Fast, Free Image Hosting and Photo Sharing and post the link to the image here.

Okay, I didn’t feel that I knew what I was doing, but I uninstalled those 3 lines, and rebooted, and did reach desktop without any problems, so that part of my conundrum is solved…thanks.

As far as the original issue with the hardware accelerated openGL driver, I did notice a section of the description of the driver available directly from the Nvidia website talking about that, but it seems that it requires using some terminal commands to install it, and I have no idea of how to do it.

EDIT: Oh wow!, I just tried XBMC again, and this time it started without squawking, so I guess that so of the things that got downloaded, when I uninstalled those things we were talking about, must have given it hardware acceleration opengl ability.

I guess it is going off in bit of a tangent, but when I tried to add my external drive, which contains my videos to XBMC, by locating the path, all that I found were a lot of folders that are native to Linux, not those in my video archive. The hard drive is mounted and does work with Dolphin, so would you have any idea of how to set the path in XBMC? I realize that may not be a fair question, since it seems that you aren’t familiar with the app, but I’m hoping that is generic enough that familiarity isn’t necessary.

So by mounted, you mean the external hard drive partition has been added to your fstab file and resides in a folder from the main or root directory of Linux? I suggest you open up a terminal session and run the following command:

cat /etc/fstab

Copy and paste the information here in a code # field for us to see. If you are mounting it on the fly, you will need to add it to your /etc/fstab file using:

YaST / System / Partitioner, right click in the left window on the external hard drive partition (like /dev/sdb1 perhaps) where your videos are kept and select edit. Now, at the bottom of the edit windows, select the mount bullet and enter a location for it to be mounted like /Videos for instance then select OK and then Select OK again. If the folder /Videos (or what ever you called it) does not exist, it will be created, if it does exist, but is not being used, it will be used to mount your external hard drive. Now, you should be able to search and include the new folder path in XBMC.

If the external hard drive partition is NTFS, you should make one more change as root to your fstab file. IN KDE the menu Run Command would be:

kdesu kwrite /etc/fstab

I would change the options line to just read defaults like the following line shows:

/dev/disk/by-id/ata-ST31500541AS_5XW14NDQ-part8                   /Software            ntfs-3g    defaults                                           0 0

If you are having trouble finding your external hard drive, you could give us a fdisk -l command like this in terminal:

su -
fdisk -l

In all cases when you copy and paste text into a message, use the Advanced Message Editor, highlight just the text you pasted and press the code # symbol to prevent the information from being reformatted.

Thank You,

oldcpu wrote:

> Go to YaST > Software > Software management > search and type ‘nvidia’
> and you should see the same 3 rpms. Mark them for de-installation and
> uninstall them.

Watching all the threads about Nvidia problems, I get the feeling that you
should be using this step as a starting point for all the Nvidia
installation problems, especially when I see the Nvidia ftp site mentioned.
Going “the hard way”, then mixing in the Nvidia repo with Yast is going to
be a mess unless the user managed to get exactly the same version from the
ftp site that is offered in the repo. I was playing with some of the beta
…270 releases and got into this mire a while back - removing all the
existing Nvidia-related stuff and starting clean seems to be the safest way
to go.

Will Honea

I have a video server nfs share mounted in a directory on my xbmc cpu, so it’s just a matter of pointing this folder to xbmc, that see it as a local folder. If you can read it in your xbmc machine file browser, you can access it with xbmc.

If you are using samba I think the process is the same, but I’m not sure.

Bottom line is: it depends on what share protocol you’re using: NFS, SMB, one of the many streaming protocols, etc.

I have been playing with nvidia drivers a lot lately on 11.4. Noting comments above about removing all other nvidia drivers I don’t think this is really needed. I’ve booted up with various messes and if the driver is there X will load the correct one. I’ve posted the way I shall do it while the repo I used exists. It’s easy. Done that way yast will load the kernel headers if they aren’t already on the machine indicating that it is going to recompile the kernel include the nvidia interface as mentioned in the myriads of out of date howto’s that are about even on the nvidia site. On this basis even though I removed the nouveau driver using yast I don’t think that is really needed. When I did that X chose NV. After installing the nvidia driver it chose that. It seems to do this on the basis of what cards the driver supports.

I would like some one who is linux conversant to try the same way as a check on my post and improve it if possible. If all ok a mod should really make it sticky. Why - many people who have no chance in the black box just want to get their machine up and running. Me well I have used linux since kde 3.1/2 and was determined to stay out of it. I’ve been in too many others. The main thing that needs checking really is if removal of the nouveau needed. It could be that X picks that or others before the latest one and uses that. What I hoped to do was to get X to use the standard gp vesa driver as this one is sure to work with all cards. The catch in this area is if some one is using a card that nv does support and wants to upgrade X may still choose NV. I would hope not as X is a fairly clever bit of software. Snap with nouveau.

Out of interest using glxgears as a guide the nvidia driver is about 4 times faster than nouveau. KDE desktop effects are handled easily as well. I’m using a 210 which isn’t exactly an expensive card. An old 7600 can barely cope on NV and isn’t supported by it really anyway. On an incarnation that correctly installed the nvidia setting utility it showed that KDE seems to use about 1/2 of the 210’s max capacity. It was peaking at this when the fade effects occurred.