nVidia Driver via Repo in 11.3 & 11.4 - Guide

How to install the nVidia drivers with the Repository

**This is a step by step account of my recent install of 11.3 _64 with a GeForce 9600GT

  • I have used this same method with 11.4 ( http://http.download.nvidia.com/opensuse/11.4/ )

    • Install openSUSE 11.3 and boot to the desktop
    • Edit /boot/grub/menu.lst and add nomodeset
      to the boot arguments in the default boot. - In Yast > System > etc/Sysconfig editor go to System > Kernel > NO_KMS_IN_INTRID and change the default no
      to yes - Add the nVidia repo for 11.3: http://download.nvidia.com/opensuse/11.3/
    • Now open Yast > Software > Software Management and you will find the driver is automatically added to install - Accept the install
    • Reboot

That’s it. It just works. Really easy.

Illustrations for your assistance:

Boot edit Pic1

Boot edit Pic2

Kernel edit Pic1

Kernel edit Pic2

Other Ref’s:
SDB:Configuring graphics cards - openSUSE

openSUSE Graphic Card Practical Theory Guide for Users

Is this for the propaitary or nouveau drivers?

For NVIDIA proprietary drivers.

I figured, just making sure. :wink:

The repo should tell you that.

I’m getting this error
Download (curl) error for ‘http://nvidia/http://download.nvidia.com/opensuse/11.3/repo/repoindex.xml’:
Error code: Connection failed
Error message: Couldn’t resolve host ‘nvidia’

how do I get the repo added?

there must be a better way to install nvidia, seems there’s always something that goes wrong.

become su in a terminal and try this:

zypper ar -f http://download.nvidia.com/opensuse/11.3/ nvidia

copy and paste this carefully with your mouse to the terminal


zypper ref

accept the key

Now close the terminal and open Software Management

Thank you, looks like it worked.

Now where is the Scale effect? It’s the one that when I mouse up to a corner all the windows lay out to see.

Do you mean in kde?
Present windows?

Just configure via desktop effect in the system settings
You will need to setup the screen edge too

Yes, I think I found it, but in opensuse its set as ctrl+F10 and that does the same.

When I installed the nvidia drivers all the text on my computer became so small I couldn’t read it. I’ve gotten almost all of it fixed so that it’s back to normal, but the text at the login screen, in Yast and in the terminal are still so small I almost can’t use them. Are there settings anywhere to change the text size in them.


Do you believe this guide will work for 11.2?

You don’t need to add nomodest to 11.2
Just add the repo (11.2) and open Software manager and it should be there ready and waiting to install.

I’ll have a go at it tonight…


Ok, so I was following the steps, but NO_KMS_IN_INTRID is missing from Yast > System > etc/Sysconfig editor go to System > Kernel. However, I also found this guide… SDB:NVIDIA drivers - openSUSE. Thoughts, anyone?


  • CT*

You don’t need to do anything special in openSUSE 11.2.

Add the repository, and install the driver, reboot and you are done. :wink:

As I said all you do is:

Just add the repo (11.2) and open Software manager and it should be there ready and waiting to install.

Yup, running the nVidia driver now… thanks for your guidance!

[Awesome graphics now, if I may add!]

I don’t understand it. You have to disable kernel mode setting. The packages from the official nvidia repository are doing this automatically via the sysconfig entry (NO_KMS_IN_INITRD) and running SuSEconfig to apply it to the kernel config. So why do you have to do this before the installation if it’s done automatically during the installation and why do you have to pass this option by bootloader command too?

As far as I know, if you install stuff directly from zypper, SuSEconfig won’t be run automatically, so you have to run it manually after the installation, but from YaST it should “just work”.

So why do you need to do something special and cryptic in 11.3? Is 11.3 a backstep from 11.2? :frowning:

What does this NO_KMS_IN_INITRD really do?

I think I’ll better wait another month before I attempt the upgrade from 11.2 to 11.3 then. In the past, waiting 2-3 months after a Suse would have helped, this time, I try not to fall into this trap.