Nvidia Driver stopped working on update

Hello,

Yesterday I ran zypper up, and some nvidia packages were updated. The trouble began when I did a reboot. X did not start at all! (complaining something about unable to find monitor).

It’s the first time since OpenSuse 10.1 that my videocard is not working.

I removed all nvidia packages from yast. The problem is, I’m not sure which packages to reinstall. Finally, I decided to install the G01-kmp-default thingy’s. Running

sax2 -r -m o=nv

gave me some graphics back. X starts on boot, and tells me which graphics card I have (that information is correct). However, I think the driver is not installed correctly. glxgears and glxinfo both don’t work, kwin effects are not working, and fans is working like hell.

I have a few questions, what could have happened?
Is the driver broken?
Is my kernel broken ( I never did a one-click install and I never updated or recompiled the kernel manually)?

How to proceed?

My videocarddriver: Nvidia Quadro NVS 140m (256 MB(?)).
OpenSuse Version: 11.1 - 64 bit.
Dell Latitude D830 Laptop
KDE4.2

I hope there is someone who can help. Thanks in advance.

Install YaST2-Factory and then run it through YaST2 as long as you have the NVIDIA repo set up it should automatically select the correct packages for you.

You don’t want factory that’s the unstable stuff.

The reason for the driver problem is the latest kernel update.
Try reinstalling the drivers with yast

The YaST2 Factory utility can only install software from configured repositories so unless there are unstable repo’s configured on the machine no unstable software will be recommended or installed.

What it will do is check all software dependencies for what is installed and automatically make recommendations to install additional software including drivers that it feels the system is missing from the stable repos that are configured.

This is also an easy way to change out all of your codec’s with the ones from the Packman repo that support proprietary formats.

You also do not have to install everything it wants to change you can just run this to check which drivers it sees as being the most suitable for your video card and then install them your self through YaST2 software management or zypper from the command line.

Well, usually you don’t have to worry about the driver breaking with the drivers from the one-click install (the ones from yast or the nvidia repos). If you have compiled the driver yourself then usually that’s when it breaks on a kernel upgrade, so trying to use the Yast drivers will only cause more conflict.

First, did you compile the driver yourself or also known as “the hard way”?

Take Care,

Ian

The initial post mentions that the drivers were removed after the problem arose and that the user did not know what driver needed to installed. So the user was going to play the let me try this driver and see what happens game.

This is why I recommended using YaST2 Factory. The user mentions that G01-kmp-default has been chosen, as I mention from best guess and is a naming convention from the repo and not the NVIDIA install script. As I remember from the last time I set up an NVIDIA card I had to install two or three packages from the NVIDIA repo to get it working.

If it was my machine I would go this route. As I mentioned the factory utility will choose the packages it thinks are best for the hardware. You can then go in and review all changes it would like to make. If you don’t want it to update a particular package just tell it to keep the existing. The only thing in this case that the user really needs to do is see which video drivers it wants to install.

If it does not work after the correct drivers have been installed. Then run sax2 to configure the xserver.

Okay, so I just re-read it, and saw that. Thanks for pointing that out. So now that I know he tried to install with yast there’s no problem reinstalling with yast.

I’ve never tried Tim’s way so it might work, but this is just another way, as I use it with my old Nvidia card (see my sig).

First you’ll want to open Yast Software Repositories and remove any Nvidia Repositories. Then choose Yast Software Management and remove any Nvidia drivers or kernels installed.

Next you’ll want to go to this site

NVIDIA - openSUSE

and choose the third One-click installer For all NVIDIA Legacy cards (Geforce 4 and older, TNT).

Let it install and do its thing. Then restart your computer.

Upon boot up, choose failsafe mode.

It will come up as a command prompt (no gui). Login as root and then enter the root password.

Now you’ll want sax2 to detect the new driver so you’ll want to type:

sax2 -r

It will let you test and configure the screen and then once everything is done you’ll want to restart by typing:

shutdown -r now

Let it boot up regularly (not failsafe) and you should see the NVIDIA logo after you login, or if you have automatic login before the desktop loads.

See if that helps.

Take Care,

Ian

Ijsbreaky, I tried your method first, without any luck.

When following your steps, I was logged in with a GUI (failsafe). From there, I tried to change the screen resolution. After that, I rebooted and I was stuck again in the console.

(A part of the) SaX.log

	(II) NVIDIA dlloader X Driver  96.43.11  Mon Feb 23 15:54:58 PST 2009
	(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
	(II) NVIDIA X compatibility module for ABI 4.0 built from git commit 98249dfa98b53a238b7d881beb5ec8b85f28ecd0 (server-1.5-branch)
	(II) Primary Device is: PCI 01@00:00:0
	(II) Loading sub module "fb"
	(II) LoadModule: "fb"
	
	(II) Loading /usr/lib64/xorg/modules//libfb.so
	(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.5.2, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
	(II) Loading sub module "ramdac"
	(II) LoadModule: "ramdac"
	(II) Module "ramdac" already built-in
	(II) resource ranges after probing:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX**
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX**
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX**
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX**
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX**
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX**
	(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
	(==) NVIDIA(0): RGB weight 888
	(==) NVIDIA(0): Default visual is TrueColor
	(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
	(==) NVIDIA(0): Using HW cursor
	(**) NVIDIA(0): Enabling RENDER acceleration
	(==) NVIDIA(0): Video key set to default value of 0x101fe
	FATAL: Module nvidia not found.
	(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
	(EE) NVIDIA(0):  *** Aborting ***
	(II) UnloadModule: "nvidia"
	(II) UnloadModule: "fb"
	(EE) Screen(s) found, but none have a usable configuration.
	
	Fatal server error:
	no screens found
]

Not sure what it means.

@TimButterworth. Should I install yast2-update-factory? I’ll give it a try anyway.************

Edit: (not allowed to edit, that’s why I have to double post)

Whew. It works. I added the NVidia Repos again (community repos). Installed yast2-update-factory. Clicked on update in yast, “Ok”. It proposed me to install the G02 version of the drivers, and they did the trick.

It’s a little strange, because I never had that version installed, but always had the ‘standard’ version installed.

It works. Happy again ^^
Thanks.

You’re lucky. All this has nothing to do with Factory. You might easily have destabilized your system to an extent you could not have solved yourself.
Do yourself a favor and disable the factory repos.

I second that stay away from factory if you want a stable system

Relax. The yast2-update-factory is in the openSUSE11.1-Oss.

And please bear in mind that my system was already screwed up. (And I usually always use zypper to install software :stuck_out_tongue: )

However. I think that the normal update ‘saved’ my system. Not the factory, because I did not explicitally run the factory.

All,

There seems to be some confusion here. First the YaST2 Factory update is a YaST2 utility not the beta version of openSUSE 11.2. Installing this utility and running it will NOT upgrade you to the unstable Build Service repo’s unless you manually configured the unstable build service repo’s to your system and accept the changes it proposes after manually fixing quite a few dependency problems.

What this utility will do when it is run with only stable repo’s configured, is check that all software dependencies are met on your system, check the hardware your system has and automatically recommend drivers and other software from the stable repo’s that were added after installation, ATI, NVIDIA, OSS, NON-OSS, Packman, etc, “which ever extra ones you added, OSS, Non-OSS and update are added automatically during installation” It will also check for available software updates, including recommending upgrades from other configured repo’s which zypper update does not automatically do by the way if the repo priorities and not set the same. It will recommend software covered in the patterns that were selected during the install that may have not been available on the install medium e.g. the software was not on the install disk but it is in the OSS, Non-OSS repo.

This utility works along the same lines as using the zypper distribution upgrade, dup. When both of these are ran with only stable repo’s configured it essentially computes a distribution upgrade from openSUSE 11.1 to openSUSE 11.1 but adding all of the additional software from the online repo’s you have configured on your system and conveniently recommend all additional software and drivers that were not available on the disk during the initial install that it see’s you need.

This is probably one of the best little know about utilities in YaST2 but unfortunately the name creates to many assumptions as to what people think it will do.

I run this every time I perform a clean install after configuring all of the extra repo’s I use. It adds the drivers I am missing for my web cam, wireless etc. Changes out the XINE and CODEC packages with the ones from the VLC repo and PACKMAN which support proprietary formats supporting: DVD, MP3, ACC/MP4 etc.

If you do not trust this I invite you to try it for yourself. After you launch it will eventually take you to a screen showing that is has computed the update from your current version to your current version. You can then select the software section and review all changes it wants to make as well as see which repo it is getting each package from. In my experience you usually have to do this anyway because it will find at least one dependency problem that you will have to work out. It will not install anything until you accept all changes it proposes.

Just to emphasize this again IT WILL NOT UPGRADE YOU TO THE UNSTABLE BUILD SERVICE SOFTWARE UNLESS YOU HAVE MANUALLY ADDED THESE REPOS TO YOUR MACHINE. IT CAN ONLY WORK WITH THE REPO’S YOU HAVE INSTALLED.

In fact it actually will do the opposite if only stable repo’s are installed and you have added something it feels does not belong. I run the Kernel head repo from build service from time to time to test out new feature in the latest kernel of the day. When I run this with the latest kernel of the day installed it, 100% of the time, it wants to downgrade me back to the 11.1 stock kernel version.

Oh since I mentioned the Factory Kernel head repo and if you think this sounds neat and it is something you would like to try. I feel I should warn you that it will prevent AppArmor from working and is not compatible with the kernel modules from the stable repo’s. So it will also break support for virtual box, ATI and NVIDIA drivers from the openSUSE repo’s and other programs until you downgrade back to 11.1 stock.

Sorry this is long and may have came off sounding aggressive but I have seen this utility get bashed by on multiple threads with the same assumptions and felt the detailed explanation of what it does and how it works was necessary.

Cheers
Tim