NVidia Driver question

I am new to this, so please forgive me for what might be a silly question–

I have a NVIDIA GeForce 8600GT sli video card. The instructions for downloading the drivers at Nvidia Installer HOWTO for SUSE LINUX users) recommend using Yast as opposed to manually recompiling the kernel. However, there is also a note saying that I should first boot into run level 3 and unload the kernel module. Does that still apply if I am using Yast?

Thanks for your help.

One click Nvidia, unless you already have the repo’s http://opensuse-community.org/nvidia.ymp

Never mind rulevel3 if you are using yast
Try yast first. The oneclick will set yast off for you.

Thank you! As a recovering Windows user, I’m glad that there is a place like this to ask questions.

In case you have any problems and want to try it the failsafe way. Installing from the repo does not work well on all systems.
Download the lastest nVidia driver NVIDIA-Linux-x86_64-177.70-pkg2.run, I put it in a folder: /temp/nVidia-drivers

Open a terminal and type:
init 3
<log in as root & with your root password>
cd /temp/nVidia-drivers (or where you downloaded the lastest nVidia driver to).
sh NVIDIA-Linux-x86_64-177.70-pkg2.run
Follow the instructions… ‘yes’ to all.
init 5

Done !
This takes less then 3min and for me it has always worked.

Screen resolution not supported in 11.0

After downloading and installing (one-click or the hard way) either version (Suse or Nvidia) of the driver for my 7300LE card, the resolution of the 19" IIYama monitor (preferred res 1440x900@60HZ) was still not supported with OpenSuse 11.0. At long last, the solution was to put a specific modeline for 1440x900 into /etc/X11/xorg.conf, together with putting the “1440x900” mode at the right places. The modeline was constucted by gtf.

It took me a lot of time to find the solution, being just a more or less experienced Suse-user. There were no instructions, hints or howto about this the restricted character of the Nvidia divers and or X-org. I succeeded bij looking into an installed Ubuntu (Hardy Heron) system’s xorg.conf, together with some Ubuntu forum discussion. Should there not be an entry in SDB or so with warnings and directions?

just one thing if your a newb like myself and thinking of trying it this way.
You will need to install these from yast2 before trying what he says here.

kernel-source
make

and

gcc

I’m about to try it hope it works! :slight_smile:

ok I did this but now I’m stuck in run level 3 :frowning:

I type init 5 and I get

INIT: Switching to runlevel:5                                                              
Boot logging started on /dev/tty1(/dev/console) at Sat May 2 19:11:59 2009          
Master Resource Control: previous runlevel: 3, switching to runlevel:                      5
Re-Starting syslog services    done
Starting service kdm           done
Master Resource Control: runlevel 5 has been     reached

but I seem to still be in 3 :frowning:
what I can see is all this text and

Ext-156:~#*flashing curser*

:frowning:
how do I load the gui again? I am currently typing this on my laptop as my desktop seems to be stuck on the black screen.

To start the gui type

startx

Good Luck,

Ian

upon restarting at the very bottom after it says:

Master Resource Control: runlevel 5 has been reached
then it says right under that: [QUOTE] Skipped services in runlevel 5: smbfs[QUOTE] Does that have anything to do with why im in runlevel 5 but stuck at a black screen??!! any help here would be appreciated thank you.

(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure that there is a supported NVIDIA GPU in this system, and that the NVIDIA device files have been created properly. Please consult the NVIDIA README for details. Aborting

uggg now what
my video card is a Nvidia 8600 GTS and I downloaded and installed NVIDIA-Linux-x86-180.51-pkg1.run and it said it was successful

I tried running the install script again… didn’t help… I be stuck in a console :frowning:

This is my canned response for doing it the ‘Hard Way’ :slight_smile:

Have you installed the nvidia driver via 1-click? If not I recommend
the hard way, else follow the easy way here;
Nvidia

If you have installed nvidia rpms via the easy way, I suggest removing
the rpms installed and disabling the nvidia repository first.

You can download the driver for your arch from;
Nvidia Unix Drivers

On the download page, check that your card is supported by the driver
your about to download by using the following command;


echo -n "0x" && /sbin/lspci -nv |grep VGA|cut -f4 -d ":"|cut -f1 -d "("

From the above output use the numbers from the output to look at the
Supported Products List (link on the left) to verify your card is
supported by the driver.

You may wish to ensure your system is up to date. The first command
refreshes the repositories, the second lists any updates, the third
will apply the updates.

 
sudo zypper ref
sudo zypper lu
sudo zypper up

NOTE: If the kernel updated, please reboot before continuing :slight_smile:

If you don’t have the kernel source and tools etc installed then


sudo zypper in kernel-source linux-kernel-headers kernel-syms
module-init-tools make gcc

Press ctrl+alt+F1 and login as your user :slight_smile:


su -
init 3

cd to the Nvidia Unix Driver you downloaded


sh NV*.run -q
sax2 -r -m 0=nvidia
init 5 && exit
ctrl+alt+F1
exit
ctrl+alt+F7

The ctrl+alt+F7 gets you back to the GUI (X session).

Now after a kernel update, you don’t need to run the sax2 command, just
the others to get to run level 3, rebuild the driver and exit.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
up 1 day 5:12, 1 user, load average: 0.29, 0.29, 0.38
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

only thing I tried before starting the hard way was with the yast add nvidia repository thing that I read here.
Nvidia Installer HOWTO for SUSE LINUX users
that didn’t work and I found this link.

I will work on this again Monday.
So can I do the ctrl+alt+F7 as it sits now and try the 1 click before continuing the hard way?
How can I just go back to standard vga adapter or what ever and try 1 click before I get a headache again haha :). Thank You very much for your reply. With all the help I should get it working soon.

Hi
I’ve never had much luck with the 1-click, as well as kernel updates
not in sync with the nvidia repository at times. So I prefer the hard
way :wink:


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel 2.6.27.21-0.1-pae
up 1 day 7:46, 1 user, load average: 0.10, 0.15, 0.17
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

ok its Monday and with a big cup o coffee in hand I’m trying this again. System loads to runlevel 3 already since it can’t load the display drivers correctly…

echo -n "0x" && /sbin/lspci -nv |grep VGA|cut -f4 -d ":"|cut -f1 -d "("

Tried that I got

0x400

or something like that what ever that ment. lol

sudo zypper ref
sudo zypper lu
sudo zypper up

did all of those it did do some updates so I rebooted. Logged in as root upon reboot and went to the dir I had Nvidia drivers downloaded. I don’t know how to make code go down a line with out pressing enter so I typed the next thing in all in one line like this.

sh NVIDIA-Linux-x86-180.51-pkg1.run -q sax2 -r -m 0=nvidia init 5 && exit ctrl+alt+F1 exit ctrl+alt+F7

and the reply I got was

Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 180.51..................................................................
./nvidia-installer: invalid option -- 'r'

so um now whats?

well I tried it again like this:

sh NVIDIA-Linux-x86-180.51-pkg1.run -q sax2 -m 0=nvidia init 5 && exit ctrl+alt+F1 exit ctrl+alt+F7

and I got

Verifying archive integrity... OK
Uncompressin NVIDIA Accelerated Graphics Driver for Linux-x86 180.51........................
Unrecognized arguments:
sax2
init
5

What should I do? :confused:

reading this:ftp://download.nvidia.com/XFree86/Linux-x86/180.51/README/chapter-04-section-04.html I found out --uninstall takes the nvidia drivers back out and restores prior xfiles. I ran the installer again with --uninstall at the end and now I’m back in gui yay! :frowning: but I still need to get the accelerated graphics drivers working… My GPU is Nvidia 8600GTS according to this:ftp://download.nvidia.com/XFree86/Linux-x86/180.51/README/appendix-a.html my card is supported by the drivers I have downloaded

0x400

so why don’t it work??? :frowning:

Post result of:

zypper lr

so we can see if the nvidia repo is in your list

Leroy@Ext-156:~> sudo zypper lr
root's password:
# | Alias                 | Name                  | Enabled | Refresh
--+-----------------------+-----------------------+---------+--------
1 | repo-debug            | openSUSE-11.0-Debug   | No      | No
2 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes     | Yes
3 | 11.0                  | 11.0                  | Yes     | Yes
4 | openSUSE-DVD 11.0     | openSUSE-DVD 11.0     | Yes     | No
5 | repo-oss              | openSUSE-11.0-Oss     | Yes     | No
6 | repo-non-oss          | openSUSE-11.0-Non-Oss | Yes     | No
Leroy@Ext-156:~>

the one thats name is 11.0 is the nvidia repo… Here is a Screen shot of what it looks like in yast. Is it the right one?
http://i232.photobucket.com/albums/ee207/iroybk/Linux/snapshot1.png