Nvidia Driver Problems

Hi everyone,

I’m really new to Linux and I’m having problems with my video card with OpenSuSE 11.1. This is my hardware configuration:

Acer Aspire M1100
AMD Athlon64 4200+
4GB DDR2 RAM
Nvidia GeForce 8400GS 512MB
OpenSuSE 11.1 x86_64

Yesterday I installed OpenSuSE 11.1 on this box and everything went fine until I got to my desktop. The resolution was messed-up and I had no 3D support available (so no desktop cube or nice desktop effects :(), so I went to the Internet and found some post about this issue, and the suggested solution was to install the Nvidia drivers, so I updated my Linux Kernel using YOU and went to SuSE’s site and installed the drivers using the nice One-Click install and everything seemed to installed fine. After installing everything, I rebooted my system and after everything loads, when it comes the part where xserver is started, everything went black and after few seconds, my display becomes idle and a message “No signal from PC” appears :disapointed:. If I switch back to vesa driver using the command “sax2 -r -m 0=vesa”, I can start X-Server but still having the resolution/3D support issues :. Is there a way I can make my nvidia driver work correctly? :confused:(By the way, my monitor is an Acer AL1716W)

Have you used sax2 to rediscover everything after installing nvidia driver?

Usually you should do it from init 3 and as root run sax2 -r -m 0=nvidia.

Hi Thank you for answering. Yes I did, I started SuSE in runlevel 3 and used sax2 -r -m 0=nvidia. The strange thing is that I get no error or warnings, the screen just turns black and after a while the monitor becomes idle:'(

I suspect it tries to set frequency or resolution too high for Your monitor. I’d use nvidia-xconfig and then inspect resolution in xorg.conf then try to start x server.

Try to change settings in xorg.conf for something your monitor can support. If you manage to run x server inspect xorg.conf set by sax2, it should be at /etc/X11/. And combine them :slight_smile:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder62)  Tue Mar 24 06:15:32 PST 2009

# /.../
# SaX generated X11 config file
# Created on: 2009-04-25T10:16:46-0600.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    Option         "Clone" "off"
    Option         "Xinerama" "off"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
EndSection

Section "Module"
    Load           "freetype"
    Load           "dbe"
    Load           "glx"
    Load           "extmod"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
    Option         "ZapWarning" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "es"
    Option         "XkbModel" "microsoftpro"
    Option         "XkbRules" "xfree86"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "mouse"
    Option         "Buttons" "7"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "KYE Wireless Keyboard & Mouse"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "--> VESA"
    ModelName      "1280X960@60HZ"
    UseModes       "Modes[0]"
    DisplaySize     305    230
    HorizSync       31.0 - 60.0
    VertRefresh     50.0 - 60.0
    Option         "PreferredMode" "1280x800"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVIDIA"
    BoardName      "GeForce 8400 GS"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    SubSection     "Display"
        Depth       15
        Modes      "1280x800" "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1280x800" "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1280x800" "1024x768" "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "1280x800" "1024x768" "800x600"
    EndSubSection
EndSection

This is what I have in my xorg.conf file, but I don’t know how exactly I know if it well configured or not :S :\

Do you have any slightest idea what is the maximum resolution you can run on Your monitor??

Try to run sax2 -r -l -m 0=nvidia

-l will set low resolution mode this might help You.

-m has to be at the end :slight_smile:

Yes my monitor’s maximun resolution is 1440X900 :slight_smile:

I think


xrandr

will return the possible resolutions and frequencies.

when I run the xrandr command I get this an “Can’t open display” error message :S

Use my xorg.conf

# /.../
# SaX generated X11 config file
# Created on: 2009-04-25T15:02:53+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dri"
  Load         "dbe"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "pl"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "12"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "A4 Tech PS/2+USB Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  340 270
  HorizSync    50-70
  Identifier   "Monitor[0]"
  ModelName    "1440X900@60HZ"
  Option       "DPMS"
  Option       "PreferredMode" "1440x900"
  VendorName   "--> VESA"
  VertRefresh  50-60
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "GeForce 8800 GT"
  Driver       "nvidia"
  Identifier   "Device[0]"
  VendorName   "NVidia"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
  Option       "Composite" "on"
EndSection

Just adjust places where your hardware differes, leave resolution as it is :slight_smile:

I can see now that when running sax it tries to set 1280x960 which your monitor can’t support.

Set everything by running as root sax2 -r -l -m 0=nvidia.

I’ve had weird little things like that happen before. I usually just drop to runlevel 3 (“init 3”) delete/rename /etc/X11/xorg.conf (so that there is none with that name) and then run sax2 and let it create a new one.

For a while now it has been able to see on its own that it needs to use the nvidia driver if installed. Just be sure to setup all the monitor stuff carefully.

I’m still having the same problem… I’ve done everything you’ve told me to do but when I try to start xserver I still get the same, a blank screen and later on, the monitor becomes idle :frowning:

i have had the same problems with the nvidia drivers, using an 8500 vid card, via yast and documentation it says use 180 version driver for 6xxx cards and up, not so, the 180 drivers seem to be for 9xxx series and up, use the 173 nvidia driver G01 i think it is called in yast, good luck :slight_smile:

Thats not true. I use 180.XX drivers for my 8400M GS. If you find that the nvidia drivers do not load in the kernel, try to uninstall them in “safe mode” using YAST. I sometimes had this problem when i installed the drivers in one kernel and tried to boot it in another kernel.

Just use YAST to install the 180.xx drivers in the kernel you want and that should work.

  1. change the runlevel to boot in console mode ( runlevel 2 )
  2. edit /etc/X11/xorg.conf and replace “nvidia” with “nv” in the device section
  3. install x11-video-nvidiaG02-180 and nvidia-gfxG02-kmp-default-180 (not the G01!) from Yast. It should replace back “nv” with “nvidia” in /etc/X11/xorg.conf
  4. start X or reboot in runlevel 3

If it doesn’t work (it happens sometimes), install the kernel sources and the kernel headers and get that file from Nvidia:
NVIDIA-Linux-x86_64-180.29-pkg2.run. Run that file in a terminal as root. It will compile the nvidia module for your kernel.

If you still have problem starting X, check /var/log/Xorg.0.log. It might provide some indications.

please try again adjusted his/her AFDB on Monday 18 May 2009 07:26 to write:

>
> 1) change the runlevel to boot in console mode ( runlevel 2 )

Runlevel 3 not 2

On boot screen of grub when the suse is selected just press 3 you will see
it appended to the line on screen this will boot to runlevel 3

HTH


Mark

Nullus in verba
Nil illigitimi carborundum

2 would have worked too (in most cases). But you’re right. Different distros have different concepts of runlevels 2-5 and I often get confused. I should have checked. Sorry.

please try again adjusted his/her AFDB on Monday 18 May 2009 13:26 to write:

>
> baskitcaise;1987569 Wrote:
>> Runlevel 3 not 2
> 2 would have worked too (in most cases). But you’re right. Different
> distros have different concepts of runlevels 2-5 and I often get
> confused. I should have checked. Sorry.
>
>

No probs,

We are not on debian/ubuntu now :slight_smile:


Mark

Nullus in verba
Nil illigitimi carborundum

Correct. Otherwise I would have said:

apt-get install nvidia-glx-180

:wink:

please try again adjusted his/her AFDB on Monday 18 May 2009 23:56 to write:

>
> baskitcaise;1987729 Wrote:
>> We are not on debian/ubuntu now :slight_smile:
>
> Correct. Otherwise I would have said:
> # apt-get install nvidia-glx-180
>
> :wink:
>
>

#zypper in nvidia-glx-180

not sure on the version number there though is missing it. but close enough
for jazz.

Less typing as well


Mark

Nullus in verba
Nil illigitimi carborundum