NVIDIA driver - problems


I recently installed open suse leap in my machine (KDE 5). After the installation I updated the system and added packman and NVIDIA repos using yast (community repos)

After the “sudo zypper instar inr”, I rebooted my system 3 times and my nvidia-settings keeps telling me: “You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root),”

I tried to run echo “blacklist nouveau” > /etc/modprobe.d/50-blacklist-nouveau.conf && reboot and the only thing I got was a system without KDE rs.

My notebook is an AVELL with NVIDIA GTX 960M.

In older posts I saw that this problem is very commun but could not find any good solution.

How can I solve this problem without break my system ?

Thank you !

You have what is kown as an Optimus graphic system this is a special configuration and must be treated special

2 ways

  1. Remove the normal NVIDIA driver (it breaks the Intel) and install bumblebee

  2. try this different method

Thank you for the answer.

I followed the instructions and tested the installation with the “optrun glxspheres” command. The output window was all those colorful spinning spheres and:

Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GTX 960M/PCIe/SSE2
308.780358 frames/sec - 344.598879 Mpixels/sec
311.886899 frames/sec - 348.065779 Mpixels/sec
311.944034 frames/sec - 348.129542 Mpixels/sec
311.461497 frames/sec - 347.591031 Mpixels/sec
311.582507 frames/sec - 347.726078 Mpixels/sec
312.173931 frames/sec - 348.386107 Mpixels/sec
311.694014 frames/sec - 347.850519 Mpixels/sec
314.326324 frames/sec - 350.788177 Mpixels/sec
312.269054 frames/sec - 348.492264 Mpixels/sec
311.965257 frames/sec - 348.153227 Mpixels/sec
309.865875 frames/sec - 345.810316 Mpixels/sec

After running the “optrun --status” the output was: “Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.” To turn it on I typed: “sudo tee /proc/acpi/bbswitch <<<ON” and the output was: “Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is on.”

As long as my “nvidia-settings” is not working anymore. How can I know if my nvidia graphics card is being used ?

Thank you !

Great, bumblebee seems to work fine on your laptop.
Bumblebee is a way to use the Optimus hardware, in order to use the energy efficient Intel graphics card for common desktop tasks and
to only switch on the heavy Nvidia graphics card, if really needed for i.e. gaming.
In common mode bumblebee will use the Intel graphics, the Nvidia card is switched off, thus sparing energy and battery lifetime.
You don’t have to switch the cards manually.
If you want to use the Nvidia graphics, you call the program, as user, with ‘optirun program’ and the program will use the Nvidia card,
bumblebee will take care of the powering on of the Nvidia card.
If you terminate the program, bumblebee will switch off the Nvidia card and then you are using solely the Intel graphics card again.

Thank you !!

For optimus sytems with bumblebee you start nvidia-settings this way:

optirun nvidia-settings -c :8

Thank you all for the answers.

I’ve installed nvidia toolkit (nvcc) in the past but now that I have everything working fine in my system, Is there any special procedure to install nvidia toolkit in optimus systems ??

Thank you all !

The major difference in nvidia-bumblebee and regular driver is that it use the default mesa (I believe) where as the regular replaces mesa. So I’d guess it would be ok if it does not replace or need the mesa files provides by regular

So its safe to install the open suse local installer *.run available at: https://developer.nvidia.com/cuda-downloads ??

thank you

Just to register the tip. Everything worked fine ! I managed to install the cuda toolkit using the official repo and than running “sudo zypper install cuda”. After setting the environment variables to the correct cuda path I was able to compile the code with nvcc.

The only thing that changes from a default system (without OPTIMUS) is the running procedure. In a default system we run “./my_cuda_program” in optimus system I needed to run “optirun ./my_cuda_program”. In cuda 7.5 I was able to do everything without the symbolic link creation described in: http://www.astro.iag.usp.br/~leonardoags/linux.html

Thank you all !!