Nvidia driver problems with new kernal

Hi all

I am in need of some help. I have just installed 11.1 on my machine and am having trouble finding a graphics driver that will work!!!

My system is an Intel(R) Pentium(R) D CPU 3.00GHz X86_64
I have got kernel-default installed at the moment and I’m looking for a driver for my Nvidia Quadro FX 1300.

I have been down the road of loading the nvidia ftp site as my repo and then looking for the relevant driver through YaSt but it throws up the following error message:

“nothing provides kernal(default:vmlinux) = f30985aa0d58b1bd needed by nvidia-gfx-kmp-deefault-96.43.10_2.6…”

So I tried to do it the ‘Hard way’ by compiling the source code from the Nvidia driver downloads.
I tried all three versions of the Legacy driver there:
Latest Legacy GPU Version (71.86.xx series): 71.86.06
Latest Legacy GPU Version (96.43.xx series): 96.43.07
Latest Legacy GPU Version (173.14.xx series): 173.14.12

and none of them finished the install saying that the kernel could not successfully be built and that I should check the nvidia.comm page for a readme on the errors??? (and before anyone says it I DO have the correct compilers loaded…gcc, make etc)

I do know that the card drivers are a little old but it would be really sad not to be able to get it working as I would have to go looking for another distro that has a kernel that I can install the driver on!!

Thanks in advance for any suggestions

How about trying the easy way with the one click


Ok… well I just tried that and the good news is that the driver seems to load… well at least it is compatible with the new kernel :slight_smile:
The bad news is now X has crashed and will not load. There seems to be a problem with the xorg.conf file!!!

It throws up the following error in the terminal when I restart X-window:
Fatal server error:
no server found
giving up
xinit: connection refused (errno 111): unable to connect to xserver
xinit: No such process (errno 3): server error

How can I get x open again???

Please help!!!

I guess I can boot with disk and then repair the install but does anyone know how to fix the cause of the problem??

Ok… got back into X using the vesa driver but still trying to get the real thing loaded!!

You could try this first in a console as su type **
sax2 -r -m 0=nvidia**
then nvidia-xconfig
and lastly nvidia-settings where you will be able to set your resolution and save to xconfig

Hope this helps


Ok… so I managed to get this to work eventually.

The one click install fromt he Nvidia site did not work at all and ended up crashing X-window because the xorg.conf was overwritten in a funny way???

Thanks very much to Geoffro for your help.

The way I got it to work was to go into the nvidia ftp site ftp://download.nvidia.com and then look under the Xfree 86 section and then look for your platform.
Download the source code for the relevant driver and save it somewhere like /home/user/whatever you want/

Make sure that ALL other nvidia driver are uninstalled via YaST GUI (this one hung me up as I missed one of them inbetween testing out different drivers)

Then drop back down to run level 3 and compile the kernel. Once the nvidia installer has finished run “sax2 -r -m 0=nvidia” and then set the display settings that you want to use.

And viola… it works now :wink:

Great glad you got it working :slight_smile: