I have done a basic installation for a server.
And then I have removed the screen and the keyboard because I have no place for them so my server is blind.

I manage the server from my laptop using NX.
I am using the root user because I can’t stop the server with a normal user.

I have installed the nvidia driver with the one click method.

I have used my television set as screen and configured a basic monitor :
Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option “DPMS”

Before removing screen and keyboard, I have configured some parameters with the nvidia control command panel.

Now without the monitor, the video fan is very noisy.
When I click on the nvidia X Server settings button I get this message :

“You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.”

It seems that the driver does not load because it does not found any monitor.

Any idea to set up the driver ?

Thank you for your help.

I think this is what you want/need


Note that his article early on addresses the reasons for your noisy fan, then down a ways it also describes in a somewhat vague way (but maybe has to be that way) how to configure a Headless X Server for an nVidia card. If you’ve updated to the latest GPU, I think the CuDA drivers might still be included in the default nVidia driver(CUDA support is being removed any day now), otherwise you may have to go to the nVidia site, download the CUDA SDK and install.

Repeat Note: This link is relevant <only> to nVidia GPUs and requires video drivers with CUDA support.

I wonder if it might just be easier to remove the nVidia card…


Before going further, have you understand that my probleme is because I must remove the monitor and then it seems that the driver does not load?

anyway I am going to read your article.

Thank you for helping.

OK that looks like what is said in the article.

I have to re-read it because english is not my first language.

1°) So I supose that I reconnect my TV ( used as a monitor )
2°) I apply what is said in the article
3°) and pray

I will give you news.


Not working.

The nvidia driver don’t load if I remove the monitor (and I want to remove it).


My card is 6800 GS.

Did you follow the article’s instructions to modify the xorg.config file?

From the article

Section "Screen"
    Identifier     "Screen0"
    Option         "UseDisplayDevice" "DFP-0"
    Option         "ConnectedMonitor" "DFP-0"
    Option         "CustomEDID" "DFP-0:/etc/X11/dfp-edid.bin"
    Option         "Coolbits" "5"
End Section

I could not use EDID function because my monitor does not understand these functions.

But now it’s working. Just a misspelling parameters in xorg.conf.

For peoples interesting in :

== Begin =======================================================

1°) Put a monitor during the configuration and stop the system, and reboot

2°) At startup in the grub menu, type number → 3 (boot in level 3)

3°) rename /etc/X11/xorg.conf to /etc/X11/xorg.conf.sav

4°) Xorg -configure (to make a new /etc/X11/xorg.conf )

5°) Edit if necessary all needed parameters that is not in the new xorg.conf file
[INDENT]In my case : Option “metamodes” “1024x768_75 +0+0”
to fix the screen definition [/INDENT]

6°) verify that parameters names match in all the script :
Section “ServerLayout”
Identifier “Layout0”
Screen 0 **“Default Screen” **0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”

Section “Monitor”
Identifier "Configured Monitor"
VendorName “Unknown”
ModelName “CRT-1”
HorizSync 37.9 - 60.0
VertRefresh 60.3 - 75.0
Option “DPMS”

Section “Device”
Identifier "Configured Video Device"
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce 6800 GS”
BusID “PCI:1:0:0”
Option “IgnoreEDID” “true”

Section “Screen”
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

 DefaultDepth    24
 Option         **"ConnectedMonitor" "CRT"**
 Option         "TwinView" "0"
 Option         "metamodes" "1024x768_75 +0+0"

SubSection     "Display"
    Depth       24


7°) stop the system

8°) remove the monitor

9°) Reboot.

10°) manage the server from another system.

=== END ======================================================