Nvidia-driver not working Suse11,KDE4, onboard-GF7050

Hi!

After Suse11 and KDE3.5 worked fine on my 1st PC i tried to run the same on the 2nd PC. (does anyone know where i can get a CD-image with Suse11 AND KDE3.5 ? I only find KDE4 :frowning: )

I installed the nvidia proprietary driver as described in the Wiki (Protokoll: HTTP, Servername: download.nvidia.com etc. - then install “x11-video-nvidia”)

In YAST all was OK, installation finished without error.
But after new login there was no nvidia-logo and it seems to me that there is the old vesa-driver running :frowning:

So i tried in runlevel3 “sax2 -r” to config the driver, but got an error-message (no screen found, look in var/log/sax.log)
In the sax.log i cannot find anything that helps me.

Motherboard: asrock alive-NF7G…SempronLE1150

Any idea, what is wrong?
I you need more information from me, please ask and tell me where to get it, this are my first (or second) steps with linux.

Parts of sax.log (to much for posting all):


...
10-Aug 14:00:26 <I>  Sysp: 3D detection data
	Card3D0   =>  Install    : <none>
	Card3D0   =>  Remove     : <none>
	Card3D0   =>  Packages   : <none>
	Card3D0   =>  Active     : 0
	Card3D0   =>  Answer     : no
	Card3D0   =>  ScriptReal : <none>
	Card3D0   =>  ScriptSoft : <none>
	Card3D0   =>  Flag       : NVReal
...

...
(II) Setting vga for screen 0.
	(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
	(==) NVIDIA(0): RGB weight 888
	(==) NVIDIA(0): Default visual is TrueColor
	(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
	(==) NVIDIA(0): Using HW cursor
	(**) NVIDIA(0): Enabling RENDER acceleration
	(==) NVIDIA(0): Video key set to default value of 0x101fe
	(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
	(II) NVIDIA(0):     enabled.
	FATAL: Module nvidia not found.
	(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
	(EE) NVIDIA(0):  *** Aborting ***
	(II) UnloadModule: "nvidia"
	(II) UnloadModule: "wfb"
	(II) UnloadModule: "fb"
	(EE) Screen(s) found, but none have a usable configuration.
	
	Fatal server error:
	no screens found
]

xorg.conf:

# /.../
# SaX generated X11 config file
# Created on: 2008-08-10T11:46:17+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "de"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
  Option       "XkbVariant" "nodeadkeys"
EndSection


Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "5"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImPS/2 Logitech Wheel Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  Option       "CalcAlgorithm" "XServerPool"
  DisplaySize  260 195
  HorizSync    30-65
  Identifier   "Monitor[0]"
  ModelName    "102020"
  Option       "DPMS"
  Option       "PreferredMode" "1024x768"
  VendorName   "BELINEA"
  VertRefresh  50-120
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
EndSection


Section "Screen"
  SubSection "Display"
    Depth      16
    Modes      "default" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "Device"
  BoardName    "Framebuffer Graphics"
  Driver       "fbdev"
  Identifier   "Device[0]"
  VendorName   "VESA"
EndSection



Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection

Section "Extensions"
EndSection


magiceye, I think you may have installed the wrong NVIDIA driver. In the NVIDIA repository, there are two drivers; one is for older hardware and the other is for newer hardware. If you installed “x11-video-nvidia” then you installed the driver for older hardware. Go into software management in YAST and un-install “x11-video-nvidia” and “nvidia-gfx-kmp-…”. After that, search for the “x11-video-nvidiaG01” driver and install that one. The appended “G01” means it’s the new driver. This should make your video card work with suse. Hope this helps.

Hm, i was sure to have choosen the …G01.
Next time i will double check this.

But 2 hours ago my Samsung HDD did only “KLACK-KLACK-KLACK…” instead of booting and the Samsung testing utility (HUTIL) gave me error-messages on every sector - so i think the harddisk is death…

Is this a new drive or an older one?

Its 4 years old (SV0802N) and worked fine until yesterday. No real loss, there were only fresh installed Windows2000 and Suse11 on it, no important data.