Nvidia driver kills my KDE

I have opensuse 11.1
I want to install my nvidia 8400gs driver.
I go to this page: es.opensuse.org/NVIDIA - openSUSE
Then I install it, but when I restart the computer… :eek: I got only terminal.
No KDE :confused: :?
I didnot know what to do. I am new in Linux
I reinstall my Suse again. Then I try install my nvidia driver again, and… the same
No KDE, only terminal
I try something like init 5, or startx,
but nothing helping
Ok, I insatalled opensuse again. Now I have opensuse and KDE, but I dont want to try again installing nvidiA DRIVER again. Please for helping

It’s a lot easier for people to help you if you keep one thread going. That way they can see what you’ve already tried. You’re going to get the same advice repeatedly by starting new threads about the same topic. You never answered the questions I had for you in your other thread about this, and here you are asking again in a new one.

Have you tried adding the Nvidia repo and installing through Yast?

No, I didnot
Is that diferent then NVIDIA - openSUSE ???

I am sorry if I repeated sime thread
Ask me whatever and I will try to answare you.
Thank you for helping

Yes it’s different, easier and as far as I know, it’s recommended.

  1. Start “Yast”
  2. Start “Software Repositories”
  3. Click “Add”
  4. Select “Community Repositories”
  5. Click “Next”
  6. Select “Nvidia Repository”
  7. Click “OK”
  8. “Import”
  9. Click “OK”
  10. Start Software Management"
  11. Type “nvidia” in the search box
  12. Driver should be preselected, click Accept
  13. Reboot

This is the extent of my knowledge.

Are you updating everything after you install openSUSE? That may make a difference. If you are still at the point where you have done a fresh install and have not yet tried installing the drivers, I would recommend a full system update. Then try installing the drivers through the previously mentioned methods (repos or 1-click). If that does not work, attempt a manual install.

To do a manual install, you will want to follow the directions located here.

Basically, you download the driver file from the Nvidia website, log out of KDE and go to runlevel 3. Then you run the script which will prompt you through the rest of the process. Try this and see if it makes any difference for you. If you continue to have problems, then we will continue troubleshooting.

To markcynt:
We have tried that process, as well as the 1-Click install, and he continues to have the same problem. That was why I was recommending he not start several new threads about the same issue. If you have any further suggestions beyond a manual install, I’m sure we would both be happy to hear them.

Thank you very much
I will try now
Just tell me what I have to do, if restarting the PC, I get only terminal

Ok, now I’m a little confused at this point. Just to make I am caught up here, I know you have tried the 1-click install. Have you tried the repository install as markcynt suggested? I was under the impression that you had, but it looks like you are saying you haven’t. You should try that before doing a manual install (the method I just described in my last post). Otherwise, continue on with the manual install and see if that works for you.

Have you had any luck getting this working?

hello I just install the nvidia drivers and my screen just keeps on flickering is there a way to fix this my grafix card is a geforce 6100 and I installed the driver with yast.

I’m not sure what might be the cause of that. You might want to try starting a new thread, since it is a new problem. Glad to hear you got it at least partially working.


I have the same problem. I couldn’t install the NVIDIA-driver
with Yast from the NVIDIA repository, since it offered only drivers for GeForce-cards. I have a Quadro FX 2700 M on a brand new Thinkpad W700.
With the 1-click it’s the same, I think. It sounded like it was
only for GeForce cards.
So I downloaded the driver from the NVIDIA-page and installed
it. But somehow my kernel was changed during this
process. First it worked fine, but after the reboot, it was a
mess. The mouse, the internet didn’t work anymore, Yast2 also not.
I tried to ,repair’’ the system with the installation CD,
but Yast still doesn’t work and the graphics is back to 800x800.
What to do?

Hi again,

the 1-click-installation does work for the Quadro FX 2700-card ! It was a little bit hidden, and in the NVIDIA-repository it was not shown at all (only the GeForce-models were mentioned).

Let’s revisit this previous help. What was the outcome of you trying to do the init 3 install? This should have worked. If it didn’t you would either get errors during the install and have a log. If the installation succeeds but you still do not have video it is probably an bad/incompatible video card.

Card not supported by official drivers? Download from here
32bit : ftp://download.nvidia.com/XFree86/Linux-x86/190.25/NVIDIA-Linux-x86-190.25-pkg1.run
64bit : ftp://download.nvidia.com/XFree86/Linux-x86_64/190.25/NVIDIA-Linux-x86_64-190.25-pkg2.run

Those links weren’t working for me for some reason. Maybe a firewall here at work. But I was looking at your VGA version and the support list. Yours should work with the 185.18.36 driver here:

32-bit: http://www.nvidia.com/object/linux_display_ia32_185.18.36.html](//www.nvidia.com/object/linux_display_ia32_185.18.36.html)

64-bit: http:NVIDIA DRIVERS 185.18.36


Hey guys,

I’ve been dealing with a similar issue for the past few weeks. I thought it was my video card because ubuntu got screwed up somehow as well. But its not. If I install it from opensuse/nvidia the screen gets screwed up. Same thing happens if I manually add the repository (at least on the last card). I guess next step would be the full driver install from scratch. I’m also waiting to hear from my buddies that work for Novell. If I find an easy fix I will post.

Also I might point out the most frustrating thing about troubleshooting this is having to reformat every time the drive screws up. Is there an easy way to roll back from cmd?

  • Thomas


>Let’s revisit this previous help. What was the outcome of you trying to >do the init 3 install? This should have worked. If it didn’t you would >either get errors during the install and have a log.

I did the init3 install. It worked, and I had a good screen resolution.
But after the reboot my system was messed up, like desribed above.
During the installation I was asked whether my kernel could be modified
and I agreed. Here something seems to go wrong.