nVidia driver issues (nForce2)

My brother’s PC is rather old, and it’s a nForce2 based computer (AthlonXP 2800+, 512MB of RAM). The install goes perfectly, and everything runs smoothly, but I’m having one issue that I am having a bit of trouble figuring out.

The IGP seems like it is not being recognised. When I go to the display settings, it just says “Default monitor”, and the refresh rate is 60Hz. On a CRT, that is unbearable to my eyes. I figured nouveau would be running, so it wouldn’t happen, but I couldn’t tell if it was, due to that issue. I also installed the official nVidia legacy drivers, and had that same issue.

Is there anything I need to do in regards to this issue? I’m sure the nVidia legacy drivers don’t support the version of Xorg on 12.3, but I’m at a loss here, since I figured nouveau would support it very well.

Edit: I forgot to mention that I installed the official nVidia drivers through Yast.

Which driver did you install?
The nForce2 chipset contains a GeForce4 IGP so you would need “x11-video-nvidia”. I can’t tell you though how well that works nowadays…

To see what driver you are really using, it would be nice if you could post the contents of the file /var/log/Xorg.0.log

I installed x11-video-nvidia, along with another nvidia driver. I believe it was 77 series that was offered by the nVidia repo in Yast. Though, that was quite some time after the install, and I had the same problem with being unable to change the refresh rate & resolution before I installed the official nVidia drivers. Neither solution gave me anything other than default monitor, 60HZ.

I don’t have access to the PC at the moment, but I’ll try and get on it soon.

Edit: I’ll try installing Mesa-demo-x, so I can get access to glxinfo.

You shouldn’t install two different nvidia drivers at the same time. That won’t work!Please remove all of them and just install x11-video-nvidia, the 77 series won’t work anymore since quite some time anyway (doesn’t support the newer Xorg)

I figured it wouldn’t be a problem, since Yast decided to install them both when I selected the official nVidia driver. I’m going to reinstall from scratch to teach my brother about installing SuSE on his own, so I’ll be sure not to make that same mistake next time. I’ll report back with results soon. Thank you for the help.

Edit: I have a decent amount of experience with Linux, but not on legacy hardware. Funny how I have no problem doing all sorts of complicated stuff on my PC, but an old one has me baffled.

Are you sure you’re talking about the 77 series driver then? It’s not available an any repo that I know of.
But the driver comes in two packages (one for the kernel module and one for the X driver), maybe you mean that?
You need both:

nvidia-gfx-kmp-desktop (or nvidia-kmp-default, depending on which kernel you are using)

The nouveau driver should work good enough work for basic stuff. Experimental 3D support is available but not included in the standard openSUSE distro. (well, it didn’t work at all anyway, when I tried it on my GeForce4 card a few years ago ;))
And there’s also the ‘nv’ driver which supports basic 2d hw acceleration on this chipset, no 3D though. (I remember using that years ago).

But your low refresh rate could also be because the driver can’t determine the monitors max. resolution (bad cable, monitor doesn’t support EDID, …). You would have to manually add a desired modeline to the Xorg config then. That’s why I suggested you post your Xorg.0.log…

Yeah, what you have listed below is what I installed. And I’ll get the log soon.

There is a bug in the nouveau driver impacting FX5200 graphic hardware commencing with the 3.7.x kernel impacting all GNU/Linux distributions. I do not know if this is relevant to your brother’s PC, but it might be.

There is a thread about this problem (started by me) in this thread:

Note an openSUSE kernel developer/packager has debugged the problem, and an openSUSE-12.3 kernel update (when it comes) should have the fix. In addition if one sticks with the stock kernel, there is a kernel update in the bug report that one can use. Its all noted in the thread I referenced.

See posts #45 (for link to kernel where FX5200 works) and post#48 and note bug report: https://bugzilla.novell.com/show_bug.cgi?id=800686 where the problem is noted as resolved. Its difficult to tell in advance exactly when the fix will generally appear. After the update is out, it is another matter.

Note comment #15 in the bug report I raised: https://bugzilla.novell.com/show_bug.cgi?id=800686 which refers to build service updates for the openSUSE kernel : https://build.opensuse.org/request/show/172496

IMHO one simply needs to download (but not install) any kernel update rpm, and then check the change history that is inside the rpm, and from that one should be able to read if that kernel has the fix.

Note both the ‘nv’ and ‘vesa’ graphic drivers still work with the FX5200 (albeit performance/resolution not so good) even with this bug. Also note that the nouveau driver works in the test kernel in the bug report I raised. wrt the proprietary nVidia driver on the FX5200 with openSUSE-12.3 I noted this in a blog post of mine: https://forums.opensuse.org/blogs/oldcpu/nvidia-173-14-36-graphic-driver-nvidia-nv34-fx5200-graphics-device-3-7-x-newer-kernels-125/

Your brother’s PC graphics may be different, so its not clear to me how much, if anything is relevant .

But do note that it states in the openSUSE-12.3 release notes that for the proprietary nvidia driver it is necessary to add group video to your brother’s PC’s users’ accounts.

On openSUSE-12.3 there was an update to the kernel to version 3.7.10-1.4. I note this from the change log:

* Thu Apr 04 2013 jslaby-at-suse.cz
- drm/nouveau: Fix typo in init_idx_addr_latched() (bnc#800686).
- commit 3bb7a0d

so if you install the updated kernel, that may fix the problem you have been observing with the nouveau graphic driver (I don’t know enough to answer any proprietary nvidia driver questions at this time (with your brother’s PC’s legacy hardware)). The fix worked for me with the nouveau driver.