Nvidia driver intermittent IRQ error and freeze on boot.

I get a freeze during boot that I think is caused by this:

    30.813] (EE) NVIDIA(GPU-0): The NVIDIA kernel module does not appear to be receiving
    30.813] (EE) NVIDIA(GPU-0):     interrupts generated by the NVIDIA GPU at PCI:2:0:0. 
    30.813] (EE) NVIDIA(GPU-0):     Please see Chapter 8: Common Problems in the README for
    30.813] (EE) NVIDIA(GPU-0):     additional information.

The freeze gives me a blank screen with cursor but completely unresponsive to anything other than hard reboot.

The readme (here https://download.nvidia.com/XFree86/Linux-x86/384.59/README/commonproblems.html ) says its IRQ relate but when I look for one with lsdev it seems fine - but then I can only run lsdev when its booted.

How can I find the cause of what seems to be an intermitted IRQ problem given it stops booting?

Thanks for any help. I cannot figure this out at all.

Please provide more info.
Does it works before?


inxi -Gxx

The output if inxi is

Graphics:  Card: NVIDIA GK107GL [Quadro K600] bus-ID: 02:00.0 chip-ID: 10de:0ffa
           Display Server: x11 (X.Org 1.20.3 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: Quadro K600/PCIe/SSE2
           version: 4.5.0 NVIDIA 430.34 (compat-v: 4.6.0) Direct Render: Yes

I have not had the problem in the last few days so its possible that a recent driver update date had fixed it. I usually only reboot once a day so it could just be luck.

It has started happening again.

Same message in the logs. Still intermittent. I have enabled SysReq keys so I can see if that gives me a cleaner reboot.

I would:
Delete all nvidia-driver-pacckages from Repo, disable the Repo, download the latest nvidia-driver from here:
make the driver executable (chmod +x), boot to Runlevel 3 (multiuser.target) and install the downloaded driver.

I have got a few upgrades since the above, and the driver is the same version as the latest on the download page. Is it still worth trying installing manually?

Are you using AMD hardware?
Possible issues with a IOMMU.

Changing videocard can easy solve your problem.

Ty - In BIOS change iommu to software rather then hardware. This helped my iommu problems.

It turned out to be pretty much that, but not quite.

I had disabled interrupt remapping (VT-D) because I knew there were issue with it, but the driver picked up that there were problems and worked around them.

Re-enabling it made the problems go away.

I do get an occasional “graphics restart” or two in KDE after wake from suspend, but it recovers in seconds so is just an irritant (especially as the machine is a desktop).

Thanks for help.