nvidia driver installed, but has no effect

Hi again guys,
This is a follow up post to an earlier one I made (here is the link: Cannot install nvidia driver - openSUSE Forums)

I have apparently managed to install the x11-video-nvidiaG01 driver using the one click install. However, if i then go into init 3, type sax2 -r -m 0=nvidia (or just sax2 -r, as per instructions on website), sax2 appears to load, but then aborts with the message ‘could not start configuration server’.

The driver appears to be installed in yast, but the xorg.conf file still says the driver is ‘nv’, not nvidia, and no opengl application work (i.e. glxgears, chromium bsu, and i cannot enable desktop effects using simple-ccsm). What could be the matter? Thank you all very much!
Taylor

Probably a stupid question, but did you get both files? The Nvidia driver consists of two RPM files that you have to install.

well, don’t trust too much and check your xorg.conf file. the specified driver should’t be mesa or vesa or something else as nvidia. By the way, if you plane installing compiz or opengl games, you should install the original nvidia driver, avalable by nvidia.com. In this case, don’t connect using konqueror but rather firefox.

Hi guys. yes I installed both files…there other one is installed because of dependacy issues and both yast/the one click installer take care of it.

I have also tried installed the one on the nvidia website, init 3, sh NV…run, etc etc. But that aborts as well, see the other post (linked to above) to see the error it gave. Thanks though,
Taylor

Is that 7700 a new-ish Nvidia graphics chip? Sometimes, driver support is slow to catch up in Linux. I will look into this. Sometimes Nvidia will release a beta driver for use with newer graphics cards that are not yet supported by the regular driver.

Also, are you using the 64 bit driver? I think you said you had 64 bit Suse installed. If so, you need to use the 64 bit driver.

From the Nvidia Linux driver website:

"Be sure to check the list of supported notebook manufacturers and models to ensure compatibility after we redirect you to the driver download page. Your notebook model may not be supported by this driver.

The GeForce M series and GeForce Go series notebook GPUs use drivers that have been customized by the notebook manufacturers to support hot key functions, power management functions, lid close and suspend/resume behavior. NVIDIA has worked with some notebook manufacturers to provide notebook-specific driver updates, however, most notebook driver updates must come from the notebook manufacturer. Additionally, the desktop GeForce graphics drivers will not install on Geforce M series and Quadro M series notebook GPU’s."

So your chip may not be supported in Linux (yet). I looked on the list of supported products, but could not find the 7700 listed. So this could very well be your problem.

I bought an Nvidia 7950GT card right after it came out and had to wait a while for a Linux driver that worked.

Hi again,
This is an upgrade from opensuse 10.2. The graphics card was fine there, I’m quite certain the driver worked. The card is not new, more than a year old and the driver from the nvidia site that i used in opensuse 10.2 was NVIDIA…169.12.pkg2.run, or something like that. oh ya and it was for x86_64, which is correct. However, when I try to run that installer now, it aborts due to some error: unable to build kernel module, or something.
So it has worked before.

Wow, I’m really stumped. I believe there was a change in the version of xorg after 10.2, which might account for the difference in the driver working in 10.2 but not in 11. When 10.3 came out a lot of people were having video problems because of this change.

About the only thing I could suggest is to try the 32 bit version Open Suse 11, but I am really stumped here. Very strange.

Usually when you get errors like you describe with the installer, it’s due to dependencies missing, but I believe you said you installed those.

Hi
You need to install the kernel-source and development tools;


sudo zypper in kernel-source
sudo zypper in -t pattern devel_basis

Then run through the install and sax2 again at runlevel 3


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 2 days 7:04, 1 user, load average: 0.27, 0.27, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hi,
the kernel-source package is already installed, i made sure of that when i installed gcc and make in order to manually install the driver the first time i tried.
the pattern devel-basis is something i have not heard of. zypper says there is no such package, and i can’t find it anywhere in yast under packages OR patterns. are you sure it’s necessary, whatever it is? it’s the first time i’ve heard anyone mention it.

Thanks again for everyone’s help! Here is my /var/log/SaX.log file. No one asked for it, but I might as well…(actually i’m only including the beginning and bottom part, since it’s usually most important)

/*************
SaX2 log : SaX2 version 8.1 - SVN Release: 1.49 2003/03/17


SVN RELEASE : 1623
:
DESCRIPTION : X11 configuration log file to collect information
: about detection, startup and configuration.
: There are three parts of logging:
: —
: 1) INIT ( detection, 3D )
: 2) STARTUP ( xorg.conf, X11 log, glxinfo )
: 3) CONFIG ( config actions )
: —
:
VERSION : SaX2 compiled for: [openSUSE 11.0 (X86-64)]
PARAMETER : -r -r
:
LOG DATE : Mon Sep 22 18:52:50 EDT 2008
*************/

Framebuffer Info:

Framebuffer is active

22-Sep 18:52:50 <I> Initializing…
22-Sep 18:52:52 <I> Sysp: Mouse detection data
Mouse0 => Protocol : explorerps/2
Mouse0 => Device : /dev/input/mice
Mouse0 => Buttons : 10
00000000 - 0x000000ff (0x100) IX**

(then it goes on and on…)
(finally:)
[21] -1 0 0x0000c800 - 0x0000c8ff (0x100) IX**
[22] -1 0 0x0000ffa0 - 0x0000ffaf (0x10) IX**
[23] -1 0 0x000001f0 - 0x000001f0 (0x1) IX**
[24] -1 0 0x000001f0 - 0x000001f7 (0x8) IX**
[25] -1 0 0x000001f0 - 0x000001f0 (0x1) IX**
[26] -1 0 0x000001f0 - 0x000001f7 (0x8) IX**
[27] -1 0 0x0000e480 - 0x0000e49f (0x20) IX**
[28] -1 0 0x0000e800 - 0x0000e81f (0x20) IX**
[29] -1 0 0x0000e880 - 0x0000e89f (0x20) IX**
[30] -1 0 0x0000ec00 - 0x0000ec1f (0x20) IX**
[31] -1 0 0x0000bc00 - 0x0000bc7f (0x80) IX**(B)
[32] 0 0 0x000003b0 - 0x000003bb (0xc) IS**
[33] 0 0 0x000003c0 - 0x000003df (0x20) IS**
(II) Setting vga for screen 0.
() NVIDIA(0): Depth 24, (–) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(==) NVIDIA(0): Using HW cursor
(
) NVIDIA(0): Enabling RENDER acceleration
(==) NVIDIA(0): Video key set to default value of 0x101fe
FATAL: Error inserting nvidia (/lib/modules/2.6.25.16-0.1-default/weak-updates/nvidia.ko): No such device
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: “nvidia”
(II) UnloadModule: “wfb”
(II) UnloadModule: “fb”
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

]****************************

Hi
That’s the base development pattern in YaST. Like I normally say, have
never been a fan of the 1-click and that’s because it never seems to
work for me when i have tried, I’ve always just used the ‘hard way’
from the Nvidia page (http://en.opensuse.org/Nvidia) plus when I
started with the nvidia drivers, there was no 1-click :slight_smile:

I would disable the Nvidia repo and also remove the files installed by
it and use the ‘hard way’.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 2 days 7:39, 1 user, load average: 0.00, 0.07, 0.11
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12


Hey Malcolm, this is a tough one. With the one-click drivers, there is still the possibility of a mismatch between Nvidia driver version and Open Suse kernel version, so that’s one possibility.

Missing dependencies is another possibility, but AFAIK, you don’t need to install the kernel development stuff just to install one-click drivers.

Lack of support in Open Suse 11 for his 7700 mobile graphics chip using currently available drivers is another possibility.

And remnants left over from previous attempts to install other drivers could also be the culprit.

If it were me, I would just do a reinstall at this point and install the correct dependencies and attempt to install using the Nvidia installer “the hard way”. And avoid any kernel updates until the Nvidia driver is working.

My $.02.

Hi
It sure is… sigh

To the OP, what is the output from the lspci command just to confirm
the video card and check the 10de hex code eg;


/sbin/lspci -nnv |grep VGA

I would also be tempted to try one of the beta Nvidia drivers, but as
foresthill says a re-install may be the quickest easiest way to get
things back to normal.

You may be stuck with the default nv driver until one is made for your
card.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 2:26, 1 user, load average: 0.65, 0.34, 0.21
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Hi guys. Sorry I’m late. Here is that output:

taylor@tjlaptop:~> /sbin/lspci -nnv |grep VGA
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce Go 7700 [10de:0397] (rev a1) (prog-if 00 [VGA controller])

In yast, uner hardware > graphics card and moitor, it recognizes that there is a 7700 card, but still can’t install the driver.

I don’t really understand how the card could not be supported. Is it common that when updating an OS, novell may not include support for a card when it was supported in the previous version? i mean, lots of people have this card, and it’s newish, but certainly not cutting edge that drivers wouldn’t exist. Sounds strange to me.

I tried a reinstall of the upgrade already. When that didn’t work, i wiped everything, installed opensuse 10.2 then immediately upgraded to 11. when that didn’t work i reupgraded to 11 again (even though it was already installed…i figured it would fill in any gaps). Any last suggestions?

It’s Nvidia that has to provide proper support for your card. Novell already supports your chip with it’s “nv” driver, although you probably don’t have any 3D support, just 2D, I would imagine.

With my GT7950 card, even after it was supported, I still had to use a particular method to install the driver, IIRC downloading the RPM files and then installing them from the desktop manually thru YAST. And there was only one certain version of the driver that worked correctly (100.xxx something).

If I ran the Nvidia installer, I would just get error messages similar to what you are reporting.

My point is, you may need to try different versions of the driver before you find one that works. Hopefully there is someone else using your same card having the same problem as you, who has posted a solution.

Maybe there is a beta driver you could try. I will look around, and you may want to do the same. Good luck, and I think there is probably a solution out there, it just may take some time to find it.

I fought with my card in 10.3 for a week or 10 days before I finally found a solution.

SWEET MOTHER OF CHRIST!
I tried a different driver on the nvidia website, wasn’t ‘supposed’ to be compatible, but my god.
now i see what i was missing…what was supposed to be there all along. jesus.
thanks for everything guys!

no who wants to help me with my soundcard…

Wow! Hey, I know the feeling.

It’s almost a dissapointment when you finally solve a big problem like this. How do you fill the void in your life left by winning your epic “battle with the penguin”? How do you spend all the time that would otherwise be devoted to fighting your former problem?

I’m sure you’ll get over it.

Old CPU is really good with sound problems. Start another thread and hopefully he will jump in.

Oh yeah, cheers and congratulations on your triumphant victory.

Hi
Excellent news, now remember what you did, because when the kernel is
upgraded you will have to do it again!! :slight_smile:

If you head over to the application->multimedia section, user ‘oldcpu’
is the sound guru :slight_smile:

Now make sure you read the sticky “Welcome to multimedia sub-area”
first.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 1 day 11:49, 2 users, load average: 0.56, 0.62, 0.28
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Just thought I’d post my two cents. My old NVidia 7600GT died the other day. 5 capacitors randomly blew out. Anyways I purchased a new 9500GT to replace it.

After install I had some config problems with dualhead so I updated nvidia drivers through 1-click-install in the usual fashion. To my dismay this broke my x-server. I could get sax2 to run but every time after saving the config file x wouldn’t load. I got the same errors as you.

After 2 hours I gave up and reinstalled SuSE 11.0. I had only recently installed it anyways so it wasn’t a big deal. After install I first did online-update and updated everything to current. I then again did 1-click-install for NVidia. SAME THING. No more X.

**After some more reading it did appear that the problem was due to an error in the 1-click-installer. People reported a driver / kernel version mismatch. ** Several people reported that the solution was to download the drivers from the NVidia site and complile from source. I attempted this on a clean load of SuSE 11.0 and it worked perfectly. I then used grub to boot into my old broken installation to attempt to salvage it. I followed the exact same procedure compiling and installing the driver from source but it did not fix my broken distro.

Summary: Something in the 1-click-install NVidia destroyed x and I could not recover it by installing the drivers from source.

My Fix: - Clean load of SuSE 11.0
- Update everything
- Install kernel-source, binutils, gcc, gcc-c++, make
- Download NVidia x64 driver
- install it with sh <NvidiaDriver>.run
- configure x with sax2 -r -m 0=nvidia

Now I’m just scared to ever use 1 click install again for nvidia drivers. =)