NVidia driver installation fails

With a freshly setup and updated 11.2 and the NVidia repository added the installation fails apparently due to a wrong version number yast tries to download (190.42 while on the download site there is just a 190.53-9.1).

Getting nvidia-gfxG02-kmp-desktop-190.53_2.6.31.5_0.1-8.1.x86_64.rpm and x11-video-nvidiaG02-190.53-9.1.x86_64.rpm directly from the site, an rpm installation fails with

error: nvidia-gfxG02-kmp-desktop-190.53_2.6.31.5_0.1-8.1.x86_64.rpm: rpmReadSignature failed: region trailer: BAD, tag 15872 type 2047 offset 28672 count 4238
error: nvidia-gfxG02-kmp-desktop-190.53_2.6.31.5_0.1-8.1.x86_64.rpm cannot be installed

So how it is supposed to work?

I did not try to follow the hard way yet, because that was written for 11.0 and 11.1, but with 11.2 the xorg.conf seems to be out of order and the whole handling changed in an incompatible way. Does anyone know where to find a documentation or HOWTO about the new system?

I already miss the middle mousebutton replicated to a thumb button (extremely handy that is).

Thanks

Martin

Didn’t you just add the nvidia repo?

That’s all I had to do this time. Once you then open Software Management it will have been automatically added for install

Yes I did add the Nvidia repository and yes the automatted wownload was started, but it failed due to a wrong version number it tries to download. And it fails ever since.

Up to now nothing changed which means that either Yast fails to update the repositories (I have no hint for this) or that the information sent to Yast or submitted when trying a 1-click-install is broken (and I think this is the case at least for the G02 drivers).

Martin

So can you boot to a desktop - do you need help?

Not anymore. Because several trouble with kde4 I re-installed the whole system today and the NVidia repository contains the right version number (respectively filename)

Martin