Nvidia driver install

I’m going round and round in circles!
I’ve got a GTX1070. and I want to use the repository that is added to yast by default. I have to use nomodeset to be able to see something on my screen, even when I was installing openSUSE.

How do you get openSUSE to use the nvidia drivers? No matter what I do, whenever I remove nomodeset I get a blank screen. I must have done this before but I can’t work it out this time round or find a reliable/working solution.

When I have the nvidia driver installed and boot up something changes despite nomodeset because the screen goes in and out of focus and I get glitches around the cursor.

Thanks for any help

I think the driver might be working now! but the screen is constantly going in and out of focus. :confused:

Add Nvidia’s repo, uninstall nouveau driver, boot to command prompt, install Nvidia’s driver.

No need to uninstall nouveau, it will be blacklisted, that’s all.

I’m beginning to think I should try a different driver. The nvidia repo worked fine for me with 15.3 but in 15.4 I’ve installed it with and without nouveau installed and from init3, the gnome terminal and yast. I’ve tried installing all of G05 and G06 packages, tried different resolutions and refresh rates. I read somewhere hsync can make the screen blurry but according to nvidia-settings it seems to be set correctly.

I’ll try the most recent driver from the nvidia website when I get chance later on.

Thank you for the replies.

Sometimes it works, sometimes - not.

Hi, new to the forum, but using openSUSE since v8.0.

I encountered a similar problem with a GTX970 card.
The driver installs fine from yast, when rebooting it does not progress into graphic level, but prompts a log in.
This is (to me) the odd thing:
I can log in, then issue startx and that starts the graphic level. I can then verify that it is the nvidia driver working from the Nvidia program that appears in the System menu. This same computer had 15.3 running fine until the new install.

I tried setting nomodeset at boot time, I also unistalled the nouveau driver, but it makes no difference.
Oddly enough in another computer with a GTX960 all works fine (with the same driver G06).

Any ideas what might be preventing going into graphic mode?

Sorry, forgot to say that this is in KDE.


inxi -Gaz

Thank you for the follow up. I am away from that machine right now but will report as soon as I can.
Do you mean running that command without the nvidia driver installed (with the nouveau one) or with the nvidia driver (i.e. after installing it and not progressing to the graphic mode?), or both?

This is the output with the nouveau driver:

Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nouveau v: kernel bus-ID: 01:00.0
           chip-ID: 10de:13c2 class-ID: 0300
           Device-2: Philips (or NXP) SPC 900NC PC Camera / ORITE CCD Webcam(PC370R) type: USB
           driver: Philips webcam,snd-usb-audio bus-ID: 2-6.1.4:8 chip-ID: 0471:0329 class-ID: 0102 serial: 01690000C6490220
           Display: server: X.org 1.20.3 driver: loaded: nouveau,vesa unloaded: fbdev,modesetting alternate: nv,nvidia
           tty: 240x75
           Message: Advanced graphics data unavailable in console for root.

And this is the output with the nvidia driver

Graphics:  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nvidia v: 515.48.07
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
           Device-2: Philips (or NXP) SPC 900NC PC Camera / ORITE CCD Webcam(PC370R) type: USB
           driver: Philips webcam,snd-usb-audio bus-ID: 2-6.1.4:12 chip-ID: 0471:0329 class-ID: 0102
           serial: 01690000C6490220
           Display: server: X.org 1.20.3 driver: loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa alternate: nv
           tty: 128x48
           Message: Advanced graphics data unavailable in console for root.

Today neither the nouveau nor the nvidia driver would automatically take me to the graphic mode when booting.
I logged in as the user and issued.


and that worked.
I am puzzled because I never had this problem before and both drivers seem to be working…

Thanks for any suggestions.

I meant “worked” in the sense of successfully launching the graphic GUI with the nvidia driver, but it still kicks me to a log in console at every start.
I also run


but that has not cured the problem. I have to issue [/FONT]


every time.:frowning:

Some further info… In found some errors in the Xorg.0.log file (sorry had to cut it as the editor complains it is too long) but I do not know what they mean:

    17.441] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
    17.441] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
    17.441] (**) Option "xkb_model" "microsoftpro"
    17.441] (**) Option "xkb_layout" "gb"
    17.441] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    17.442] (II) event0  - Power Button: is tagged by udev as: Keyboard
    17.442] (II) event0  - Power Button: device is a keyboard
    17.442] (II) config/udev: Adding drm device (/dev/dri/card0)
    17.442] (II) xfree86: Adding drm device (/dev/dri/card0)
    17.442] (II) LoadModule: "modesetting"
    17.443] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    17.443] (II) Module modesetting: vendor="X.Org Foundation"
    17.443]     compiled for 1.20.3, module version = 1.20.3
    17.443]     Module class: X.Org Video Driver
    17.443]     ABI class: X.Org Video Driver, version 24.0
    17.443] (II) modeset(G0): using drv /dev/dri/card0
    17.444] (**) modeset(G0): Depth 24, (--) framebuffer bpp 32
    17.444] (==) modeset(G0): RGB weight 888
    17.444] (==) modeset(G0): Default visual is TrueColor
    17.444] (II) Loading sub module "glamoregl"
    17.444] (II) LoadModule: "glamoregl"
    17.444] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so
    17.450] (II) Module glamoregl: vendor="X.Org Foundation"
    17.450]     compiled for 1.20.3, module version = 1.0.1
    17.450]     ABI class: X.Org ANSI C Emulation, version 0.4
    17.519] (II) modeset(G0): glamor X acceleration enabled on NVIDIA GeForce GTX 970/PCIe/SSE2
    17.519] (II) modeset(G0): glamor initialized
    17.567] (II) modeset(G0): Output DVI-I-1-1 using monitor section Monitor0
    17.567] (II) modeset(G0): Output HDMI-1-1 has no monitor section
    17.567] (II) modeset(G0): Output DP-1-1 has no monitor section
    17.583] (II) modeset(G0): Output DVI-D-1-1 has no monitor section
    17.648] (==) modeset(G0): Using gamma correction (1.0, 1.0, 1.0)
    17.648] (==) modeset(G0): DPI set to (96, 96)
    17.648] (II) Loading sub module "fb"
    17.648] (II) LoadModule: "fb"
    17.649] (II) Loading /usr/lib64/xorg/modules/libfb.so
    17.649] (II) Module fb: vendor="X.Org Foundation"
    17.649]     compiled for 1.20.3, module version = 1.0.0
    17.649]     ABI class: X.Org ANSI C Emulation, version 0.4
    17.649] (EE) 
    17.649] (EE) Backtrace:
    17.649] (EE) 0: /usr/bin/X (xorg_backtrace+0x65) [0x55b84b1b2285]
    17.649] (EE) 1: /usr/bin/X (0x55b84b000000+0x1b5f59) [0x55b84b1b5f59]
    17.649] (EE) 2: /lib64/libpthread.so.0 (0x7f6e2afc5000+0x168c0) [0x7f6e2afdb8c0]
    17.649] (EE) 3: /lib64/libc.so.6 (gsignal+0x10d) [0x7f6e2ac1acdb]
    17.649] (EE) 4: /lib64/libc.so.6 (abort+0x177) [0x7f6e2ac1c375]
    17.649] (EE) 5: /lib64/libc.so.6 (0x7f6e2abd0000+0x42cda) [0x7f6e2ac12cda]
    17.649] (EE) 6: /lib64/libc.so.6 (0x7f6e2abd0000+0x42d62) [0x7f6e2ac12d62]
    17.649] (EE) 7: /usr/bin/X (dixRegisterPrivateKey+0x23f) [0x55b84b07b47f]
    17.649] (EE) 8: /usr/lib64/xorg/modules/libglamoregl.so (glamor_init+0xca) [0x7f6ca143c57a]
    17.649] (EE) 9: /usr/lib64/xorg/modules/drivers/modesetting_drv.so (0x7f6ca1666000+0x11e1d) [0x7f6ca1677e1d]
    17.649] (EE) 10: /usr/lib64/xorg/modules/drivers/modesetting_drv.so (0x7f6ca1666000+0x9bf4) [0x7f6ca166fbf4]
    17.649] (EE) 11: /usr/bin/X (AddGPUScreen+0xf0) [0x55b84b05d190]
    17.649] (EE) 12: /usr/bin/X (0x55b84b000000+0xb761c) [0x55b84b0b761c]
    17.649] (EE) 13: /usr/bin/X (0x55b84b000000+0xbd041) [0x55b84b0bd041]
    17.649] (EE) 14: /usr/bin/X (0x55b84b000000+0xb931f) [0x55b84b0b931f]
    17.649] (EE) 15: /usr/bin/X (0x55b84b000000+0xb9ecb) [0x55b84b0b9ecb]
    17.649] (EE) 16: /usr/bin/X (config_init+0x9) [0x55b84b0b8919]
    17.649] (EE) 17: /usr/bin/X (InitInput+0xc7) [0x55b84b09c4a7]
    17.649] (EE) 18: /usr/bin/X (0x55b84b000000+0x60d35) [0x55b84b060d35]
    17.649] (EE) 19: /lib64/libc.so.6 (__libc_start_main+0xef) [0x7f6e2ac052bd]
    17.649] (EE) 20: /usr/bin/X (_start+0x2a) [0x55b84b04aa1a]
    17.649] (EE) 
    17.649] (EE) 
Fatal server error:
    17.649] (EE) Caught signal 6 (Aborted). Server aborting
    17.649] (EE) 
    17.649] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
    17.649] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    17.649] (EE) 
    17.820] (EE) Server terminated with error (1). Closing log file.

Wild guess - make sure the ‘xf86-video-intel’ package is not installed - bug 1200328.

Thanks GeoBaltz, but that intel package is not currently installed.
I reverted to the nouveau driver, and it went through to the graphic mode fine, but another time it failed (showing a local log prompt. I logged in as the user and issued the “startx” command which went fine. So it might not be a nvidia driver problem after all as it also happens with the nouveau driver.

Is a xorg.conf file not needed at all? (I noted I have a xorg.conf.install file in /etc/X11/ but not xorg.conf). :dont-know:

Just posting in case it helps somebody else…

After trying lots of different things and reading various webpages, I came across a comment that mentione the G06 driver (what I had installed) and that the G05 can also be used with the card I have, so I tried it.
Problem solved! Now booting carries on into the GUI. :slight_smile:

It worths bug report.
Try to upgrade from G05 to G06 one more time.

Thanks for the suggestion. I did, and still G06 does not take me to the GUI.
I am puzzled why logging in as the user and issuing ‘startx’ works…

Test this: instead of startx, do sudo systemctl restart xdm. Does this produce the expected GUI login screen?

If you are using KDE and you login to it and presented you a black screen
Could be plasmashell is not loading, just a guess.

So try alt-F2 and do


if kde
start then that’s the culprit.

Add plamashell in the auto start might be the workaround.

Thank you I tried this and I get the following error:

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This aplication failed to start because no Qt platform plugins could be installed. Reinstalling the application may fix this problem.