NVIDIA driver install w/o internet connection?

I am hoping someone can help me out with my issue, i have a laptop with NVIDIA GeForce Go 6600 running OpenSUSE 11 BUT have no internet connection. All of the “instructions” for installing the driver i’ve found involve being able to use Yast. I already downloaded the 100.14.09 drivers(on another comp) and when i try to install them it tells me there’s no precompiled kernel. Any ideas are very much appreciated.
Thank you

You need to install the base development tools and the kernel source
from the DVD.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 i586 Kernel
up 13:00, 2 users, load average: 0.37, 0.39, 0.29
Artigo VIA Esther 1.0GHz CX700M2 UniChrome PRO II Graphics

You will probably need the new drivers : version 173.14.09 is the latest and recommended. The version of the driver that you are using is not compatible with the kernel version that comes with openSUSE 11.0. From version 173.08 onwards compatibility with recent 2.6.x kernel has been restored. See this
Linux x64 (AMD64/EM64T).

You need the following packages (all in the 11.0 dvd) to install nvidia’s binary driver:-

  1. kernel-source
  2. binutils
  3. make
  4. gcc

After that installing the binary driver in the usual way (see Nvidia Installer HOWTO for SUSE LINUX users) should work.
Hope that helps.

Thankyou for the expediant responses, i installed the kernel-source, binutils, make,and gcc and verified they were installed and were the latest version. then i downloaded the newest NVIDIA driver(173.08) and then hit ctrl+alt+F2 then logged in as root then went into level 3. I ran the nvidia .run file and now it is saying "the kernel header file ‘/lib/modules/’ does not exist… so thank you so far, youve gotten me farther than i previously had gotten…any ideas for what to do now?

Just looked at my kernel-source version…it is …do i have to install the older 4-8 version?

You have not downloaded the latest version of the nvidia binary driver: 173.08 is not the latest, 173.14.09 is the latest, and you can get it here Linux x64 (AMD64/EM64T) for 64 bit and here Linux Display Driver - x86 for a 32 bit computer.

Try the above procedure out with this version of the driver, I am not sure if the one you have downloaded (173.08) will work; I had given the link to that one only because the compatibility changes were first made in that version and it is reflected in the change-logs there. Sorry if I misled you. But please do try out with the latest version and let us know if it works.

Ok, so i installed 173.14.09…AND…it says Unable to determine the version of the kernel sources located in ‘/lib/modules/’ it also says "you may specify the kernel source path with the ‘–kernel-source-path’ command line option’ id give that a try but dont exactly know how i would use it

GOOD NEWS, thankyou to the quick responses i was able to figure the driver installation out. I was a bit confused about why it was asking for the kernel so i typed in rpm -qa kernel* gcc* binutils* make* to make sure everything was REALLY up-to-date and i found the issue, it told me that my kernel-source was BUT my kernel-default was so i D’ld and installed the kernel-default- AND rebooted into failsafe mode and the 173.14.09 nvidia drivers worked. Thank you malcolmlewis and badshah400 very much for all the help and i hope that this can help out others.

So it turns out i have the same problem, different kernel-source than actual kernel.

How can i grab the newest kernel-source? I check yast and only the previous kernel version is available(the one i already have).


Ok from what i learned when i was having issues, your kernel-source and kernel-default have to be the same. I dl’ed kernel-source- and kernel-default-…installed them, restarted went into init 3 and ran the install… worked just fine for me