Nvidia driver gives gdm failure on fresh 11.4/Gnome install (GT430 card)

Hello

Apologies if this is a repeated thread. I have spent ages looking at similar problems but not not quite the same. I have installed 11.4/Gnome (x86) and wanted to use my GT430 card. I went here: ‘http://en.opensuse.org/SDB:NVIDIA_drivers’ and used the ‘one click’ install for current cards. All went ok until I rebooted and I got a ‘gdm[1239]: WARNING: GdmDisplay: display lasted 0.846578 seconds’ message. I got five of these in succession until the ‘gdm[1239]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check X server log for errors’ appeared and it popped me down to an init 3 login.

So, I deleted the blacklisting conf file so that I could get back in to Gnome on Nouveau (which I did ok). I then noticed there was no /etc/X11 Xorg.conf file so I ran /usr/lib/nvidia-xconfig to generate one (which it did) - but it made no difference.

I am at a loss know after spending 8 hours on this. Any pointers would be greatly appreciated. My machine is still at fresh install state so even if I have to reinstall 11.4 it does not matter.

Some install data:

Kernel: 2.6.37.6-0.5-default
Gnome: 2.32.1
GPU: GT 430 (PCIx)
Opensuse : 11.4 (32bit)

[Drivers]
nvidia-computeG02: 270.41.06-5.1
nvidia-gfxG01-kmp-default: 173.14.28_k2.6.37.1_1.2-27.1
nvidia-gfxG02-kmp-default: 270.41.06_k2.6.37.1_1.2-4.1
x11-video-nvidiaG01: 173.14.28-28.1
x11-video-nvidiaG02: 270.41.06-5.1
xorg-x11-driver-video-nouveau: 0.0.16_20110115_b795ca6-3.1

rpm -qa | grep kernel results
kernel-source-2.6.37.6-0.5.1.noarch
kernel-default-2.6.37.6-0.5.1.i586
kernel-devel-2.6.37.6-0.5.1.noarch
kernel-default-devel-2.6.37.6-0.5.1.i586

Many thanks

Richard

I have never installed the driver using the 1-Click method. I suggest you move on to the next one called repository method and give that a try. I install it the hard way, which works just fine, but the repository method might be better for you. Here is a different Link to look at:

SDB:Configuring graphics cards - openSUSE

Thank You,

Beside jdmcdaniel3’s advise, when I look at your list I find it strange that
you have the 270 and the 173 driver installed. I never had that at the same
time on one of my machines so I do not know if that is a problem or not.
If I were you I would uninstall the 173 drivers (the G01 versions) and see
if the problem fixes itself after that and restarting the xserver (and
blacklist noveau again for testing it).


PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.3 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
ION | 3GB Ram

Beside jdmcdaniel3’s advise, when I look at your list I find it strange that
you have the 270 and the 173 driver installed. I never had that at the same
time on one of my machines so I do not know if that is a problem or not.
If I were you I would uninstall the 173 drivers (the G01 versions) and see
if the problem fixes itself after that and restarting the xserver (and
blacklist noveau again for testing it).
Very good martin_helm. I might have to change your name to Eagle-Eye.

Thank You,

Thanks everyone I will remove the G01 drivers and if that does not fix it then try the different way.

Cheers

Thanks everyone I will remove the G01 drivers and if that does not fix it then try the different way.

Cheers
bigdutch100, you must come back and tell us of your success and good luck.

Thank You,