NVIDIA driver for linux (openSuSE 10.3) issues

I am in the process of compiling a computer behavior architecture known as MOOS. In the past I have had no issues with this install, but I have recently updated the NVIDIA driver and have found an issue. I have already solved the problem, but I am trying to find out if there is a better way of handling it.

The problem originates when making the program. I received the error:
/usr/lib/gcc/i586-suse-linux/4.2.1/…/…/…/libGL.so: undefined reference to `_nv001465gl’

This error directed me into looking at libGL and checking if there was an error. After navigating to /usr/lib/ I checked the symbolic links that were created for libGL.

lrwxrwxrwx 1 root root 22 2009-04-29 10:40 libGLcore.so.1 → libGLcore.so.173.14.12
-rwxr-xr-x 1 root root 4912 2007-09-21 20:34 libGLcore.so.1.0
-rwxr-xr-x 1 root root 13886336 2008-09-22 13:18 libGLcore.so.173.14.12
-rw-r–r-- 1 root root 659 2008-09-22 13:18 libGL.la
lrwxrwxrwx 1 root root 10 2009-04-29 10:07 libGL.so → libGL.so.1
lrwxrwxrwx 1 root root 18 2009-04-29 10:40 libGL.so.1 → libGL.so.173.14.12
-rwxr-xr-x 1 root root 391344 2007-09-21 20:34 libGL.so.1.2
-rwxr-xr-x 1 root root 671684 2008-09-22 13:18 libGL.so.173.14.12
lrwxrwxrwx 1 root root 11 2008-05-22 14:11 libGLU.so → libGLU.so.1
lrwxrwxrwx 1 root root 20 2009-04-29 10:07 libGLU.so.1 → libGLU.so.1.3.070001
-rwxr-xr-x 1 root root 495800 2007-09-21 20:34 libGLU.so.1.3.070001

I noticed that libGLcore.so.1.0 and libGL.so.1.2 were not being referenced. After looking into YaST Software Update, I found that the 173.14.12 versions were created and linked by nvidia while the 1.0 and 1.2 versions were created by MESA. To test my theory, I relinked the base libGLcore and libGL file to those created by MESA, and tried to make my program again. This time around everything worked perfectly.

It would seem that there is a fundamental difference between the libGL created by nvidia and the equivalent created by MESA. I have to have this functionality, but would like to continue using and updating NVIDIA without having to relink the file each and every time. Is there anything else I should look into or is this something with nvidia’s driver. Thanks.