Nvidia Driver Errors - Please Help

First off CPU + GPU specs:
AMD Phenom II X6 1090T Processor 3.2 gHz
NVidia GF104 [GTX 460] (rev a1)
Dual monitor set up.
OpenSUSE 12.1

I assume that’s all you’ll need for this problem. I recently just decided to switch to Linux again (I’m an on and off user), specifically OpenSUSE. I have heard some great things and I personally love it but I’ve had an issue from the start with drivers.

My main monitor has a resolution of 1280x1024 and my secondary has 1024x768. Now, I know that most Linux OSs will throw in a Nouveau driver for NVidia cards (which suck relative to the prop. driver NVidia offers), so the first thing I did after installation was try to install the NVidia Linux proprietary driver for my card. Nouveau naturally mirrors my displays on both screens, with both in 1024x768 as default instead of the 1280x1024 of the main monitor.

The first time, I installed the repository, then installed a few NVidia card software options and the driver. Log off, and it goes straight to console Linux, no more displays. I try to activate with “display” or “startx” and it says that it cannot start due to a read error (something about line 486 or so, but I’m not quite sure of the exact error as that was in the early hours of the day). Keep in mind, I’ve been doing fresh installs to make sure the error is contained in a controlled environment that you are all familiar with and that previous attempts haven’t left any lingering errors. This next time, I unplugged my 1024x768 monitor to do installation, everything went fine in the proper resolution (before it was defaulting to lower quality and mirroring the screens), but when I tried to plug in my new display, nothing could turn it on, it would just sit blank forever. Next time, nothing changed at all, stayed exactly the same (didn’t blacklist nouveau this time is my guess).

So I reinstalled, this time I install repo, then installed just the driver, and finally blacklisted nouveau. Nothing changed in any way, until I rebooted, which made my main screen the only active screen (in proper 1280x1024 format). And when trying to access nvidia-settings, it would give me

"ERROR: NV-CONTROL extension not found on this Display.
ERROR: Unable to determine number of NVIDIA GPUs on ‘:0’.
ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ‘:0’.
ERROR: Unable to determine number of NVIDIA VCSCs on ‘:0’.

But it would start regardless, but the only available menu is “Nvidia-settings Configuration” with the 5 check boxes, no actual menu.

I thought, maybe the driver wasn’t active, so I type “startx” and it gives me:
“xauth: file /root/.serverauth.15405 does not exist.
Fatal server error:
Server is already active for display 0 If this server is no longer running, remove /tmp/.X0-lock and start again.
(line about support line for X.org)”

After a few seconds it also gives:
“XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0” after 7 requests (7 known processed) with 0 events remaining.”

I’m not much of a Linux expert, and honestly have very little know-how on this kind of troubleshooting especially, so any help would be very much appreciated. I’m sorry for the large amount of text, but I wanted to make sure you have all the information you need to help me. I guess I can settle to use Nouveau and configure it for dual monitor support, but with the massive performance hit from doing so rather than fixing this (if this isn’t so true, feel free to speak up, but from what I’ve heard, with my card the performance hit is exponential), I’m not sure if that would be the best way to go over Windows. Thank you so much in advance everyone.

Not sure what has gone wrong for you, but if you are ready to try loading the nVIDIA driver the hard way, here are a few more resources for you to look at:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.45 - Blogs - openSUSE Forums

S.A.N.D.I. - SuSE Automated NVIDIA Driver Installer - Version 1.46 - Blogs - openSUSE Forums

And for using the latest built-in nVIDIA driver, try loading a newer kernel instead:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.70 - Blogs - openSUSE Forums

S.G.T.B. - SuSE Git Kernel Tarball Creator - Version 1.80 - Blogs - openSUSE Forums

Thank You (for using openSUSE),

There’s a couple of things you should not have done:

  • startx as root. It means you start the desktop as root, there’s loads of posts across the forums on why one should not do this.
  • if you install the right driver packages, there’s no need to blacklist anything, it’s done by the package’s scripts. Same for “NO_KMS_IN_INITRD”.
  • Reinstalling. Believe me, linux is that stable, that a reinstall will generate the same situation.

On thing I can think of, is that you don’t have the NVIDIA driver for your running kernel. Please open a terminal window, and post output (between CODE tags) of commands below:


uname -a
rpm -qa | grep nvidia
lsmod | grep nvidia
glxinfo | grep direct

The things you said to not do:

  • Oh my bad, like I said, on and off Linux…
  • Oh, well I was looking around and saw that numerous people had errors with needing to blacklist nouveau?
  • I know that! I knew the reinstall wouldn’t FIX anything, I just wanted to start every single troubleshoot with the same exact environment. Making sure that any past attempts at fixing anything didn’t cause any problems.

Here’s the output:
kenneth@linux-tfnt:~> uname -a
Linux linux-tfnt 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux
kenneth@linux-tfnt:~> rpm -qa | grep nvidia
x11-video-nvidia-96.43.20-16.1.x86_64
nvidia-gfx-kmp-desktop-96.43.20_k3.1.0_1.2-15.1.x86_64
kenneth@linux-tfnt:~> lsmod | grep nvidia
kenneth@linux-tfnt:~> glxinfo | grep direct
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.

The things you said to not do:

  • Oh my bad, like I said, on and off Linux…
  • Oh, well I was looking around and saw that numerous people had errors with needing to blacklist nouveau?
  • I know that! I knew the reinstall wouldn’t FIX anything, I just wanted to start every single troubleshoot with the same exact environment. Making sure that any past attempts at fixing anything didn’t cause any problems.

Here’s the output:
kenneth@linux-tfnt:~> uname -a
Linux linux-tfnt 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux
kenneth@linux-tfnt:~> rpm -qa | grep nvidia
x11-video-nvidia-96.43.20-16.1.x86_64
nvidia-gfx-kmp-desktop-96.43.20_k3.1.0_1.2-15.1.x86_64
kenneth@linux-tfnt:~> lsmod | grep nvidia
kenneth@linux-tfnt:~> glxinfo | grep direct
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.

That’s the legacy driver; for a GTX 460 you need the G02 packages.

Wow, I almost felt like a complete idiot…
Okay so another reinstall (totally fresh slate, again controlled environment).
I did the proper procedure, now when I went to “nvidia-settings” it gave me the pop-up error:
“You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run ‘nvidia-xconfig’ as root), and restart the server.”

The settings window appeared, but still with only that one menu available. I went to console and here’s what happened:
kenneth@linux-2j0v:~> su
Password:
linux-2j0v:/home/kenneth # nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.

WARNING: Unable to find CorePointer in X configuration; attempting to add new
CorePointer section.

WARNING: The CorePointer device was not specified explicitly in the layout;
using the first mouse device.

WARNING: Unable to find CoreKeyboard in X configuration; attempting to add new
CoreKeyboard section.

WARNING: The CoreKeyboard device was not specified explicitly in the layout;
using the first keyboard device.

Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.backup’
New X configuration file written to ‘/etc/X11/xorg.conf’

Tried nvidia-settings, same error and popup. So I tried to do nvidia-xconfig one more time and the output was simlpy:
linux-2j0v:/home/kenneth # nvidia-xconfig

Using X configuration file: “/etc/X11/xorg.conf”.
Backed up file ‘/etc/X11/xorg.conf’ as ‘/etc/X11/xorg.conf.backup’
New X configuration file written to ‘/etc/X11/xorg.conf’

Tried nvidia-settings again, same problems though.

Ran through the code provided by the man above again and:

kenneth@linux-2j0v:~> uname -a
Linux linux-2j0v 3.1.10-1.9-desktop #1 SMP PREEMPT Thu Apr 5 18:48:38 UTC 2012 (4a97ec8) x86_64 x86_64 x86_64 GNU/Linux
kenneth@linux-2j0v:~> rpm -qa | grep nvidia
nvidia-computeG02-295.40-15.1.x86_64
nvidia-gfxG02-kmp-desktop-295.40_k3.1.0_1.2-14.1.x86_64
x11-video-nvidiaG02-295.40-15.1.x86_64
kenneth@linux-2j0v:~> lsmod | grep nvidia
kenneth@linux-2j0v:~> glxinfo | grep direct
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Error: couldn’t find RGB GLX visual
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.