Nvidia Driver Error

I have Suse 11.2 M5 64bit installed on an AMD 64x2, Nvidia 8400GS

I downloaded NVIDIA-Linux-x86_64-185.18.31-pkg2.run

I have installed:

  • compiler gcc,
  • program make and
  • package kernel-source (That is installed as well as the kernel-source-Vanilla)
  • package kernel-syms

I also have the linux-kernel-headers installed.

I opened up Konsole, su root

Typed in: init 3

Then I typed in: sh NVIDIA-Linux-x86_64-185.18.31-pkg2.run -q (also tried it without -q just for the hell of it.)

I get the error:

ERROR: The kernel header file ‘/usr/src/linux/include/linux/version.h’ does not
exist. The most likely reason for this is that the kernel source files
in ‘/usr/src/linux’ have not been configured.

What am I missing here?

locate version.h

Maybe somthing wrong in Nvidia Driver.
I had the same problem and don’t remember how I fix it.
Try NVIDIA-Linux-x86_64-185.18.31-pkg2.run --update

I gave that a try. It downloaded it and then went to install it but I got the same error. The version.h all seem to be in the correct places.

you need the kernel-devel packages installed

I had those installed already. Not sure what the issue was. But… After I tried all the things I could think of I went back into yast and I ended up breaking things. When I went to reboot all I got was a black screen. I could find no way around it.

No big deal. Tomorrow I am going to reinstall 11.1 and wait for 11.2 Milestone 6.

I still would like to know what I missed or if it was something else

I ended up reinstalling 11.1 tonight. I am still not sure if it was something I did or did not do or something else.

I ha d the same problem. the fact is that the kernel source in the repo is still 2.6.30 while probably you have kernel 2.6.31 installed. it was for me. so I installed the right kernel source from factory and everything is ok now

Thanks. I will keep that in mind in case this comes up again.

I can add some more. Had the same problem on latest Factory kernel update. Point is, that the new kernel does not automatically install the new kernel sources. If you correct that by hand, i.e. selecting the version matching to the kernel, there’s no problem in installing the driver anymore. Can also be done from the Yast ncurses interface.

And there’s more. From what it looks like the kernel-desktop gets auto-installed, and configured as first choice in GRUB. Suddenly I had 2 kernels…


I installed the latest driver (185.18.31) using the kernel-pae and not the kernel-desktop.

uname -r

rpm -qa | grep kernel

I hope this helps

ps: sorry my english

Wasn’t it

make modules_prepare

which builds this file?