Nvidia driver dependancy issues

Hi, I have a Acer M1640 Desktop with a Nvidia GeForce 7050 chip. I have downloaded the Nvidia driver but when I try to install the two driver kernel modules nvidia-gfxG01-kmp-lockdep and nvidia-gfxG01-kmp-pae I get a “nothing provides…” error. Can anyone help me get my graphics card setup? It would be nice to test out some of the desktop effects Suse has to offer, right now I am on the generic VESA mode. :frowning: Thanks in advance.

The two files you need are one named “X11.xxxx” and the other is “G01.xxxx”. There are different versions of these depending on whether you are running 64 bit (X86_64) Suse or a lot of memory (pae).

I don’t know what version of Suse you are running (I assume 11) and whether you have the 64 bit or the 32 bit version installed.

If I read your post correctly, it sounds like you are trying to install two “G01” files. You need a matching pair of the correct G01 file and the correct “X11” file for your system.

There are no other dependencies for this version of the driver, just those two files.

Thanks for clarifying that, yes I am using Suse 11 64bit KDE 4. I guess I installed it right then. Is there another step to activate the Nvidia driver after installing the repositories? I see the two files check marked in Yast and they installed successfully but I am still on VESA mode. Sorry I’m relatively new to the Linux world, just moved from Ubuntu not too long ago.

Sometimes you can just reboot and the driver will work.

If that does not work go to the terminal, type su, enter root password, and then enter the command

init 3

Then log in as root and run this command:

sax2 -r -m 0=nvidia

Sax2 should start up. Go to “change settings” and confirm that 3d acceleration is activated and your resolution is correct.

Exit sax2 and type


That should do it. When you get back to your desktop, go to the terminal and to check 3d acceleration run


Also run


and confirm you are using the Nvidia driver.

If you have updated your kernel, this is a common cause of Nvidia driver problems, but hopefully your present set-up will work once sax2 is run in text mode and told to switch to the Nvidia driver, which is what the series of commands above are intended to do.

Alright I’m back again, I did as you said and when I got to entering

sax2 -r -m 0=nvidia

I got a “bash:command not found” error. Any idea on how to resolve that? Thanks again.

Couple questions. Are you logged in as root? Also, are you using a “zero” in the sax2 command, rather than the letter “O”?

Couple questions. Are you logged in as root? Also, are you using a “zero” in the sax2 command, rather than the letter “O”?

Also, are you out of the x-server (AKA “text mode”)?

-Yep, double checked and made sure I used a zero and not the letter “O”.

-And if you mean by a black looking screen with nothing but text yes, that’s where it takes me, then from there I enter the sax2 command and then I get my bash error.

How about just trying

sax2 -r

If it still won’t work, just reboot and see what you have. Try running the command


and see if you are using the Nvidia driver or not.

-Tried option 1 and still gave me a bash error.



and it said “you do not appear to be using the nvidiax driver”.

I have also tried reboots as well and still defaults to the VESA. :frowning:

You need nvidia-gfxG01-kmp-default and x11-video-nvidiaG01 then you can run nvidia-settings


Well appreciate the help everyone but I think I probably have a bad install or something since it could not find even the “Sax2” command while logged in as a root. So I guess I’ll just live with it, thanks anyways.

It should be in /usr/sbin?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 12:35, 2 users, load average: 0.00, 0.17, 0.20
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

What kernel version are you running?

To find out use the command

uname -r

It may help us to know that info.

Also, your card model and what version of Suse you are running. Maybe I can find a driver that will work, if I know all of that.

It came up with