NVIDIA driver 550.90 broken, plus no boot option for kernel 6.9.3

Hello guys. Today NVIDIA driver 550.90 come out in Tumbleweed repo so I upgraded (system in snapshot 20240531) and things broke.

First I missed MOK enrollment and found out the new public key located in /usr/share/nvidia-pubkeys rather than /var/lib/nvidia-pubkeys, though it was an intended change mentioned in boo#1224773.

Rebooted and NVIDIA drivers could not be loaded. nvidia-smi said NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running., though NVIDIA drivers were indeed installed. No nvidia_drm in lsmod. Tried dracut --force --regenerate-all and no improvement.

Went back to the pre snapshot before the update and found that even the snapshot selection menu in grub reported the kernel version to be 6.9.3, uname -r still said 6.9.1. And 6.9.3 could not be found in YaST Boot Loader > Bootloader Options > Default Boot Section. Tried update-bootloader --reinit and update-bootloader --refresh and no improvement.

I guess openSUSE packaging team for NVIDIA drivers are making some changes and improvements and things break sometimes during the phase. I totally get that.

Not ranting. Just want to share a problem I met today. Have you encountered the same? Just now I’ve updated to 20240605 snapshot and still broken. Time to go back to yesterday('s snapshot)!

It would probably be worth reporting the entire issue on bugzilla if it isn’t there already. That’s going to be the best way to ensure it gets looked at and addressed.

No problem so far with actual kernel and G06 driver on different machines. Secureboot disabled on them…

Did you try to import the certificate again after you missed it the first time??

ich@laptopneu:~> zypper se -si *G06*
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                          | Type  | Version                 | Arch   | Repository
---+-------------------------------+-------+-------------------------+--------+-----------
i+ | nvidia-compute-G06            | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-compute-G06-32bit      | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-compute-utils-G06      | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-driver-G06-kmp-default | Paket | 550.90.07_k6.9.3_1-23.1 | x86_64 | NVIDIA
i+ | nvidia-drivers-G06            | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-gl-G06                 | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-gl-G06-32bit           | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-utils-G06              | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-video-G06              | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
i+ | nvidia-video-G06-32bit        | Paket | 550.90.07-23.1          | x86_64 | NVIDIA
ich@laptopneu:~> 

ich@laptopneu:~> zypper se -si kernel-default
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

S  | Name                 | Type  | Version   | Arch   | Repository
---+----------------------+-------+-----------+--------+---------------
i+ | kernel-default       | Paket | 6.9.1-1.1 | x86_64 | (Systempakete)
i+ | kernel-default       | Paket | 6.8.9-1.1 | x86_64 | (Systempakete)
i+ | kernel-default       | Paket | 6.8.8-1.1 | x86_64 | (Systempakete)
i+ | kernel-default       | Paket | 6.9.3-1.1 | x86_64 | OSS
i+ | kernel-default-devel | Paket | 6.9.1-1.1 | x86_64 | (Systempakete)
i+ | kernel-default-devel | Paket | 6.8.9-1.1 | x86_64 | (Systempakete)
i+ | kernel-default-devel | Paket | 6.8.8-1.1 | x86_64 | (Systempakete)
i+ | kernel-default-devel | Paket | 6.9.3-1.1 | x86_64 | OSS
ich@laptopneu:~>
ich@laptopneu:~> uname -r
6.9.3-1-default
ich@laptopneu:~> 

Glad to hear that things work fine for you!

Indeed I’ve re-enrolled the key. After that mokutil --list-enrolled reported:

[key 28]
Owner: ...
SHA1 Fingerprint: ...
Certificate:
    Data:
        Version: 3 (0x2)
        Serial Number:
            ...
        Signature Algorithm: sha256WithRSAEncryption
        Issuer: CN=Local build for nvidia-driver-G06 550.90.07 on 2024-06-06

And just tried to disable secure boot to sadly see no difference. :joy: I’m filing a boo ticket.

Hey guys! I worked this out! And the real causes behind these are truly bizarre.

As the title mentioned, there was no boot option for kernel 6.9.3, albeit it had been installed, and I had done dracut -f. And the NVIDIA driver 550.90 was made for kernel 6.9.3, as the full name of the package of the kmp-default one was nvidia-driver-G06-kmp-default-550.90.07_k6.9.3_1-23.1.x86_64. I was always guided to boot in kernel 6.9.1, so the NVIDIA driver could not be properly loaded, I guess.

So while investigating the output of update-bootloader as mentioned in the original post, I happened to notice that grub menu could not be updated because of an error of /etc/grub.d/00_tuned, which requires /etc/tuned, which was deleted by me because I don’t use tuned, which prevented boot option for kernel 6.9.3 to be generated. So I reinstalled tuned to recreate etc/tuned and did update-bootloader and dracut things and rebooted. Voilà! My system went back to normal and the NVIDIA driver got properly loaded.

Thank you for your reply. And thanks go to the people helping out on bugzilla.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.