nvidia+compiz+hibernate=2muchslow

Hi people.
Is my first time testing suse and i have now a very good concept of it. I need to only solve one problem which annoysme.

I have a Biostar TF7025-M2 mobo which comes with an nvidia GF7025 onboard, 2 Gb DDR2, 7.1dolbyd etc.
Monitor Samsung 22’’ with 1680x1050 optimal resolution.

I have installed opensuse with the GNOME livecd and i am really impressed.
Since with “nv” driver or “vesa” i dont have any 3d aceleration, i installed the nvidia driver, which i am aware that doesnt work good after hibernating (but with some special conditions it used to work).

Installed the nvidia driver with the 1-click procedure and everything worked. BUT i have sometimes microfreezes when doing some tasks with videos, or flash in websites.
Si i am using the fusion icon to switch to Metacity when this microfreezes becomes too much annoying.

now here is the problem. If i want to go back to compiz, it draws lots of black errors and terrible slow, it becomes completelly unusable after deactivating it and reactivating it.
If i reboot having metacity selected on Fusion icon, then compiz start but in the fusion icon, Metacity keeps selected and i have to select “Reload WM”.

Part of my xorg.conf is:

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVIDIA GF7025"
    BoardName      "Framebuffer Graphics"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "DamageEvents" "True"
    Option         "DisableGLXRootClipping" "True"
    Option         "AllowGLXWithComposite" "True"
    Option         "RenderAccel" "True"
    Option         "UseEvents" "False"
    Option         "TripleBuffer" "True"
    Option         "BackingStore" "True"
....

Section "Extensions"
    Option         "Composite" "Enable"
    Option "DAMAGE" "Enable"
    Option "RENDER" "Enable"
EndSection

Does someboy know how to solve this slow rendering after having disabled compiz?
Or even better, how to solve the microfreezes?

Is there some other information missing?