NVidia card and drivers look like horrible on new machine

So, I just installed Linux on a new machine. An HP Spectre X360 15-DF003DX 2-in-1 laptop, 15.6" and 512GB SSD.
The video card is a GP108M (GeForce MX150) as far as Linux Hardware Information says so.

The video display for this is just wrong … The default display is 3840x2160 and in some cases the screens are all just way off.
In some cases the windows headers are just too big, the icons are too big, the lower left icon for the Applications is too big.
When I open up Chrome, Mozilla, or the header is way too small … I can’t even read it. In some applications, the lettering is too small.me

The overall experience just sucks so far. My last laptop it was perfect.
Is there some way I can fix the video to make it normal? I don’t want to remove the Nvidia drivers, but I’d also like a decent display.

I added the NVidia repository, and I tried to update the drivers, and tried to install an NVidia control panel … anything which I thought might fix the display.

Can anyone help me out with this? Thanks!

There are reportedly problems with nvidia graphics when using the latest kernel (4.12.14-lp151.28.4-default). If you are able to install the previous kernel, that might help.

Please use code tags to paste here input and output from the following (inxi may need to be installed first):

xrandr --listproviders; inxi -GxxSM

Also if /etc/X11/xorg.conf exists, try restarting X after renaming it something else.

Note with very high resolutions you may need to adjust the dots per inch settings to get larger font rendering.

With that Hi-res I’d guess things are too small. That is all adjustable in the desktop settings.

Though the specs are not clear I’m guessing that this is a Intel+NVIDIA GPU (Optimus) This configuration requires special handling though that should not matter to screen resolution issues.


Maybe read 5.4 in the Relaese Notes for Leap 15.0:

I just did a fresh install, and I just copied all my old data from my last system to this new system. So, I am not sure how I can really install the previous kernel without blowing up what I have already.

I might just have to wait until there is an update to Nvidia drivers for this current kernel.

If you haven’t installed NVidia’s proprietary drivers or enabled NVidia’s driver repos, you won’t blow anything up by installing the release kernel:

sudo zypper in --oldpackage kernel-default-4.12.14-lp151.27.3

Well, I tried this command over the weekend, and it didn’t work. I tried using sudo and I also made sure the software was installed.

It’s simply the command wasn’t right, but I’d be willing to try again, with the correct command.

Ugh … I can’t remember where I saw it, because I just tried looking back over this thread to give credit where credit is due.

The situation is that I used SUDO to edit /etc/sddm.conf which was initially empty.

I added this text to this file, and I remember they said the 192 is 96x2, and if you change 192 make sure it is a factor of 96 …
ServerArguments=-nolisten tcp -dpi 192

Which I could give credit to the original poster. This did help a lot, but it’s not 100%, but it is sooooooooo much better, so the laptop is now tolerable.



Well, I tried this command over the weekend, and it didn’t work.[/quote]Xrandr can only run from within X (Xterm, Konsole, LXterm, Gnome-terminal, etc.). Inxi provides incomplete output when not run from X. If this doesn’t explain “doesn’t work” and permit you to try again and succeed, please describe in detail what does.