NVIDIA + Bumblebee + kernel 3.9 issue

No the --add-this-kernel parameter just creates a new installer. I did a clean install today, I didn’t need to reinstall the xorg-x11-server. Have only two problems, performance for primusrun i slow and bbswitch doesn’t power off the nvidia card after running primusrun or optirun and there’s no way to unload the nvidia module to release the card. OpenGL works as expected on both cards

Overman79 updated his repository with version 310 of nvidia drivers. It works on kernel. I am soooo relieved now. Thank you sooo much Overman79 :slight_smile:

I have not tested this version with 3.9.1 kernel. (The 312/317 versions did not work on 3.9.1)

I tried and 310 didn’t build with kernel 3.9.1, it built fine on 3.8.5.

resume of my test: 310, 313, 319 not working on kernel 3.9.x with bumblebee. (OS 12.3, kernel:stable repo, overman79 repo)

So I’m back to my trusted 3.8.5 (btw overman’s 310 build there) until there will be a “clean” solution for 3.9 kernel and nvidia 319, or at least 313.

I am doing the same, using 310 on kernel. But I am facing this isssue - If i put my computer on sleep (which i have to do since it is a laptop), after wake up it says :
FATAL: Error inserting nvidia (/lib/modules/3.8.8-1-desktop/updates/nvidia.ko): No such device

It does that even after restart :frowning: I really wish it was at least stable with 3.8.8. How is your experience so far?

BTW, its very very slow to shutdown and restart opensuse 12.3, even if this is a high end custom laptop. I dont know whats the issue though.


/var/log/messages has :

NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:11a1)
2013-05-13T22:51:56.775137-04:00 nuxpc kernel:   487.359948] NVRM: installed in this system is not supported by the 310.51
2013-05-13T22:51:56.775139-04:00 nuxpc kernel:   487.359948] NVRM: NVIDIA Linux driver release.  Please see 'Appendix
2013-05-13T22:51:56.775141-04:00 nuxpc kernel:   487.359948] NVRM: A - Supported NVIDIA GPU Products' in this release's
2013-05-13T22:51:56.775143-04:00 nuxpc kernel:   487.359948] NVRM: README, available on the Linux driver download page
2013-05-13T22:51:56.775146-04:00 nuxpc kernel:   487.359948] NVRM: at www.nvidia.com.
2013-05-13T22:51:56.775147-04:00 nuxpc kernel:   487.359971] nvidia: probe of 0000:01:00.0 failed with error -1
2013-05-13T22:51:56.775192-04:00 nuxpc kernel:   487.360034] NVRM: The NVIDIA probe routine failed for 1 device(s).
2013-05-13T22:51:56.775197-04:00 nuxpc kernel:   487.360037] NVRM: None of the NVIDIA graphics adapters were initialized!

and modprobe nvidia fails with:

FATAL: Error inserting nvidia (/lib/modules/3.8.8-1-desktop/updates/nvidia.ko): No such device

Kernel hackers please help :smiley:

Please start a new thread. The title indicates this is about kernel 3.9, if we go on this is gonna be very confusing.


i had the same problem with a recent 3.9.1 Kernel from Tumbleweed and Overmans Nvidia driver 319.17-21. I found out that the ARCH variable in /var/lib/dkms/nvidia/319.17-2.1/source/Makefile is set to a wrong string. On my x86_64 computer it was set to x86. That was the problem for me. I changed the following in the file:

ifndef ARCH
 ARCH := $(shell uname -m | sed -e 's/i.86/i386/' -e 's/armv[0-9]\w\+/arm/')


#ifndef ARCH
 ARCH := $(shell uname -m | sed -e 's/i.86/i386/' -e 's/armv[0-9]\w\+/arm/')


This way ARCH get correctly set to x86_64 and then the compiler finds all the correct paths etc and builds the module just fine.

I really dont know where the ARCH variable gets set to “x86”. Do you have an idea? Maybe from make or dkms?


You’re a genius !! I confirm that the driver compiles and runs fine on Tumbleweed’s 3.9.1 kernel.

Me too! Your hint works as well on Kernel 3.9.2. Thank you, Thank you so much oopepe.


i search the way to install bumblebee with kernel 3.9.2

have you modified theses files and rebuilded it?
x11-video-nvidia-319.17-6.1.src.rpm dkms- dkms-nvidia-319.17-2.1.src.rpm

any way to get file you builded?

ok i installed: bumblebee, dkms, dkms-nvidia, dkms-bbswitch, Virtual-GL, primus, x11-video-nvidia

i add my user to video and bumblebee group

systemctl enable dkms

ln -s ‘/usr/lib/systemd/system/dkms.service’ ‘/etc/systemd/system/multi-user.target.wants/dkms.service’

systemctl enable bumblebeed

ln -s ‘/usr/lib/systemd/system/bumblebeed.service’ ‘/etc/systemd/system/graphical.target.wants/bumblebeed.service’

i get
primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.

in /var/log/message

2013-05-17T23:17:28.758390+02:00 linux-ct1k bumblebeed[683]:   141.758955] [ERROR][XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
2013-05-17T23:17:28.758473+02:00 linux-ct1k bumblebeed[683]:   141.758992] [ERROR][XORG] (EE) NOUVEAU(0): [drm] error opening the drm
2013-05-17T23:17:28.759145+02:00 linux-ct1k bumblebeed[683]:   141.758998] [ERROR][XORG] (EE) NOUVEAU(0): 820:
2013-05-17T23:17:28.759679+02:00 linux-ct1k bumblebeed[683]:   141.759047] [ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.
2013-05-17T23:17:28.760180+02:00 linux-ct1k bumblebeed[683]:   141.759057] [ERROR][XORG] (EE)
2013-05-17T23:17:28.760733+02:00 linux-ct1k bumblebeed[683]:   141.759069] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
2013-05-17T23:17:28.761272+02:00 linux-ct1k bumblebeed[683]:   141.759078] [ERROR][XORG] (EE)
2013-05-17T23:17:28.761864+02:00 linux-ct1k bumblebeed[683]:   141.759822] [ERROR]X did not start properly
2013-05-17T23:20:13.658456+02:00 linux-ct1k bumblebeed[683]:   306.659345] [ERROR][XORG] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
2013-05-17T23:20:13.659536+02:00 linux-ct1k bumblebeed[683]:   306.659383] [ERROR][XORG] (EE) NOUVEAU(0): [drm] error opening the drm
2013-05-17T23:20:13.659567+02:00 linux-ct1k bumblebeed[683]:   306.659393] [ERROR][XORG] (EE) NOUVEAU(0): 820:
2013-05-17T23:20:13.660029+02:00 linux-ct1k bumblebeed[683]:   306.659401] [ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.
2013-05-17T23:20:13.660602+02:00 linux-ct1k bumblebeed[683]:   306.659409] [ERROR][XORG] (EE)
2013-05-17T23:20:13.661048+02:00 linux-ct1k bumblebeed[683]:   306.659421] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
2013-05-17T23:20:13.661463+02:00 linux-ct1k bumblebeed[683]:   306.659429] [ERROR][XORG] (EE)
2013-05-17T23:20:13.662019+02:00 linux-ct1k bumblebeed[683]:   306.659875] [ERROR]X did not start properly

/var/log/Xorg.8.log content file

X.Org X Server 1.14.1
Release Date: 2013-04-17
   306.542] X Protocol Version 11, Revision 0
   306.542] Build Operating System: openSUSE SUSE LINUX
   306.542] Current Operating System: Linux linux-ct1k.site 3.9.2-1.g04040b9-desktop #1 SMP PREEMPT Sun May 12 14:53:56 UTC 2013 (04040b9) x86_64
   306.542] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.9.2-1.g04040b9-desktop root=UUID=2ee6c3da-6d8b-4e7f-a676-a44cc2d166d4 ro quiet splash=silent "acpi_osi=!Windows 2012"
   306.542] Build Date: 02 May 2013  03:47:46PM
   306.542] Current version of pixman: 0.28.2
   306.542]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
   306.542] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
   306.542] (==) Log file: "/var/log/Xorg.8.log", Time: Fri May 17 23:20:13 2013
   306.542] (++) Using config file: "/etc/bumblebee/xorg.conf.nouveau"
   306.542] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
   306.542] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
   306.542] (==) ServerLayout "Layout0"
   306.542] (==) No screen section available. Using defaults.
   306.542] (**) |-->Screen "Default Screen Section" (0)
   306.542] (**) |   |-->Monitor "<default monitor>"
   306.543] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
   306.543] (**) |   |-->Device "DiscreteNvidia"
   306.543] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
   306.543] (**) Option "AutoAddDevices" "false"
   306.543] (**) Option "AutoAddGPU" "false"
   306.543] (**) Not automatically adding devices
   306.543] (==) Automatically enabling devices
   306.543] (**) Not automatically adding GPU devices
   306.543] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
   306.543]     Entry deleted from font path.
   306.543] (==) FontPath set to:
   306.543] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
   306.543] (==) |-->Input Device "<default pointer>"
   306.543] (==) |-->Input Device "<default keyboard>"
   306.543] (==) The core pointer device wasn't specified explicitly in the layout.
    Using the default mouse configuration.
   306.543] (==) The core keyboard device wasn't specified explicitly in the layout.
    Using the default keyboard configuration.
   306.543] (II) Loader magic: 0x802c20
   306.543] (II) Module ABI versions:
   306.543]     X.Org ANSI C Emulation: 0.4
   306.543]     X.Org Video Driver: 14.1
   306.543]     X.Org XInput driver : 19.1
   306.543]     X.Org Server Extension : 7.0
   306.543] (II) config/udev: Adding drm device (/dev/dri/card1)
   306.543] setversion 1.4 failed
   306.543] (II) config/udev: Adding drm device (/dev/dri/card0)
   306.543] setversion 1.4 failed
   306.545] (--) PCI:*(0:1:0:0) 10de:0de8:17aa:21fc rev 161, Mem @ 0xc0000000/16777216, 0x80000000/536870912, 0xa0000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/524288
   306.545] Initializing built-in extension Generic Event Extension
   306.545] Initializing built-in extension SHAPE
   306.545] Initializing built-in extension MIT-SHM
   306.545] Initializing built-in extension XInputExtension
   306.545] Initializing built-in extension XTEST
   306.545] Initializing built-in extension BIG-REQUESTS
   306.545] Initializing built-in extension SYNC
   306.545] Initializing built-in extension XKEYBOARD
   306.545] Initializing built-in extension XC-MISC
   306.545] Initializing built-in extension SECURITY
   306.545] Initializing built-in extension XINERAMA
   306.545] Initializing built-in extension XFIXES
   306.545] Initializing built-in extension RENDER
   306.545] Initializing built-in extension RANDR
   306.545] Initializing built-in extension COMPOSITE
   306.545] Initializing built-in extension DAMAGE
   306.545] Initializing built-in extension MIT-SCREEN-SAVER
   306.545] Initializing built-in extension DOUBLE-BUFFER
   306.545] Initializing built-in extension RECORD
   306.545] Initializing built-in extension DPMS
   306.545] Initializing built-in extension X-Resource
   306.545] Initializing built-in extension XVideo
   306.545] Initializing built-in extension XVideo-MotionCompensation
   306.545] Initializing built-in extension XFree86-VidModeExtension
   306.545] Initializing built-in extension XFree86-DGA
   306.545] Initializing built-in extension XFree86-DRI
   306.545] Initializing built-in extension DRI2
   306.545] (II) LoadModule: "glx"
   306.546] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
   306.546] (II) Module glx: vendor="X.Org Foundation"
   306.546]     compiled for 1.14.1, module version = 1.0.0
   306.546]     ABI class: X.Org Server Extension, version 7.0
   306.546] (==) AIGLX enabled
   306.546] Loading extension GLX
   306.546] (II) LoadModule: "nouveau"
   306.546] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
   306.547] (II) Module nouveau: vendor="X.Org Foundation"
   306.547]     compiled for 1.14.1, module version = 1.0.7
   306.547]     Module class: X.Org Video Driver
   306.547]     ABI class: X.Org Video Driver, version 14.1
   306.547] (II) LoadModule: "mouse"
   306.547] (II) Loading /usr/lib64/xorg/modules/input/mouse_drv.so
   306.547] (II) Module mouse: vendor="X.Org Foundation"
   306.547]     compiled for 1.14.1, module version = 1.9.0
   306.547]     Module class: X.Org XInput Driver
   306.547]     ABI class: X.Org XInput driver, version 19.1
   306.547] (II) LoadModule: "kbd"
   306.547] (II) Loading /usr/lib64/xorg/modules/input/kbd_drv.so
   306.547] (II) Module kbd: vendor="X.Org Foundation"
   306.547]     compiled for 1.14.1, module version = 1.7.0
   306.547]     Module class: X.Org XInput Driver
   306.547]     ABI class: X.Org XInput driver, version 19.1
   306.547] (II) NOUVEAU driver 
   306.547] (II) NOUVEAU driver for NVIDIA chipset families :
   306.547]     RIVA TNT        (NV04)
   306.547]     RIVA TNT2       (NV05)
   306.547]     GeForce 256     (NV10)
   306.548]     GeForce 2       (NV11, NV15)
   306.548]     GeForce 4MX     (NV17, NV18)
   306.548]     GeForce 3       (NV20)
   306.548]     GeForce 4Ti     (NV25, NV28)
   306.548]     GeForce FX      (NV3x)
   306.548]     GeForce 6       (NV4x)
   306.548]     GeForce 7       (G7x)
   306.548]     GeForce 8       (G8x)
   306.548]     GeForce GTX 200 (NVA0)
   306.548]     GeForce GTX 400 (NVC0)
   306.548] (--) using VT number 7

   306.603] (II) [drm] nouveau interface version: 1.1.0
   306.603] (II) Loading sub module "dri"
   306.603] (II) LoadModule: "dri"
   306.603] (II) Module "dri" already built-in
   306.603] (II) NOUVEAU(0): Loaded DRI module
   306.658] (EE) NOUVEAU(0): [drm] failed to set drm interface version.
   306.658] (EE) NOUVEAU(0): [drm] error opening the drm
   306.658] (EE) NOUVEAU(0): 820: 
   306.658] (II) UnloadModule: "nouveau"
   306.658] (EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
   306.658] no screens found
   306.658] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
   306.658] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
   306.658] (EE) 
   306.658] Server terminated with error (1). Closing log file.

it’s like nouveau driver are user… would prefer nvidia one

any idea?

Follow the installation instruction of Smithfarm - the Brain: openSUSE 12.3: How to install ‘bumblebee’ for NVIDIA Optimus VGA that is similar to yours.

After dkms-nvidia installation modify Makefile described by opeepe and then continue with the installation order.


Done this. Perfect!
319.17 running on 3.9.2 kernel.

Thanks oopepe for that hint.


Thanks to everyone here for figuring this thing out! Unfortunately I’m not such an experienced Linux-pro and I’m having some troubles applying the fix:

The problem is the same - installing dkms-nvidia on openSuse Tumbleweed x64 → make is failing with exit status 2. So what I already did is modifying the Makefile but then what next? If I just go on with the procedure at Smithfarm, bumblebee wont work. Don’t I have to recompile something with the modified Makefile?

I already tried reinstalling dkms-nvidia, but it pulls down the driver from NVIDIA again and the changed Makefile is overwritten.

Kind regards,


Here’s what you have to do, it’s no more than forcing dkms to build the driver now:

su -c 'dkms build -m nvidia/319.17-2.1'

enter the root password when prompted for. If you editted the Makefile correctly the driver should be built. Easiest way to force the usage of the driver is to reboot. After reboot and relogin, open a terninal window and run the commands as shown above the output (bold typeface):

glosscomputer@laptop:~> **glxinfo2 | grep OpenGL**
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string: 3.0 Mesa 9.0.2
OpenGL shading language version string: 1.30
OpenGL extensions:
glosscomputer@laptop:~> **primusrun glxinfo2 | grep OpenGL**
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 610M/PCIe/SSE2
OpenGL version string: 4.3.0 NVIDIA 319.17
OpenGL shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL extensions:

the commands should output about the same, models may vary.

Thanks, that (almost) did the job!

I encountered two small problems, but was able to quickly solve them. So for all with the same issues:

  1. After the modification of Makefile described by opeepe
su -c 'dkms build -m nvidia/319.17-2.1'

was whining that the module was already built. I don’t know if it was too “brute-force” but i just deleted the folder


containing the faulty built module. After that dkms rebuilt just fine.

  1. After a reboot, I tried to run
primusrun glxspheres

but it failed with something like ‘* could not access secondary GPU *’
A little bit of internet search brought the solution:
[SOLVED] Nvidia Bumblebee optirun not working any more](http://ubuntuforums.org/showthread.php?t=2043971)

Apparently bumblebee.conf was missing some entries, so:

kdesu kwrite /etc/bumblebee/bumblebee.conf

The ‘Driver’ entry had to be eddited


After a reboot everything works :slight_smile:

Big thanks to opeepe and Knurpht for the quick reply! I’m really happy with my Tumbleweed now, with Kernel 3.9.2-8 especially the boot-up just flies!


I updated to kernel 3.9.6 because of some interesting news about usb audio.

Can’t build dkms nvidia anymore. Even if editing Makefile. That worked fine in 3.9.5.
But it seems not working anymore.
Anyone tried 3.9.6 kernel and bumblebee, to see if it’s my fault?

Yup, see here:

knurpht@laptop:~> primusrun glxinfo2 | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 610M/PCIe/SSE2
OpenGL version string: 4.3.0 NVIDIA 319.23
OpenGL shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL extensions:
knurpht@laptop:~> uname -a
Linux laptop.knurpht 3.9.6-13.g8ead728-desktop #1 SMP PREEMPT Thu Jun 13 19:23:10 UTC 2013 (8ead728) x86_64 x86_64 x86_64 GNU/Linux

To help you, we need output of the commands as shown above, and of the dkms command

solved, was editing the Makefile in the build folder instead of the one in source folder LOL lol!
all working now!

now I have another problem.
The pc boots with nvidia card ON.
I have to:

rmmod -f nvidia
echo OFF >> /proc/acpi/bbswitch

to turn card off.
Then running apps with optimus will work fine(turning the card off at the end) until next reboot.
I use proprietary driver in bumblebee.conf

I blacklisted nvidia (nouveau was already blacklisted) by adding “blacklist nvidia” to /etc/modprobe.d/50-blacklist.conf.
I created too /etc/modprobe.d/50-blacklist-nvidia.conf with “blacklist nvidia” inside. 50-blacklist-nouveau.conf exists too.

It seems nvidia module is still being loaded at boot.

# lsmod | grep nvidia
nvidia               9429642  1 
drm                   306733  6 nvidia,i915,drm_kms_helper

I already removed nvidia entries from /etc/sysconfig/kernel (even in yast)

grep nvidia /etc/sysconfig/kernel

is empty. Double checked in yast too. No more nvidia there.

I mkinitrd and reboot every time was needed.

this is /var/log/messages, cut to only show nvidia and bumblebee lines:

2013-06-18T20:45:08.710629+02:00 linux-vdyp kernel:    34.360743] bbswitch: version 0.7
2013-06-18T20:45:08.710641+02:00 linux-vdyp kernel:    34.360750] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.VID_
2013-06-18T20:45:08.710643+02:00 linux-vdyp kernel:    34.360755] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG_.VID_
2013-06-18T20:45:08.710644+02:00 linux-vdyp kernel:    34.361135] bbswitch: detected an Optimus _DSM function
2013-06-18T20:45:08.710645+02:00 linux-vdyp kernel:    34.361145] pci 0000:01:00.0: enabling device (0000 -> 0003)
2013-06-18T20:45:08.710646+02:00 linux-vdyp kernel:    34.361168] bbswitch: disabling discrete graphics
2013-06-18T20:45:08.721648+02:00 linux-vdyp kernel:    34.372617] thinkpad_acpi: EC reports that Thermal Table has changed
2013-06-18T20:45:08.831629+02:00 linux-vdyp kernel:    34.481969] pci 0000:01:00.0: power state changed by ACPI to D3cold
2013-06-18T20:45:08.831647+02:00 linux-vdyp kernel:    34.481975] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off
2013-06-18T20:45:08.832722+02:00 linux-vdyp bumblebeed[632]:    34.456053] [INFO]/usr/sbin/bumblebeed 3.2.1 started
2013-06-18T20:45:09.733886+02:00 linux-vdyp dkms_autoinstaller[612]: Done.
2013-06-18T20:45:09.734284+02:00 linux-vdyp systemd[1]: Started LSB: Automatically install DKMS modules for new kernels.
2013-06-18T20:45:11.428661+02:00 linux-vdyp kernel:    37.079705] nvidia: module license 'NVIDIA' taints kernel.
2013-06-18T20:45:11.428678+02:00 linux-vdyp kernel:    37.079709] Disabling lock debugging due to kernel taint
2013-06-18T20:45:11.553009+02:00 linux-vdyp dbus[646]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
2013-06-18T20:45:11.553018+02:00 linux-vdyp dbus-daemon[646]: dbus[646]: [system] Activating service name='org.freedesktop.nm_dispatcher' (using servicehelper)
2013-06-18T20:45:11.555930+02:00 linux-vdyp dbus-daemon[646]: dbus[646]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
2013-06-18T20:45:11.556386+02:00 linux-vdyp dbus[646]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
2013-06-18T20:45:11.677628+02:00 linux-vdyp kernel:    37.328478] nvidia 0000:01:00.0: power state changed by ACPI to D0
2013-06-18T20:45:11.677647+02:00 linux-vdyp kernel:    37.328481] thinkpad_acpi: EC reports that Thermal Table has changed
2013-06-18T20:45:11.677648+02:00 linux-vdyp kernel:    37.328502] nvidia 0000:01:00.0: enabling device (0000 -> 0003)
2013-06-18T20:45:11.677650+02:00 linux-vdyp kernel:    37.328636] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
2013-06-18T20:45:11.677651+02:00 linux-vdyp kernel:    37.328812] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
2013-06-18T20:45:11.677652+02:00 linux-vdyp kernel:    37.328816] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  319.23  Thu May 16 19:36:02 PDT 2013
2013-06-18T20:45:11.678557+02:00 linux-vdyp systemd[1]: Started Dynamic Kernel Modules System.
2013-06-18T20:45:11.679002+02:00 linux-vdyp systemd[1]: Starting Multi-User.
2013-06-18T20:45:11.679300+02:00 linux-vdyp systemd[1]: Reached target Multi-User.
2013-06-18T20:45:11.679531+02:00 linux-vdyp systemd[1]: Starting Graphical Interface.
2013-06-18T20:45:11.679738+02:00 linux-vdyp systemd[1]: Reached target Graphical Interface.

Overman79 repo. nvidia 319-23.1-1, kernel 3.9.6-1.g8ead728-desktop

why nvidia taints kernel and why is loading at boot if blacklisted and not in /etc/sysconfig/kernel?

could you help?