Nvidia and Security Questions


I have started to use OpenSUSE after experimenting with lots of other distros, and as a beginner have found all of my questions in other forums. However I cannot find anything specific enough (or that works for a couple of questions.

I installed 11.1 Gnome and played around with it but a few things kept cropping up, so I thought I would try the 11.1 KDE. I would like to stick with the KDE version but I am having a few problems. i would be grateful of any advice for the following:

1: I am running a NVidia GeForce 6100 Graphics card. Using gnome I installed the 2 drivers from the Nvidia repro as recommended (GFX G02 option as this worked under Gnome). When I reboot all the titlebars are missing, my keyboard only works in certain software, and the wifi dissapears completely. I have tried the options ‘default’ and ‘GFX G01’ and this only logs in as root without any graphical interface.

2: Amarok - I wanted to use version 2.0 but it does not recognise any of my music files (formerly from iTunes). Version 1.5 seems to recognise and play them all. the only thing it does pick up (and play) are the BBC podcasts.

3: Being new to Linux I am unsure of how it works in comparison to Vista. Does linux have Internet security type suites built in or do I need to install extra software like I would in Windows.


  1. I recently installed 11.1 on an old board with a geforce 6100 and found ‘manually’ installing the driver available on nvidia’s site worked better than those from the repo, I used the latest version. Having said that there were a few things that didnt work to my liking, suse 11 ran perfectly on the same board

  2. Did you install amarok-xine and change the engine to xine in amarok’s settings? That usually works for me with mp3s etc, though itunes format I’ve never used, but I’m sure someone on the forum uses itunes files with amarok 2.0, lets hope they post if switching the engine to xine doesn’t work for you

  3. Suse has it’s own firewall as well as Novell AppArmor, you don’t really need to install anything else although you might wish to use clamav and spamassassin in conjuction with your mails, if you use kmail and install both clamav and klamav you’ll find that klamav has a tool for integrating clamav with kmail that’s VERY simple, just one mouse click

Linux just isn’t susceptible to infections in the same way as windoze, many people hold the view that linux can’t be infected by viruses but that’s a whole other subject, just relax in the knowledge that the minute you switched to suse from vista you eliminated almost all risk of malware problems

There are other firewalls you could install but I’m not sure that any of them are any better than suse’s own built-in one, plenty of people are running servers behind suse’s own firewall so it should certainly be ample for a purely desktop machine. I’ve ran suse since version 10.2 as both server and desktop on nothing but what suse comes with, as well as the firewall in my router, without any problems whatsoever … at least none that I’m aware of

There are people far more knowledgeable than me on security issues using the forum but I’m sure they’ll tell you that the above is basically correct even though I don’t doubt they could go into far greater detail

Thanks for the reply Ecky.

Nvidia - I am attempting to manually install the driver. I have played around with root commands (as I know none) and have eventually got the .run file to start up. It says it can’t find the driver and needs to access the internet to find it.

As I have to execute the .run file with no x server, what command do I use to start a network connection prior to executing the file to give access the the internet.

Amarok - I could not find an option in 2.0 to change the engine to xine. Unlike 1.4.1 where there is a tab for it. I have got the xine installed anyway.

Thanks for clarifying the security question. This makes sense and confirms what I thought, its only when Windows user fire questions about it I confuse myself.

As I have to execute the .run file with no x server, what command do I use to start a network connection prior to executing the file to give access the the internet.

don’t worry, simply say No to looking for pre-compiled drivers/modules on internet and it will start compiling your driver. If you say yes, it won’t find them anyway, so it will start compiling the driver anyway.

linuxoidoz is spot on, it’s the driver’s kernel it’s looking for on the net and there never is one, it just compiles it all by itself

One thing though, when the driver install finishes it asks about running nvidia-xconfig to initialise the driver, decline that

Use this command instead: sax2

Some will say to use sax2 -r -m 0=nvidia, but simply running sax2 has always worked for me, once sax has run, first type exit to ‘un-become’ root

If you get a login prompt, login as the user you configured for yourself when instaling and type: startx

If you’re aready logged in as that user and don’t get a login prompt, just type: startx

That should take you into your desktop

As for Amarok, to select xine as your engine it should be here: Settings, Configure Amarok, Engine, then you should see a Sound System drop-down box that currently says: Gstreamer/Yauap Engine, see if you can change that to xine

If you can change it, set it and click Apply, then OK, no need to alter anything else in the options that suddenly appear after clicking Apply

I disagree here better to answer yes to all the questions during the install and
reboot when done


Well using sax2 is the way most suse-nvidia howto pages say to do it, and it’s always worked well for me

But like most things there isn’t necessarily one way and one way only that works, one such page does say that it shouldn’t be necessary to use sax in suse 11 so one would assume it to be true of 11.1 also

I suppose it’s the way I’ve become used to after doing it that way for the past few years, and it definitely still does work, I did it that way on a laptop just recently and it’s working fine

Of course, you can just let nvidia-xconfig run and if it was to fail or just plain not have configured things to your liking, still go back and use sax as it would drop you back to a prompt anyway if it did fail

I have managed to install the NVIDIA driver manually after following your instructions and installing other bits it needed to run.

Unfortunately though the Nvidia driver gives the same result as the GFX G02 driver - no titlebars and no keyboard in suse applications, no wifi icon (although I am on internet).

Any ideas?

Also if I install anything manually will it appear in the install software application. If not how do you remove, not that I need to (yet), hopefully.

Are you using compiz or any other desktop effects.
If so try disabling it/them


Usually anything you install using an rpm file shows up in Yast’s Software Management, to uninstall anything that shows there clear the tick out of the checkbox to to the left of the program name then click the Accept button

One reason why you wouldn’t see a wi-fi icon could be that it’s configured to use ‘traditional method with ifup’, you can check if this is the case in Yast, Network Devices, Network Settings on the Global Options tab

If it is the case and you really want a connection icon in the tray change ‘Traditional method with ifup’ to ‘User controlled with Netwok Manager’ on the Global Options tab and click Finish

Regards your graphics driver, I don’t know whether you checked compiz/desktop effects after geoffro’s post or not, but something else to look out for that indicates the nvidia driver is properly installed and initialised is seeing an nvidia splash screen as your machine boots up … you can’t really miss it as it’s got a great big green nvidia icon on it, although it can flash by pretty quick on a fast machine

Still not working.

NVIDIA is definitely activated at log-in and all desktop effects are turned off. Still no titlebars or keyboard in suse applications. If I open up certain applications like ‘configure desktop’ I can’t get rid of them even if I restart the PC. i have managed to type by logging out and back in as failsafe option.

I have tried to re-install Opensuse to clear the Nvidia problem. When it booted up again it seemed fine, but then after restarting it re-set itself back to as it was. Any suggestions as to how to sort it out or to uninstall the Nvidia driver. As I installed it manually I don’t know how to remove it using root commands.

I have tried ‘rpm -e nvidia’ but it says it does not recognise software.

Also with the Amarok I cannot find any option to use xine in the version 2.0.

To uninstall the package you installed with the .run file you use the same command as for installing it but add --uninstall to the end of the line

rpm -e only works for packages installed from an rpm (at least I believe that’s right)


sh NVIDIA-Linux-x86_64-177.82-pkg2.run --uninstall

I doubt whether that will solve your issues though, unless they only appeared after you installed the nvidia driver perhaps

You seem to have a whole bucketload of issues going on there, probably needing a deeper look at what’s going on with the system than someone like me can give, from a few forum posts at least (although trying a newer graphics card may help with some of it if you have one, may at least help you narrow down whether it is in fact the graphics causing your problems)

If no-one more knowledge here is able to help you, if it were me I’d then think about installing an earlier version

I’ll be perfectly honest with you mate, and I hope no-one gives me a rollocking for this, but I did a test install of 11.1 on a spare drive and quickly decided I’ll be sticking with suse 11 on kde 3.5 probably until 11.2 comes out when I’ll do another test install, and if you’re on a geforce 6100 I suspect my hardware is considerably more up to date than yours, mine’s a 1gb geforce 9850 on a dual core amd 6000 with 8gb of ram

If you do wanna try an earlier version you can get them here:

Index of /distribution

It has seemed to boot up okay now that I have done a re-install but it still hasn’t sorted the graphics driver problem out.

Its a bit odd though that I was using Gnome 11.1 with Nvidia installed and working fine, using emerald and Fusion animations, but for some reason its a no show with the KDE 11.1. I have experimented with KDE and Gnome, and to me I like the KDE as it appears a bit sharper and cleaner appearance, plus it runs a bit prompter on my set-up than the Gnome.

You might be write about using 11.0, I was running 11.0 Gnome for a few weeks in December when I started getting into Linux and it all worked fine - except when I played too much and buggared it all up every now and then. I don’t really know enough anyway about what difference their is between the 3.5 and 4.0.

Thanks for your help though, at least I have a lot more points to add to my ‘Thats what that means then!’ root command list. Plus trying these things out meant I had an explore of bits I haven’t needed to before.

KDE 3.5 is an older and more ‘mature’ version of the kde desktop than KDE 4/4.1

3.5 was the final version in the 3 ‘series’ before it moved on to 4

Obviously an awful lot of work goes into a desktop environment and it wouldn’t be fair to expect a completely new version to have everything spot on with the first couple of builds as soon as it’s released for every possible computer configuration, there will always be bugs that need ironing out in any program

If every program was perfect ‘first time’ there probably wouldn’t be any need for new versions of anything, and the kde 4 series will improve in allsorts of areas as it matures

People using it and reporting bugs is all part of that process however, otherwise the developers wouldn’t know what needed fixing, the reason I’m not using the latest versions at the moment is that I have one machine for both server and desktop functions

My wife’s board died so she has my desktop for the moment until I rebuild hers, once I get it back this machine will go back to being a server only and my desktop will be getting the latest versions of both Suse and KDE, albeit as a dual boot to begin with

Provided you have the drive space it’s not too difficult to have two versions of Suse installed, when 11 came out I kept my 10.3 when I first installed 11 until I was happy with how I had 11 working, and even had both versions using the same home partition successfully at one stage

If you were so inclined you could do the same with 11 and 11.1 and benefit from the useability of 11 as well keeping up with cutting edge of things that is Suse 11.1 on the latest kde, it’s what I’ll be doing when I do get my desktop back

Whatever you decide to do, best of luck with it :wink: