NVIDIA and "could not open default font 'fixed'"

hello,

I just installed 11.1 on brand new box. This is 64bit system based on Intel Core i7. I’m not writing this in 64bit sub-forum because I do not know if it is a 64bit-specific problem.

installation was smooth. obviously Xserver was configured to use opensource ‘nv’ driver and is working OK with this driver.

Then I wanted to install NVidia binary drivers. I used 1-click install from opensuse.org wiki. Configuration was fine but Xserver dies with fatal error:
“could not open default font ‘fixed’”

from X log file I see that all font paths were excluded with “no such file or directory” :o

the funny thing is that when I just change xorg.conf back to use ‘nv’ driver instead of ‘nvidia’ in Section Device then X work flawlessly. so fonts are ok and in place.

any hints?

thanks in advance!

Well, one suggestion would be to back up the xorg.conf file and then change the device line containing the ‘nv’ driver to ‘nvidia’ and restart it.

The other would be to have you post the x11 log file and let the forum have a go at it.

I reinstalled opensuse for another reason and it works, at least Xserver starts.

However, I have another problem - EDID from my flat panel is not acquired correctly. Flat panel is LG L245WP, connected to Gainward GeForce 9800GT via DVi-HDMI cable. X should start in 1920x1200 native mode but instead it detects flat panel as HDTV and starts in HDMI 1080p mode. :frowning: screen is shifted to top-left corner and looks really ugly. This is a known problem and can be overcomed in windows by tweaking .inf files to override wrong EDID information, but how to do this in Linux???

The funny thing is that my 2nd machine with old GF 7600GT AGP card works perfectly well with this panel… this machine is running opensuse 10.3 32bit with nvidia driver 173.14.12.

ok, problem can be workarounded by using custom EDID file.

steps:

  1. shutdown (required to fully reinitialize graphics output)

  2. connect flat panel to graphics card using old-fashioned vga (DSUB) cable

  3. start linux, login to X and start nvidia-settings

  4. run Acquire EDID and save edid.bin to some directory

  5. add the following line to your /etc/X11/xorg.conf in Section Device for graphics adapter:
    Option “CustomEDID” “DFP-0:/full/path/to/edid.bin”

DFP-0 is Digital Flat Panel connected to 1st DVI connector on your nvidia card

be sure to put propoer path to edid.bin.

  1. reboot (again required to fully reinitialize graphics output)

  2. be happy with nice resolution :slight_smile:

As you seemed to be happy to share the solution, I went ahead and added it to the hcl over here.
Bit rude of me I guess, so if you want it removed feel free to do so yourself, or send me a private message and I’ll undo my actions.

perfect, thanks.