Nvidia all problems

I’m sorry for a likely incorrect positioning …
I’ve been using (open)suse for some years and (other version) linux for some more.
I am not an expert though, but I didn’t have big problems so far untill the recent
opensuse 11.3 release(been using since 9.something).

My machine:

  • processor:
    AMD Athlon™ 64 Processor 3500+
    motherboard: (I havent data , but can look for if useful)
  • GRAPHIC CARD:
    NVIDIA GeForce 6200 TurboCache™

Clean Install of opensuse 11.3 (64 bits) Linux 2.6.34.7-0.7-desktop x86_64

Well, this is my last attempt to have graphics working… I tried:

  1. Default install
  2. Installing with “one click” proprietary graphics from nvidia
    (with and without repo )
  3. Installation the hard way …

NOTHING WORKED … I’m using the failsafe option… Untill my upgrade to 11.3
I had version 11.1, with Nvidia proprietary drivers, installed the “hard” way and
everything was perfect…

I don't know if the problem is the 64 bit version (everything began with this

and the firefox-plugin of adobe… )
I have read the wikis, in and out suse … forums, etc. etc… and

  1. the solutions are similar but NOT exactly the same …(blacklistint nouveau or not… options in grub or not… ) I tried ALL of them and no one worked … for someone not an expert this is a bit dissapointing…

  2. the last clean install with default installation seemed to work but after a weeks
    or so, and upgrade of several package (via yast2) we went back to previous problems.

    problems:
    Desktop freezeng (for several seconds)
    and worst corrupted graphic (going to ctrl + alt + f9 and back solves the problem
    the first times, then a reboot is unavoidable …

    I have also read about some bugs in the official nvidia drivers… I have read almost everything (including those than say to have solved the problem…)
    NOTHING DEFINITIVE…

    HELP… I’m getting crazy … I don’t want to change distro…

Did you read the openSUSE-11.3 release notes and follow what it had to say about “Initializing Graphics with KMS (Kernel Mode Setting)” ? ie did you FIRST, when trying again after the failed driver installation attempts to set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards and Reboot your machine?

Did you also use the ‘nomodeset’ as a boot code when booting to run level 3 so as to install ‘the hardway’ ?

Reference your failed attempt to install “the hardway” did you remove the rpms from the failed attempt to install via the repository method ? If you did not, then that probably doomed ‘the hardway’ from the start.

Can you provides us the EXACT file name that you tried to install the hardway?

Given you did NOT mention following the release notes, and given you did NOT mention ‘nomodeset’ and given you did NOT mention setting the NO_KMS_IN_INITRD sysconfig variable , I sort of suspect that is where your problem might be.

Well, nvidia graphics cards have these problems. AMD ATI RADEON graphics cards are full compatible with opensuse linux.
Do you read this? SDB:NVIDIA drivers - openSUSE

If you want to install nvidia card to your operating system do this

Just activated the Nvidia repository and once back into the software management you will be automatically selected by the binary nvidia drivers to install.

I understand that you have many problems with nvidia, Just change philosophy and buy amd ati radeon. This graphics card which I use is written on my signature.

If you want to upgrade there is a easy way
do this:

a)choose ALT+F2
b)Write this kde(gnome)-terminal.
c)On terminal write this: su -c “yast2 repositories”
d)The category of software repositories, select all sources of 11.2 and disable. That happens if you select them all and click the Enabled that it is not enabled. Click OK when finished.
e)Thereafter open a Gnome(kde)-terminal and run commands to add the source for 11.3.
su root

zypper ar -f Index of /update/11.3 “openSUSE 11.3 Updates”

zypper ar -f Index of /factory/repo/oss “openSUSE Factory Oss”

zypper ar –f Index of /factory/repo/non-oss “openSUSE Non-oss”

f)Start the upgrade with the command:su -c “zypper dup”
g)Choose enter to start download packages. Select (y) is yes and complete the upgrade.
h)Reboot your system.
I)Get in your account
J)That’s all.

If you want to upgrade try on it. It is easy;)

stamostolias, … without doubt we appreciate your efforts to help, … but I am struggling to understand the relevance of your post to help the OP install the proprietary nvidia driver. Adding OSS, Non-OSS, and Update again, which are already in place by default, is IMHO not going to solve anything.

Sorry, I thought that “I tried ALL” was a shortcut, … anyway the answer to all questions is YES… I didn’t want to get too long.

    I read the openSUSE-11.3 release notes (that appartently are in constat change..) and I set, NO_KMS_IN_INITRD=YEs (with yast), I also tried

mkinitrd before rebooting, and of course add nomodeset (this is one of the paramenter that depending of the forum/threard is differenttly set…)
I also removed all packages (besides being black listed … )… never got the NVIDIA logo when I installed the “hard way” (I got it before with 11.1)…

  two little notes:
         I have other 11.3 box (AMD Athlon(tm) 64 X2 Dual Core Processor 6000+   with newer nvidia   card GeForce 9400 GT )  and the default install
         (with noueveau etc.. ) works fine ...(god so far..!)
         I also tried, update the kernel (since in other post/forum) read about problems with the current kernel.... (and recompile etc..) same, same
         problems ...
and one more:
         Apparently everything was ok, when I run:  sh NVIDIA-Linux-x86_64-260.19.12.sh  (well a newer version...)..
       
    puffffffffffffff..
         Thank you very much for all your support..

How about trying with an older version of the Nvidia driver? Like 256.53: NVIDIA DRIVERS 256.53 Certified

You’re probably right, however while I can change easly to another distro, I can do nothing regarding a change in the graphics card…

Uhmmm, I’ve tried so many things that I am not sure about this one… I have played definitively with several drivers
but always the last one (and the update some time after…) just because somewhere I read about possibel bugs … etc

  thanks !

I’ve set up a few machines using nvidia through the 5,6,7,8,9 and Gts series and after spending a day or two on each of the cards through the 5-8 series I gave up on the nvidia drivers with them, could only get them working properly on the geforce 9 and gts cards

I found they worked a lot better using the driver suse comes with, but I did have to make some changes to 50-monitor.conf and 50-screen.conf (found in /etc/X11/xorg.conf.d) files by adding modes generated using cvt to get decent resolutions, may be worth you trying the same approach if you haven’t already

The error message says puffffffffffffff ??? Is that with 13 or 14 f’s ??

… serious thou, … do you get any errors ? What does the /var/log/Xorg.0.log file tell you ? I assume you installed kernel-source and kernel-syms of the same version as your kernel ?

I did ask for EXACTLY what name of file you attempted. I guess you are not able to tell me ?

The most current version is here: NVIDIA DRIVERS 260.19.29 Certified

sorry, I do have the two or three drivers I have used, unfortunately I am not in the same place than that machine, those are however
the one you can download when you are in the nvidia page, and ask for drivers: Geforce 6200 ™ Turbo.(and linux 64)

here the web page:

NVIDIA - Download Drivers

and the file is what you say: NVIDIA-Linux-x86_64-260.19.29.run , the one you can get on friday 21:49 gmt

I have been through this problem quite a while so that is why there were one or two upgrades…

The log didn’t say much, - I can include on Monday, thou,… maybe more interesting is the error when ctrl + alt +f9 (in the case of desktop crash.)
and the alt f10, don’t remember literally but something like " attemp to yield cpu atom?? …" sorry …
I also read about problem with kde 4.4 so, I included composite disable … (at some point) without any results … again in some other place
about the difficulties in sorting these problems out since there are so many places where modules are loaded and unloaded etc. that is
really complicated to put everything in “the same direction”, thus in some place it is recommended to add the “nvidia” name manually (in the xorg.config .)
well too many things…

Thanks, I will try to put everything line by line, and if I can the different ways of "solving" the problem (with references), today I upgrade the

kernel (official upgrade) so I will try once again the installation, I will documment everything… Do you recommend a) one click install b) the “hard way”
I have used (untill his 11.3) the “hard way” without problem.

     Many thanks again..

NOTHING WORKED … I’m using the failsafe option… Untill my upgrade to 11.3
I had version 11.1, with Nvidia proprietary drivers, installed the “hard” way and
everything was perfect…

I gave him a easy way to upgrade his operating system because he has problems.Regarding the graphics card to solve this problem without changing distro is to buy amd ati radeon. I have this card and I have not problems wihtout drivers. Only Drivers I have are amd drivers for motherboard’s chipchet, amd programm for 3d acceleration and amd profiler for cpu, nothing else.

Well, nvidia graphics cards have these problems. AMD ATI RADEON graphics cards are full compatible with opensuse linux.
Do you read this? SDB:NVIDIA drivers - openSUSE

If you want to install nvidia card to your operating system do this

Just activated the Nvidia repository and once back into the software management you will be automatically selected by the binary nvidia drivers to install. 

CPU: AMD PHENOM II X3 ΣΤΑ 3,7 GHZ

I gave you 2 solutions to your problem.

I appreciate your comments and efforts to solve my problem, but I thought I have made clear that almost “all” standard procedures
included in the release notes, sdb: nvidia drivers, wiki etc… have been used without success. It might happen that some of the many ways (very similar,thou) of configuring the graphics card was donde incorrectly. Nevertheless, I can not change (at least easily) the graphics card and more importantly, I have been working with all repositories than I know or could find (this include the nvidia repository, the factory, the kernel repositories etc. etc…, so the second option of
activating the binary drivers has also been used. In this last case the correct driver were selected (according to the installation precedures etc…) but still
something is not working: a) with the default clean install (with nv, or noueveau drivers), b) with easy 1-click install, (with and without the repository way)
c) the “hard way”, even the command :% sh NVIDIA-Linux-x86_64-260.19.29.run declared that everything was fine … etc. etc…

  Many thanks again...

On Sat, 08 Jan 2011 17:06:01 +0530, ppcm <ppcm@no-mx.forums.opensuse.org>
wrote:

>
> I appreciate your comments and efforts to solve my problem, but I
> thought I have made clear that almost “all” standard procedures
> included in the release notes, sdb: nvidia drivers, wiki etc… have
> been used without success. It might happen that some of the many ways
> (very similar,thou) of configuring the graphics card was donde
> incorrectly. Nevertheless, I can not change (at least easily) the
> graphics card and more importantly, I have been working with all
> repositories than I know or could find (this include the nvidia
> repository, the factory, the kernel repositories etc. etc…, so the
> second option of
> activating the binary drivers has also been used. In this last case
> the correct driver were selected (according to the installation
> precedures etc…) but still
> something is not working: a) with the default clean install (with nv,
> or noueveau drivers), b) with easy 1-click install, (with and without
> the repository way)
> c) the “hard way”, even the command :% sh
> NVIDIA-Linux-x86_64-260.19.29.run declared that everything was fine
> … etc. etc…
>

for many users problems with nvidia began after version 256.35–up to and
including that version, i’ve seen very little problems in these forums.
i’m not sure if you’ve tried that already, but as far as i remember,
you’ve tried the latest drivers, from various sources.

i think it might be worth the trouble trying this outdated driver, which
is available here: ftp://download.nvidia.com/XFree86/Linux-x86_64/256.35/
(64bit).


phani.

OK, these are some more test. Besides some other discussion forums (where the problems with nvidia seem more than huge), I have
basically look at:

SDB:NVIDIA the hard way - openSUSE
Install Nvidia driver with openSUSE 11.3 while there is no repo - Jobapedia
(and the release notes etc…)

A) With a clean install, it apparently works,… the right drivers etc. are selected etc. Then there are some freezes (see messages
below), and after a while, desktop corruption a back to reboot … (sometimes can be solved temporarily with CTRL + ALT + F9 (and back)
The nouveau driver is selected by the way …
************> I have read that the problem with the adobe plugin (npviewer.bin …) is unrelated however iit usually happens (the freeze)
after problems with this plugin (when will we get rid of the wrapper???)

tail of /var/log/messages (related or not to the current problem)

b2c000]
Jan 10 12:34:42 famjc kernel: 2169.554099] npviewer.bin[8394]: segfault at 0 i
p 00000000f60f4db1 sp 00000000ff9ae8f0 error 4 in libflashplayer.so[f5d56000+b2c
000]
Jan 10 12:39:40 famjc kernel: 2467.466250] npviewer.bin[8438]: segfault at 0 i
p 00000000f60f9db1 sp 00000000ff9c36c0 error 4 in libflashplayer.so[f5d5b000+b2c
000]
Jan 10 12:41:20 famjc acpid: 1 client rule loaded
Jan 10 12:41:32 famjc kernel: 2575.510061] NVRM: Xid (0005:00): 8, Channel 000
00000
Jan 10 12:41:32 famjc kernel: 2577.510031] NVRM: os_schedule: Attempted to yie
ld the CPU while in atomic or interrupt context
Jan 10 12:41:32 famjc kernel: 2579.548112] NVRM: Xid (0005:00): 2, CCMDs 00000
000 0000357c 00000224 00000000 00001000
Jan 10 12:41:32 famjc acpid: 1 client rule loaded
Jan 10 12:43:21 famjc kernel: 2688.511392] NVRM: Xid (0005:00): 13, 001e 31415
90c 00000019 00000104 00000000 00000800
Jan 10 12:43:29 famjc kernel: 2696.511101] NVRM: Xid (0005:00): 8, Channel 000
00002
etc…

B) I upgrade several packages … same problem…

c) Following Phanisvara suggestion, I installed and older driver: NVIDIA-Linux-x86_64-256.35.run

D) Procedure:

++++++++ ON THE DESKTOP ++++++++ 

-2) yast2 window -> system -> boot loader -> (edit) your-default/desktop
(in Optional Kernel Command Line Parameter , ADD ) nomodeset

-1) yast2 window -> system -> etc/sysconfig/editor ->
go to kernel || then click: NO_KMS_IN_INITRD

  /etc/sysconfig/kernel and set NO-KMS-IN-INITRD = yes

COMMENT) in the wiki  [SDB:NVIDIA the hard way - openSUSE](http://en.opensuse.org/SDB:NVIDIA_the_hard_way)

Steps -2), -1) are not placed anywhere in the timeline, indicating when they should be done, it might be done
with yast in console mode but is more complicated (??), I did it first.
 PROBLEM: This is madness, I would say that after the clean install, I had  "NO-KMS-IN-INITRD = no", I might be wrong, but IT has been set to
          yes (by who??) ---&gt;  may it happen that and update of the "default installation" has changed this to "yes"

          Moreover, this would imply "nouveau" is not used but 
          neither blacklisted .... then somehow is used and corrupt ..


       MAYBE that is it will work.... WRONG after some minutes back to the end of point A) ... so lets continue installation..
  1. su

  2. root-user % init 3

  3. sh NVIDIA-Linux-x86_64-256.35.run ( an old driver … other person suggestions…)

  4. modprobe nvidia

  5. echo “blacklist nouveau” >> /etc/modprobe.d/50-blacklist.conf (this could also be done previously…)

  6. mkinitrd

(So this is not the exact step-by-step procedure … or is it?? )

NOTE: it is not deleted the “nouveau” package (since it is black listed)

Two last thins I rebooted (no rcxstart etc.), and between 2) and 3) I went to desktop again, I came from a clean install and forgot the
kernel source … everything was fine …

NO NVIDIA logo pufff (only 3 f) .... apparently everything ok...  several minutes again  ...... DESKTOP corruption..

I have the other drivers I installed…

NVIDIA-Linux-x86_64-260.19.12.run
NVIDIA-Linux-x86_64-260.19.21.run
NVIDIA-Linux-x86_64-260.19.29.run

I will try one of them and I am afraid I won’t work… and I will quit…

Thank you very much to everybody for your help... really puzzle that graphics card that is "almost and standard" can perform nowadays

so badly and give so much trouble … too much …

Thank again …

Did you consider and reject the possibilities that this might be

  • poor quality installation CD/DVD and
    *] possibility of a hardware problem (such as failing power supply not being strong enough to support your NVIDIA GeForce 6200 TurboCache™ graphic card)

ppcm wrote:

>
> stamostolias;2275090 Wrote:
>> I understand that you have many problems with nvidia, Just change
>> philosophy and buy amd ati radeon. This graphics card which I use is
>> written on my signature.
>
> You’re probably right, however while I can change easly to another
> distro, I can do nothing regarding a change in the graphics card…
>
I use a GS8400 on an Intel Motherboard with latest Nvidia driver with no
problems. Only thing I had to do was execute /usr/bin/nvidia-xconfig
after installing the hardway.( note I have KMS set to yes and nomodeset
on as per oldcpu’s comments. It has worked on 11.2, 11.3, and 11.4. when
I try from repo I get dependency problems with 11.3 and 11.4, but not
from hardway. Also I enter runlevel 3 from the boot command line. Login
as user and switch to root before running the nvidia installer.

Not sure if this will help any, looks like you have done everything I
do.


Russ
openSUSE 11.3 (2.6.34.7-0.7-default)|KDE 4.5.5 Release 1|
Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS
Nvidia 260.19.29|