Nvidia 9300GE recognized as Vesa Framebuffer on 11.1

Hi all,

I’ve some trouble with my graphic card (nvidia 9300GE, 256Mo) : It’s recognized by sax2 as a “Vesa frame buffer”.

I tried to install various drivers I found on the nvidia repository, or via the “One click install”, but I can’t get it to work… There are 2 scenarios (depending on the driver) :

  • I install the driver, run sax2 -r, and nothing change (X works, but with the vesa driver)
  • I install the driver, run sax2 -r, and have a black screen (X dosen’t work any longer)

I tried nvidia-xconfig, but It seems to break Xorg conf (startx fails with “no screen found” message)

Obviously I have a problem with nvidia driver… Which is the right one for me ? Anybody with a working 9300GE or acer aspire X3200 ?

Thanks

Try running sax2 -r and changing the driver in xorg.conf from vesa to nvidia.

I installed drivers recently for my 7950GT. When I ran sax2, my card was also recognized as “vesa framebuffer”. I thought the install had failed, but when I rebooted and ran

nvidia-settings

Everything was fine.

So if you see this same thing while running sax2 right after installing your driver, don’t freak out, just reboot and see what happens.

Thanks both of you,

I installed the last driver, ran sax2 -r, and reboot… My graphic card is now recognized as a Geforce 8200. I tried to check “enable desktop effect” in the control panel, but it says my card didn’t support any affect. So I tried nvidia-settings, but it said that the nvidia driver was not loaded. So I ran nvidia-xconfig… It wrote a new config file, but X doesn’t works any longer (black screen on startx). I have to boot in failsafe for X to work again… (sax2 -r fails to start and reconfigure X as well)

Any idea ?

Composite extension is disabled by default. Run sax2 -r, then go to your xorg.conf and delete the “Composite” “off” line in the Extensions section. This should enable desktop effects.

Make sure you run sax2 -r when X is NOT running, otherwise it doesn’t start.

Hi,

I had the same problem with an Acer M5201 desktop fitted (standard) with a Nvidia 9500 graphics card.

Using the Nivida source and compiling the driver worked fine and detected the card correctly and wrote a full X config file in /etc/X11/. Sax2 does not seem to want to detect the card. However the hardware listing under Yast is fine and shows all the details of the two installed display systems. Seems a shame to have to go back to nearly the old days of hand configuring the X Config file.

To recover from an X session that will not start because the config file does not have a working display, copy the backup xorg.config file over the newer one generated by nvidia-config. Both are to be found in /etc/X11/.

Nigel

After much travail, I believe I’ve discovered what may be a fairly common problem: sax2 only goes as far as the first video device it sees. Any built-in video chips are going to show up before an add-on card. Quite the opposite of what one might hope for, but there it is. I used “lspci” to figure out the correct “BusID” entry required in xorg.conf. I could then run sax2 without the “-r” and it all worked fine.

Just a side note here to get the desktop effects to work you need to run this

nvidia-xconfig --composite
nvidia-xconfig --render-accel
nvidia-xconfig --add-argb-glx-visuals -d 24

Either from the cli before x starts or in a console as su

Also tend to find installing the drivers the “hard way” tend to work better
as the nvidia drivers fix X if you answer yes to all the questions

/Geoff