Nvidia 8800 GTS on Gateway FX

Ok… my laptop is a Gateway FX and has an Nvidia 8800 GTS, im not new to Linux but i cant seem to figure this one out… Suse install completely but video is laggy… like doing ZigZags all the time, tried to test some screen resolutions but even when i try 800x600 the test is in 1440x900 or something like that… it is NOT testing what im trying to test… so im stuck with a ZigZagging screen and i cant do much on the system… can anyone help? Will be greatly apreciated… :slight_smile:

EDIT1: Sorry… forgot to mention… im using SuSE 11.2 :stuck_out_tongue:

Did you installed the NVIDIA Graphic driver provide from the NVIDIA Repository for openSUSE 11.2?

Yes… the ones that installed by default… instalation is clean, and on the X11 properties it says Nvidia 8800 GTS so i assume it installed correctly…

In a terminal run this command:

/usr/sbin/hwinfo --gfxcard

Reply with the output.

openSUSE never installs this driver per default, because this driver is on the server from NVIDIA.com. You have to do that manually. Or otherwise you can use vesa driver now ( thats the reason why it is so laggy ).

openSUSE has a good documentation about his products at the website. Did you ever read it? Not even about NVIDIA, nearly about anything! I would suggest you read the documentation.
And here is the documentation link how to install NVIDIA driver: Proprietäre NVIDIA-Grafiktreiber - openSUSE

Pilger before making a harsh reply like that (“Did you ever read it?”) you should consider my screen on SuSE its doing ZigZags so i can BARELY read anything! yes i know it has documentation, i said im not new to SuSE, i just CANT read it!

So… if it did not installed the NVIDIA drivers… why X11 config says my Video Card is an NVIDIA 8800 GTS??? make me think it did… so SuSE should work that confusing think out… not my fault!

Thanks for nothing dude! dont waste my time if your intention is NOT to help…

Mark… will try that out and Copy&Paste it to somewhere else i can get it out, if not ill try to take a screencapture somehow… next time i boot in SuSE, cheers buddy!

Joresarcos, after all the “dust settles” (or zigzags disappear) you could consider writing a bug report on one of the openSUSE graphic drivers. My guess is your PC is using the openGL “nv” driver, although it is possible it is using the “vesa” driver. Still, this should have worked automatically. Guidance for writing a bug report is here: Submitting Bug Reports - openSUSE

There was a change made between openSUSE-11.1 and 11.2, where in openSUSE-11.2 an effort was made to make automatic graphic configuration more automatic. … Unfortunately, that has not worked for everyone. :slight_smile:

The openSUSE-11.2 release notes had this to say:
openSUSE 11.2 Release Notes

YaST and X.Org Configuration (Keyboard, Mouse, Graphics Board, and Monitor)

In the past, YaST offered an configuration interface for the graphical desktop (X.org) such as keyboard, mouse, graphics board, and monitor. During the installation a suitable xorg.conf was created.

In most cases it is no longer needed because the Xserver is now able to automatically configure the system. If it fails for your system, try the following steps:

Check whether an old /etc/X11/xorg.conf file exists. If so, move it away and start your desktop again.

If it still does not work, run sax2 from the command line and execute the configuration procedure.

To adjust hardware components to your personal needs, start the GNOME desktop control center or Configure Desktop in KDE, and configure your devices such as the mouse or keyboard. The display configuration dialogs also let you configure multiple monitor setups. To configure multiple monitors, in other desktop environments, use xrandr.

For more information, see the Desktop User Guides shipping with openSUSE. They are also available from Documentation - openSUSE

Now there are typically 3 graphic drivers that are used with a nVidia card (although there is a 4th in the works), with these 3 being:

  • vesa
  • a generic video driver that works with almost all nVidia, ATI, Intel, etc … graphic hardware. Performance is poor, but compatibility is high. It is fairly robust in that it will work with various kernels and xorg apps without a need to rebuild the driver
  • nv
  • an opensource free (free as in free software foundation defintion of free - openGL) graphic driver specific for nVidia cards. Theoretically should work with all cards. It has better performance than the vesa driver, although its performance likely is not good enough for 3D/special desktop effects. It is fairly robust in that it will work with various kernels and xorg apps without a need to rebuild the driver
  • nvidia
  • the proprietary (free as n free beer) graphic driver. Best performance. Special desktop effects work with most average to new hardware. But very sensitive to kernel updates and xorg updates which can break the driver, forcing a rebuild of the driver
    Typically, with 11.2, the “nv” driver is setup by default.

Check if you have an /etc/X11/xorg.conf file. You probably do not. If you do, then move it somewhere (or rename it) per the release note recommendation and reboot. Does that help ?

If not, then try to force a custom graphic configuration by running a tool to create a configuration file for your graphics … that file being /etc/X11/xorg.conf file. You can do this by booting your PC to “run level 3” text mode, so you can change the driver. You can boot to “run level 3” by rebooting your PC and when the initial boot menu appears (where you select windows or openSUSE or openSUSE fail safe) press “3” (no quotes) so that “3” appears in the option line (with a space between it and the preceeding entry). Then select the openSUSE boot and boot the PC. It will boot to a text login. Login as a regular user. Once logged in, type “su” to switch users to root (administrator). Then send one of the following two commands to configure your graphics (assuming you have only one graphic device):

  • sax2 -r -m 0=vesa
    #that is zero equals vesa and it sets up a configuration for loading of the slower vesa driver
  • sax2 -r -m 0=nv
    #that is zero equals nv and it sets up a configuration for loading of the moderate speed nv driver that should now be set up ok, but did not succeed. Note you do not have to accept the sax2 suggestion, but you can say no to its resolution suggestion and it will give you an option to tune the resolution. You may wish to try something conservative intially.

Once you have exited sax2, then type “shutdown -r now” to reboot, and do not press “3” this time when rebooting.

Once you get a stable graphics, you can look at loading the proprietary graphic driver by following guidance here:

good luck.

Now THAT’s what i call a helpful post! THANKS A TON!!! :slight_smile:

Will try all that out and reply if im done… Thanks again! :slight_smile:

  1. It is not harsh, when i ask you if you have read that documentation, because the thing with the proprietary NVIDIA Driver which has the best performance for highend cards like 8800GTS, is not new. This documentation exists half a decade about that driver. If you are not new to SuSE, and you told me that i could have expect that you read it before. If you could read this forum, i could associate, that you can read the documentation about NVIDIA drivers to, so that you can understand why there is no NVIDIA proprietary driver included in openSUSE and why openSUSE uses another driver, which is free but works not everytime well with the latest highend cards by NVIDIA. You know openSUSE is free and includes only free software. NVIDIA is not free. Its not a thing openSUSE has to sort out. NVIDIA has to sort that out!

  2. So if the polite question “Did you ever read it?” is harsh for you, what is then “Thanks for nothing dude! dont waste my time if your intention is NOT to help”?

  3. I love to help everybody here with openSUSE, but that needs also some cooperation.

Thanks a lot!

1.- If SuSE is using VESA then it shouldnt say its using NVIDIA 8800 GTS… sorry, not NVIDIA’s fault. And im using a dual boot with Win7 wich is why i can read this Forum…

2.- You were harsh, i was harsh… simple!

3.- so far… you havent helped yet… i appreciate you try though…

  1. If SuSE uses Vesa it can still say you have got a NVIDIA 8800GTS installed in your computer. SuSE is not dumb and knows your graphic cards name also without the NVIDIA Driver.

  2. I just asked if you have read it, whats harsh on it?

  3. Hope your laptop is running now.

Have a nice night!

It can be a bit tricky at times, to tell exactly what driver is being used, if there is no /etc/X11/xorg.conf file.

One way that works sometimes, is per markcynt’s suggestion, which is to type:
/usr/sbin/hwfin --gfxcard
and look for a “Driver” entry, and see if it says “vesa”, “nv” or “nvidia”. For example, I am using the proprietary “nvidia” driver and I see:

  Driver: "nvidia"
  Driver Modules: "nvidia"

Another way is to examine the content of /var/log/Xorg.0.log and look to see if may tell you. For example, I am using the proprietary “nvidia” driver and I see:

(II) LoadModule: "nvidia"
(II) Loading /usr/lib64/xorg/modules//drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver

Sounds to me like you have no video driver installed from the repo. Try the following which worked fine for me (Geforce 8800 GT). I am sorry for any mistakes but I am currently at work using Windows XP so it’s all from memory! :wink:

edit -> Just found the one-click here which might help you with this! Nvidia Drivers

  1. Add the nvidia repository to your list by opening the administration tool YAST found under computer in your KDE menu. Enter the root password when prompted.

  2. Click on software in the left side of the screen and software repositories on the right. Names could be different but it should be the last option in the software section.

  3. Click add, select the HTTP option and click next.

  4. Enter only the following information and click next:
    Name: (come up with a name. Nvidia might be a good one :stuck_out_tongue: )
    server: download.nvidia.com
    Directory: opensuse/11.2/

  5. When you confirm all of this accept the key that it will prompt you for.

You’ve now added the Nvidia repository to your list. Now when you go to install software OpenSUSE should already have selected the nvidia drivers for you so you should just be able to install them by pressing ok. Ignore any error messages that might appear about a missing xorg.conf file because 11.2 doesn’t use this anymore.

Again, I’m working off memory here and it is known (to my wife) to fail!

When you either reboot or restart x by pressing ctrl - alt - backspace twice you should have a working nvidia driver and find that the graphics are smooth as silk!

It’s just identifying your card, not the driver.

Here’s what the command I gave you shows for me. I put the relevant output in bold and left out what doesn’t really matter.

mark@Family:~> /usr/sbin/hwinfo --gfxcard

  Hardware Class: graphics card
  Model: "nVidia GeForce 8800 GTS"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0193 "GeForce 8800 GTS"
  SubVendor: pci 0x3842 "eVga.com. Corp."
  SubDevice: pci 0xc813
  Revision: 0xa2
  **Driver: "nvidia"**
 Driver Modules: "nvidia"

If I didn’t have the driver installed the driver would be called “nv”.