Nvidia 8600gts, oS 12.1, install hangs with colored lines across black screen

I have been working on this for a good two weeks and have gotten almost nowhere. I have been reading on these forums and reading hosts everyday but am not having any luck.
Sgigabyte mono p4, western digital 500gb had, opensuse 12.1, nvidia GeForce 8600 gts 256mb memory, 8gb ram, intel quad core, the second generation of processors. Every time I try to install opensuse it hangs on reboot and shows a bunch of colored lines across a black screen. Last time I let it sit there for ten hours and rebooted with hard reset. Then it said boot manager was missing.

I am also having other problems, such as getting repos configured so I can listen to. Plus, and several other issues. I really want to get this up and running. I am in Minneapolis, mn. I am willing to pay someone to come to over, get it working, go through it with me so I understand. Can’t pay a whole lot but if you know Linux well this should be pretty easy.
Please post he or message me.

Also, feel free to post solutions here as well. I would still like to fix this on my own if I could.

Thank you verymuchfor any attention you are able to lend.

Did you boot with the option “nomodeset”? First thing to try. Then, as soon as you get a running system and an Internet connection, install the proprietary nvidia driver from nvidia repo.

I’m not sure how to do this as I can’t get to a boot screen. It doesn’t even finish installation. It just hangs there with the lines on the screen.
How would I enter “nomodeset?”

Enter “nomodeset” in the Boot Options just before booting.

Once you get openSUSE installed, open a terminal and enter the following commands to install the proprietary nvidia driver:


su -l
zypper ar [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia
zypper refresh
zypper install x11-video-nvidiaG02

That should be all you need to do.

Alternative is to install the nVidia proprietary driver. Recommend this approach over the previous post because you’ll get the following additional benefits

  • You’ll install the latest stable driver no matter what the version and name
    = By adding the repo, you can ensure the driver will always be automatically updated with a “zypper up”

When you reboot, when you arrive at the menu screen where you normally select “Normal” boot,

  • Click F5. Select Failsafe boot
  • When you’ve completed booting into “Failsafe,” open YAST.
  • Open Software Repositories.
  • Click “Add” button
  • Select “Community Repositories” radio button
  • Select nVidia Graphics Drivers repo
  • Click “Next” until you can “Finish” to complete adding the repo.

Then from a Root CLI execute the following commands,


$ zypper refresh
$ zypper update


If a new nVidia driver is offered, accept, install and reboot.
If a new nVidia driver is not offered, then execute the following command from the root CLI which should list all available nvidia drivers.


$ zypper search nvidia
{/CODE]

Select the most appropriate driver, more than likely a "Desktop" driver, or if you're a CUDA developer you can install the driver without a Desktop or Server designation by using the following command


$ zypper in drivername



Reboot.

Any nVidia GPU driver problems you're experiencing should be fixed, and you can boot into normal mode.

HTH,
TS

???
I don’t understand.

Believe the method you describe certainly works, but it’s a one-time install which does not automatically update.

By adding the nVidia repo, updates are installed automatically with all others using “zypper up” which greatly eases maintenance if you don’t mind automatically updating the graphics driver (some will have misgivings).

TS

Are you sure about that?

Hum … What do you thing this command does?

zypper **ar** [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia

Or shall I rather write:

zypper **addrepo** [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia

To achieve auto refresh - so that the driver gets updated with zypper up - you can add the -f option. But it’s optional and therefore not required.
That would be:

zypper **ar** -f [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia

in other words:

zypper **addrepo** --refresh [noparse]ftp://download.nvidia.com/opensuse/12.1/[/noparse]  nvidia

But you can modify the repo and add this flag any time whenever you decide to install the latest driver with zypper up (rarely needed, IMO).

zypper mr --refresh nvidia

Certainly no need to boot in failsafe mode*, launch YaST or click anywhere. :wink:

  • except for disabling KMS, but nomodeset will do it as well.

I cannot get to a boot screen. OpenSUSE does not install. That is what I’m having trouble with. It just freezes. I can do a hard reset, but it comes up with an error such as bootmanager not found. I can’t type anything in. There’s no way to get to a boot options screen.

Is there a way to do the “nomodeset” before installing?

Thanks for your previous replies.

How are you trying to install? DVD? Live CD? Do you see a menu? Which option do you select?

I am using a regular install DVD, not a LiveCD. I start up and see this screen and then it goes to the screen that gives these options and similar ones:
Boot from harddisk (doesn’t work)
New Installation
etc. (I’m at work and can’t remember the exact screen.)

I have not found any area to type anything in.

From that screen, once I make a selection (new installation) it goes to the license agreement, etc.

http://img201.imageshack.us/img201/2158/dvdnomodeset.png

When I install 12.1 final release x86_64 DVD on my PC, the install appears to be hung at the point where the install completed the kexec “reboot”. The screen is garbage. However I have found that the hard drive diode is still indicating some activity. I then wait until the diode ceases. Then I ctrl-alt-delete. Then I initiate a reboot by hitting the down arrow two times. Then I hit enter. The PC reboots to complete the install.

Ah. Perfect. Thank you, please_try_again. I will try that tonight. I wasn’t aware typing there was an option.
Incidentally, I’ve tried running the Rescue System, but it asks for a Rescue Login and password. I try my password and the root password, and nothing works. Is there a default password?

Hi lupejus,

Do you have an Nvidia card?

Yes. It is the same as yours and I am installing from the openSUSE 12.1 x86_64 DVD. In my case I even though I never bothered with the nomodeset parm, 12.1 installs fine with the workaround that I have previously listed. But since nomodeset has been mentioned I may try it out myself just the one time. BTW when you do get 12.1 up and running you don’t want to set nomodeset for 3D effects until/unless you install the nvidia proprietary drivers.

Correct me if I’m wrong but to permanently set the nomodeset option, I would edit this file:

/etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT=“nomodeset”

How do I not set nomodeset for 3D effects? Or does it do so automatically when nomodeset is on?

Thanks for the tip, lupejus

I tried please_try_again s tip and it worked fine. However the nomodeset boot parm is picked up by the install process and incorporated into the Optional Kernel Command Line Parameter. Because of this my monitor is set with a default resolution that is not the preferred one and the 3D effects won’t work. If you do not wish to use Nvidia’s proprietary drivers then you to go to YaST -> YaST2 - Boot Loader -> Hi-light the installed entry from the list box and Edit. This brings up the Boot Loader Settings: Section Management. Here you remove the word nomodeset from the Optional Kernel Command Line Parameter and click OK then reboot.

So I gather that you have installed 12.1. If you set nomodeset at the start of the install the 3D effects are not working. You don’t have to create a /etc/default/grub, which I would not do. You need nomodeset for the Nvidia driver. Opensuse 's 1-click install works fine. Otherwise use YaST -> YaST2 - Boot Loader -> Hi-light the installed entry from the list box and Edit. This brings up the Boot Loader Settings: Section Management. Here you can see the word nomodeset in the Optional Kernel Command Line Parameter box and simply erase the word nomodeset then click OK to close out and then reboot.

writing this is hard work but it sure make me think, I think.