NVIDIA 8400M and 8600 11.3 problems

Hi Guys,

Like a guy earlier today report a problem with Opensuse 11.2 working fine on his machine but 11.3 is not. I have somewhat the same problem. The default installation freezes randomly. I have seen this error before with Intel video cards but never with NVIDIA. Right now, I’m using VESA in failsafe mode and trying to install some drivers from this repo.

For anyone experiencing this issue, I’ll try and find a fix for this. (Hope their is one)

BTW, can anyone confirm when the official drivers for NVIDIA cards are coming out?

More info guys

The NVIDIA drivers stopped the machine from freezing. BUT (a really big but), CPU usage is very high. Right now, I’ve disable compositing that is enabled when the drivers are installed. That seems to calm things down a bit. Also, when copying files from NTFS partitions, it kills both my CPUs.

Is there a way that I can see a more detail CPU usage than what top or system manager can give me?

More info Again

Everything has settled down. I’ve tracked down the CPU usage due to some applications that crashed. The configure- KDE control module (hey I like to tinker), is one of the leading problems for me when i want to modify Kwin.

I’ve found that flash no longer uses one CPU but spreads the load across the cores. I guess they went multi-threading.

Well so far so good. I’m being really cautious now. Anybody faced problems like this? BTW, it was a clean install.


I had a little trouble loading the proprietary nvidia driver (built from nvidia download) in RC2. If you want to use nvidia’s driver, your safest option will be to disable modeset in the kernel. In theory, you should be able to do this by simply adding the ‘nomodeset’ argument to your kernel boot parameters. This did not work for me in RC2.

I had to edit /etc/sysconfig/kernel. Change the value of NO_KMS_IN_INITRD from the default value of “NO” to “YES”. Then run the command mkinitrd and reboot.

I had no problems running the nvidia provided bundle. The only issue I had was with kernel mode. From the problem you discribed, I suspect nvidia’s driver is NOT loaded on your box. The command hwconfig --gfxcard will tell you which driver is loaded. The proprietary driver is called “nvidia”. The default driver in 11.3 is called “nouveau”.

Have Fun!

Sebastian, you seem to be getting things under control. Keep us posted if there are any set backs…


Super *nix noob here, but I think I’m encountering a similar issue. 11.2 works great. Blanked the HD and installed 11.3 on a lappy with 9400M NVidia card, and on reboot I get through the Lizard loading screen, and then the screen blanks out and is filled with a bunch of vertical multi-colored lines :confused: Failsafe works fine.

Sabbyman: I’m used to being spoon-fed proprietary NVidia drivers in Kubuntu through the Hardware Driver Manager (finds them for you to download, single click install…super convenient for a novice). Could you explain how you got your card working, and how I might upgrade to the proprietary drivers to potentially solve this issue?

Step-by-step spelled out instructions would be greatly appreciated, though I realize you may not have all the time in the world to do so.


The nvidia driver needs to be installed manually at the moment until nvidia gets it’s driver repo in place for 11.3
openSUSE Graphic Card Practical Theory Guide for Users

SDB:NVIDIA drivers - openSUSE

Hello Mr. Noob … :),

If you don’t need to have high-performance opengl … as in games … try running with the opensource nouveau driver that is installed by default. I have been using it for about a week now; I might not go back to the proprietary driver.



I’ve got some suggestions for those who do a clean install on machines with 8400 to 9400 cards with opensuse 11.3 32bit. I suggest that you install the NVIDIA drivers as soon as possible. The Nouveau driver does not work. It freezes the screen completely. Sometimes I can’t logon the system. For any noobs out there, if you can’t login, try pressing Ctrl + Alt + Backspace to kill and restart X. It may take up 30 seconds to restart (No joke here). Try and boot into failsafe and install the drivers there.

After driver installation and reboot, the machine is somewhat laggy at first, so bear with it for at least 2 minutes. when configuring anything with Kwin, it hangs for a few seconds. It may seem frozen but it isn’t. SO just WAIT; at least for 30 seconds. CPU usage is very high when modifying Kwin with compositing on. fortunately, it automatically disables compositing. Turn it on when you are done.

One of my peeves is that USB headphones still need to be configured everytime I boot or startup from standby. So thats a delete and re-add so that both Flash and Amarok use the Headphones. Setting to default does little difference.

Anyone with the same experiences?