Nvidia 8400 GS Video Garbage

I didn’t see any solutions to this issue from all of the posts, upon posts, in attempts to be helpful. I too, have nothing but corrupted video now that I installed the One-click for this card. And yes, all patches were applied. I have installed twice thinking I might have overlooked something. I purchased this card for my second Linux box based on the “almost glowing” remarks on the HCL NVidia compatibility list. My 7600 works great on my other box, but I was trying to save some cash on my new box. I wanted to get something ready to test 11.2 with. I’ve have also done everything manually as well! So, does anyone have a viable solution? I’ve been using Unix for some 20+ years as an Admin and I’ve thrown everything at it I know – even stupid stuff. I guess I could just return the card, but I noticed that someone said they have it working with 11.2 already. More unfortunately – I’m very stubborn.

Thanks. I’ll take whatever recommends I get.


I would remove the stuff you installed, then do it the manual way.

Simply download the correct driver from nvidia.com, make sure you have the kernel source installed as well as make (search in yast for those).

Log into a VT as root (ctrl-alt-f1), run init 3, cd to the folder that contains the file you downloaded and run sh NV(press tab for autocompletion)

It should compile, you’ll figure it out.

Then run** nvidia-xconfig -composite** if you want desktop effects.

Next run** init 5**, press ctrl-alt-f7 and enjoy.

Oh, and don’t trust the 1-clicks again ;).

Well, everything is still corrupted. I only have the 32bit version, althought that shouldn’t make a difference. I still get what other people describe as as corrupted video. The person who said it worked well with 11.1 tested it with the PCI version which is what I have. I noticed you listed yours as an 8400m. Mine is just an 8400 GS PCI. I could have other issues with clock timing on the MB, but other people seem to have reported a similar problem as this. I can use the card in Frame-Buffer mode, but it is just so SLOW that I can harldy stand it. I would go buy another 7600 GS, but who knows if it will be supported on 11.2. I just need another workstation I can mess around on. I would have liked to have some great video to go along with it. Again, thanks for your time.


I have an 8400GS PCI (not PCI-e) graphic card, running in an old PC (a 32-bit Athlon-2800).

I first put this card in an Athlon-1100 PC, but although I could run Linux, the graphics would turn to garbage after a while. After a LOT of investigations, tests, etc … I came to the conclusion the power supply on this old PC had degraded too much over the years (the PC is 8 years old) and was no longer able to provide sufficient power to reliably power the card. I was not about to invest more money in this old PC (to replace the power supply) so instead I put the card in my slightly newer (5 years old) Athlon-2800 PC. From there the 8400GS PCI card runs GREAT !!

IMHO you should check your hardware.

Note I use the proprietary nVidia driver to take advantage of the vdpau functionality. I can play selected High Definition Videos (1920x1200 resolution) on this 32-bit Athlon-2800 (with the 8400GS) that friends with a slow Dual Core and a less capable graphic card have problems playing.

Note I always build the proprietary graphic driver “the hardway” , which is NOT hard.

Did I say the card works great?

Thanks, that’s kind of the road I was headed towards, as if there was a genuine driver/hardware issue from the manufacturer I suspect there would be all kinds of posts about the problem. While everything is rated as it should be, i.e. the power supply is >= 350W, the motherboard was picked up used. Althought I put it through it paces and double checked my ram, I’ve been doing this long enough to know that anything – ANYTHING – is possible. One of the reason I suspected that hardware could be the problem, based on the post before your post, is that while I was getting garbage, after a while it was only in the horizontal position. Talk about a red flag, huh? Besides, after about 1 minute I had to reboot the PC because I couldn’t fire up and xterm or telint to 3. So, I am very greatful for you pointing me in that direction. I don’t like to second guess myself.

Thanks so much,


There is not much I can add, other than to note on my 9-year old athlon-1100 PC, I could leave it running the VESA or nv (openGL) driver overnight, with not a problem seen. Of course one does not get the desired performance of the 8400GS with those. But with the nvidia proprietary driver, the problem would happen, sometimes within minutes, sometimes it would take a couple of hours, but eventually the screen would turn to garbage. This old athlon-1100PC has a 350 watt power supply. The manufacturer recommended 300 watts for the 8400GS. BUT after some surfing, I learned that a large number of power supplies, after 9-years of reasonably heavy use, will not be output 100% of their rated power, but in fact will be outputting significantly less. Hence it was not unusual for a 350 watt power supply to be outputting a LOT less than 300 watts after 8 years.

Now my 5-year old athlon 2800 has only a 325 watt power supply, but I recall paying extra for that power supply when I purchased the PC, and the store technician noted this was a good power supply that should not degrade much over the years, in comparison to others.

Some of my tribulations are here, as I investigated if it could be a driver problem (which was my first mis-diagnosis): Black and white squares during KDE login - openSUSE Forums

… and some more of my explorations here: vdpau mplayer / ffmpeg - Page 2 - openSUSE Forums

I also went to the nVidia forum and looked for help there but the general consensus there was I had a hardware problem, of which the power supply was a likely candidate.

anhydroux wrote:
> have nothing but corrupted
> video now that I installed the One-click for this card.

i avoid the One-click like H1N1…just too many ways for it to cook
my system…ymmv, but i assumed it is for those too lazy to do it the
right way, which is (imHO) mislabeled as “the hard way” here

i assume you have (google) verified the 8400 GS is supported by the
driver you are installing, and others have had success…

hate to say it, but maybe your “I’ve thrown everything at it I know –
even stupid stuff” has introduced some little thing somewhere that is
now a problem…i wouldn’t know how to back out of every “stupid”
thing you might have do and return to pure default and begin again
with the easy “hard way”…but, that is what i’d recommend (even if it
requires putting in the install DVD (not CD) and selecting repair on
both these screens, one after the other:

if that doesn’t work i think you are assured a hardware problem of
some sort (but, i’m not a real guru)…

> Will

Will Honea of ‘OS/2 fame’??

Have a lot of fun…

I’ve attempted to get desired resolution of 1920x1200_60 without success from both nvidia 8400 gs and 9500 gt cards on same gigabyte board EP45-DS3L
Works great with ubuntu or debian but NOT suse 10+ or Fedora core 10+ and I have no idea why…
and I’m not a newbie at this…

Possibly because it is two cards on the same board? I note having just one, an 8400GS works fine on my PC:

From my /var/log/Xorg.0.log:

(**) Mar 30 17:31:40 NVIDIA(0): Enabling RENDER acceleration
(II) Mar 30 17:31:40 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Mar 30 17:31:40 NVIDIA(0):     enabled.
(II) Mar 30 17:31:41 NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G98) at PCI:2:0:0 (GPU-0)
(--) Mar 30 17:31:41 NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:2:0:0:
(==) Mar 30 17:31:41 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) Mar 30 17:31:41 NVIDIA(0):     will be used as the requested mode.
(==) Mar 30 17:31:41 NVIDIA(0): 
(II) Mar 30 17:31:41 NVIDIA(0): Validated modes:
(II) Mar 30 17:31:41 NVIDIA(0):     "nvidia-auto-select"
(II) Mar 30 17:31:41 NVIDIA(0): Virtual screen size determined to be 1920 x 1200

and as noted it works great.

And from running xrandr:

oldcpu@hotbackuppc:~> xrandr
Screen 0: minimum 320 x 175, current 1920 x 1200, maximum 1920 x 1200
default connected 1920x1200+0+0 0mm x 0mm
   1920x1200      50.0*
   1680x1050      51.0
   1600x1200      52.0
   1440x900       53.0
   1400x1050      54.0     55.0
   1280x1024      56.0     57.0     58.0
   1280x960       59.0     60.0
   1280x800       61.0
   1152x864       62.0
   1024x768       63.0     64.0     65.0     66.0     67.0     68.0
   960x720        69.0     70.0
   928x696        71.0     72.0
   896x672        73.0     74.0
   832x624        75.0
   800x600        76.0     77.0     78.0     79.0     80.0     81.0     82.0     83.0     84.0     85.0
   720x400        86.0
   700x525        87.0     88.0
   640x512        89.0     90.0     91.0
   640x480        92.0     93.0     94.0     95.0     96.0     97.0     98.0
   640x400        99.0
   640x350       100.0
   576x432       101.0
   512x384       102.0    103.0    104.0    105.0    106.0
   416x312       107.0
   400x300       108.0    109.0    110.0    111.0    112.0
   360x200       113.0
   320x240       114.0    115.0    116.0    117.0
   320x200       118.0
   320x175       119.0

If you have this working on 2 other distributions, what is stopping you from studying what they are doing and applying it to openSUSE ?

… if all else fails, write a bug report on openSUSE on this. There is guidance here for writing bug reports: Submitting Bug Reports - openSUSE and you can log on to the bug reporting tool with your forum user name and your forum password. By writing a bug report you get the attention of the SuSE-GmbH packager/expert on graphics.

moonly wrote:

> I’ve attempted to get desired resolution of 1920x1200_60 without
> success
> from both nvidia 8400 gs and 9500 gt cards on same gigabyte board
> EP45-DS3L
> Works great with ubuntu or debian but NOT suse 10+ or Fedora core
> 10+ and I have no idea why…
> and I’m not a newbie at this…
Just to let you know I have a Samsung lcd. with 8400GS running
1920X1080 with know problems. Did you install the latest Nvidia
driver? (195-36.15). Works in both 11.2 and 11.3 MS4 before
yesterdays upndate to MS4, It now using Nouveau driver at 1920x1080.

When using Nvidia driver I had to install the hardway (actually
easy) because YaSt gives me a dependence error from the nvidia repo.

| openSUSE 11.2 ( x86_64 | KDE 4.4.1 release
225 | Intel Core 2 Dual E7200 | 4 GB RAM | GeForce 8400 GS | 320GB
Disc (2) |

As I use a KVM (iogear) which I now know was interfering with my lcd monitor detection, monitor resolution, I can report that without the KVM I can get my lcd’s default resolution of 1920x1200_60 dependably.

My apologies for not considering my kvm before making the previous post.