nVidia@64 bit and YaST

I have a 64 bit Suse 11.1, so I can’t use YaST to install the drivers. The only way is “The hard way”.

I’m not afraid to do it. This is OK for me.
The problem is. I don’t like to mess my system.

I love Yast in SUSE as 1 Control Panel (probably typical behaviour for Windows ex users ;p).
If I add a new software I want to see it in the YaST and be able to remove it.

If I will start to install soft just like that I will forget what I have already install.

So: How to make changes done in a Hard Way, visible in the Yast?



can’t be done. If you are using RPMs, the software should show up in Yast, else no.

I always use the NVidia installer to install the drivers and never had a problem with it. IMHO a driver isn’t regular software like a user application, so I don’t care if it shows up in Yast.


Ok, thanks buckesfeld.

At least I will no dig more. No means No :wink:

However, if we say that YAST software section is something like Add/Remove Software Manager, then maybe there exists a kind of GUI Device Manager? - where you can also administrate the drivers (not only see a list of them or set some parameters).

BTW: I managed, the ‘Hard way’, no problem. 3D on board.

  • cygi wrote, On 10/16/2009 11:26 PM:

> If we say that YAST software section is something like Add/Remove
> Software Manager, then maybe there exists a kind of GUI Device Manager,
> where you can also administrate the drivers?

Doesn’t make much sense, IMHO. Most drivers are part of the kernel and the kernel handles them almost perfectly.
It’s just when closed source drivers come into play. And there aren’t many.


If you don’t have a very old nvidia card, this is complete non sense.

Why on earth shouldn’t that work with 64 Bit?


This comment was mainly added so that other users don’t believe this is true.

In my case is a fact.

I tried to use the Yast and after install I had a fatal error of the X.

I tried the “Hard Way” and it works.

I don’t know why. Maybe this?

NOTE: For 64-bit users wishing to use nvidia-gfxG02-kmp-default, the nVidia kernel against which the driver is built (9 Sep 09) is not a kernel available from the repositories. The so called “Hard Way” will mostly take you the time to download the packages

Works here without problems.

So was this comment. Only 2 boxes, both 64 bit, both nVIDIA, kept-up-to-date, working fine.

I must admit, that I was already running my (self built) 190.40 RPMs, so I had to do a quick downgrade.

glxinfo |grep rendering
direct rendering: Yes

rpm -qa "*nvidia*"

uname -a
Linux Fatboy #1 SMP 2009-08-15 17:53:59 +0200 x86_64 x86_64 x86_64 GNU/Linux
  • added nvidia repo

  • installed packages matching my card (G02) and kernel flavor (kmp-default)

  • configured card with sax2

Done (in less than 5 minutes).

(The vdpau-devel by packman can be ignored, it is irrelevant for the drivers.)

=> and Back to 190.40 again…

rpm -qa "*nvidia*"

glxinfo |grep rendering
direct rendering: Yes
  • Akoellh wrote, On 10/19/2009 11:26 AM:
    > Works here without problems.

Doesn’t mean it works for everybody, of course. My overall experience with various NVidia cards over time is that using the repo is gambling, while the installer works all the time.


I like and almost trust the repo method, but as insurance I always keep a recent installer rpm available, because I can apply it from the Linux console should X not want to work.

Quite right, but I was not the one making a misleading statement.