Nvidia 520MX and Intel integrated. OpenGL error.

Hi everyone;

 I have installed the Nvidia drivers for my Gefore 520MX with Intel Integrated Graphics.

I’ve tried installing the Nvidia Drivers with one click on the opensuse website and leaving the nouveau drivers for intel to use but, It does not run at all.
I’ve always done the easy way and remember having problems blacklisting nouvea using guides with a single GPU but this is a laptop and there’s nothing I can do.

What steps should be taken when you have 2 GPU?
How can I know when it’s running on discrete or integrated?
I have installed bumblebee but, why isnt working?

Asus A53S (openSUSE 13.1)
Connectivity Network interface10/100/1000 LAN, 802.11b, 802.11g, 802.11n USB ports3 VGAYes HDMIYes Display Natural resolution (max)1366 x 768 pixels Diagonal screen size15.6 inch Drives Optical driveDVD-RW Primary hard drive750 GB General Dimensions (H x W x D)34.9 x 378 x 253 mm Laptop typeMidweight Weight2.6 kg Graphics Graphics hardwareGeForce GT 520MX Memory Amt of RAM4GB Other Integrated webcamYes Processor Processor typeIntel Core i5 Processor speed2.4 GHz

Please help me!!!:’(

A Guide for installing and configuring the drivers for newbies would be awesome!! Thanks:P

Have a look at my signature, I’m using the larger brother of your laptop. Here’s a blogpost on this matter. Please be aware that you have to remove all traces of your NVIDIA attempts, i.e. uninstall driver packages etc. The “normal” ones won’t work, stronger: they’ll bork the system, so if you’re still experimenting I suggest you perform a clean install, then use the one-click to get funcionality from the NVIDIA.
BTW. I hardly use the NVIDIA, since the Intel does a fine job. A friend has the exact same ASUS and he’s very satisfied on the Steam result. But, I’m not much of a gamer.

And, take your time to read the entire blogpost, some people immediately go for the one-click links, and forget to reboot, add themselves to the bumblebee group etc.

I really do need the dedicated GPU to work because of Autodesk Maya, Mudbox, NUKE, Houdini, OpenShot and Blender. Too much 3D design and I get the best performance on the Linux platform. I tried Fedora but performance was below compared to openSUSE so I decided to stick to it.

I will try and find a solution. I have reinstalled the OS a couple of times experimenting and like you said it has crashed a couple of times. I used the one-click and installed bumblebee in various way, used the community repository on yast for nvidia and even used the hardway going all the from stopping X11 and starting the rxcdm service from the command line. Still nothing.