Nvidia 520 dual monitor not recognized

I’m new to OpenSuse and have limited Linux experience. I’m using KDE. I have a Nvidia 520 graphics card with two monitors plugged in. I added the packman repository and added the Nvidia-settings however it doesn’t give me an option to add my other screen.
I tried following a few different posts I saw on a prior installation but they were all dead ends. I updated my kernel (a recommendation I found from another post). When I go to Configure Desktop and check out Multiple Monitors it says “This module is only for configuring systems with a single desktop spread across multiple monitors. You do not appear to have this configuration.”
After looking through many confusing posts (at least to me) I don’t even no where to go from here. Thank you for any help!

With both monitors plugged in, note what is reported via


Are both monitors detected?

Launch nvidia-settings via a terminal

kdesu nvidia-settings

How To Set Up Dual Monitor In KDE With Nvidia Settings - Muktware

Thank you for your response!
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1280 x 1024, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
1280x1024 77.0*

kdesu nvidia-settings: Opens up a Nvidia window but it gives an error upon opening that says, “You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.” There are a few checkboxes on the window but none seem to be related to dual monitors.

If you would like to install the proprietary video driver for nVIDIA, have a look at these possible methods.

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.45 - Blogs - openSUSE Forums

Thank You,

As James has mentioned, you’re not using the proprietary driver, but it’s easy to install, and ‘nvidia-settings’ is the configuration tool for that driver.

I downloaded the .run file and closed x server and ran init 3 and installed the run file. I added the 3 development items in Yast so it could compile. I then rebooted my machine. After running nvidia-settings the control panel came up and had the option for me to use a twin monitor. Thank you so much! I look forward to learning more about opensuse and hope to eventually be able to contribute more to the community!

Well done! :slight_smile: