Nvidia 180.27 - when will it be in repo?

Hi

I have the ‘suspend / resume’ bug from 180.22 where laptop does not resume and has to be powered down hard.

Apparently it is fixed in 180.27 but I cannot get the installer to work and have to reinstall 180.22 from yast from command line (running the 180.27 installer does not let me get back into a gui or run sax2).

Anyone know when we can get them from repo or got the installer to work from Nvidia?

Thanks

180.27 is still beta and not officially released by NV (if it was, it’ll be up on the official DL page). So you’ll have to wait

but I cannot get the installer to work

How does it not work?
These are usually bomb proof.

nvidia drivers are usually a little slow hidding the repo’s.

And what about sus 2 disk?

180.27 for Linux x86/x86-64 released - nV News Forums

I run through the installation in runlevel 3 (you cannot run it from GUI), then when I try go back to run level 5 I just get a login terminal in runlevel 5.

Reboot does not fix it and sax2 wont start:

Error: API mismatch: the NVIDIA kernel module has version 180.22,
but this NVIDIA driver component has version 180.27. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: “nvidia”
(II) UnloadModule: “wfb”
(II) UnloadModule: “fb”
(EE) Screen(s) found, but none have a usable configuration.

    Fatal server error:
    no screens found

Still no sign of 180.27 on NVs DL page Drivers - Download NVIDIA Drivers

there’s a mismatch between your kernel module and the driver libs. Install the hard way from the NV script itself and don’t use the -K option!

Yes it is a beta but is the best driver I used yet.

180.27 for Linux x86/x86-64 released - nV News Forums

ftp://download.nvidia.com/XFree86/Linux-x86/180.27/

ftp://download.nvidia.com/XFree86/Linux-x86_64/180.27/

Hi
Did you download the NVIDIA…pkg1.run? If you already have a valid
xorg.conf there is no need to run sax2 again. Also make sure you have
the linux-kernel-headers and kernel-syms installed.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 1 day 20:43, 1 user, load average: 0.19, 0.67, 0.55
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

there are pkg0,1,2. what is the different?

I had a similar problem with 180.22 - the installing the driver and having Sax2 fail. My problem was that I had 177.whatever installed from the repo, then did the *.pkg.run for the newer version. Just needed to do

# rmmod nvidia

then Sax/gui worked fine.

In the readme it says to use the highest number so I went with pkg2.

I guess they are versions? But cant tell from the dates.

Getting closer…

Today I tried again with 180.27 this time I removed 180.22 in YAST before going into runlevel 3 and running the script again.

When running the script I got an error that a previous driver (180.27) was already installed and would be uninstalled (yes it said 180.27), so I accepted this, it also could not find a suitable kernel through the internet so compiled its own interface (think that sounds right?).

After it finished I accepted to modify X.org and then launched into runlevel 5.

This time I got a GUI but was in 800x600 (1280x800 is my native res) so I changed it in the NVIDIA X Server Settings applet and all was OK until logout / reboot where 800x600 came back again.

I Used Sax2 to set 1280x800 and it now keeps this setting on reboot.

Also the suspend / resume issues are gone from 180.22 lol! lol!

However I have lost my 3d effects, when I go to Desktop - System Settings and Desktop Effects, the ‘Enable desktop effects’ check box is greyed out and I have a message…

“Compositing is not supported on your system. Required X extensions (XComposite and XDamage) are not available”.

Any ideas?

Its working now…

Just had to change the Composite option in xorg.conf to “on”.

Hi
32bit are normally the pkg1 and the 64bit and pkg2 which from your
later posts I’m assuming your using.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 2 days 6:36, 2 users, load average: 0.10, 0.18, 0.22
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27

Hi
When you update in the future, there is no need to re-run any config on
the xorg.conf. Unless there are some addition switched to add, just run
nvidia-xconfig --help to see how to add the new options. Else I just
update and run init5 && exit.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 2 days 6:38, 2 users, load average: 0.05, 0.15, 0.20
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.27