Nvidia 180.22

Can compile , but when I run SaX2 it will die with a error .
sh NVIDIA-Linux-x86-180.22-pkg1.run -q , compile , sax2 -r -m 0=nvidia dies , no desktop , dropped back to beta 180.17 , which works no problem .
Anyone else have trouble with 180.22 ?

Since the NVIDIA drivers include a script that can reset your xorg.conf file, I don’t run sax2 anymore to set the video drivers.

I actually don’t even change the xorg.conf file anymore. My drivers are set to be the nvidia and that line doesn’t change with new drivers.

I have downloaded the 180.22 drivers but have yet to install them. I will try it tonight.

There’s no need to compile the 180.22 driver since it is now available via repositories. I just installed it alongside other updates in YaST.

Duh , did not see in repository , it is there and DLed .
Thanks !

Must have been added today… I had problems with a manual install as well btw (while the same beta ones you mentioned did work fine).
Let’s see if this repository new stable does work.

it doesn’t…
Doing a wget on an url as long as the one used for the older beta drivers isn’t fun btw.

How did it go for you gib62588, rebooted the x-server yet? Cause if this is gonna wreck the GUI for a lot of nvidia users I don’t think people are going to be happy…

Through YaST worked fine , 180.22 , funny manual would not work , SaX2 would crash .
Don’t see much improvement , if any !

Broken for me.

I switched back to “nv” driver in the xorg.conf file, but I would like to downgrade to a previous version of the proprietary driver. How would i go about doing that?

Hmm , just checked to see what the NVIDIA X Server Settings read and it say I am still running the 180.17 drivers , something is up here , in YaST2 it no longer shows a update path , show 180.22 installed .
Had “More Software” sub tree when manual installing (compiling) Nvidia driver (always get that with manual install) , now just have X server in System>Configuration (NVIDIA X Server usually not there with manual install , compile ) , but shows 180.17 as driver ID .

I just installed the 180.22 and had no problems. My nvidia-settings shows 180.22 as the driver.

I always install install by downloading the driver from nvidia and thenrun in console login. (init 3).

Try this:

  • open YaST->software management and remove any nvidia drivers.
  • open a console window use sax2 to set back to nv driver (sax2 -r -m 0=nv).
  • Reboot
  • download (if you haven’t already) the 180.22 drivers from nvidia.
  • logout.
  • In the login manager window choose Menu->console login.
  • login as root
  • navigate to your “NVIDIA…run” driver.
  • type sh “NVIDIA…run”
  • follow on screen prompts
  • allow the nvidia-installer to change your xorg.conf file (last dialog box that pops up)
  • type exit and wait for the graphic login screen to appear.

See if that will work for both of you. That is basically the manual install or “hard way” as some people say. I have always installed the nvidia drivers this way and have had no problems with it. These steps will have to be repeated everytime there is an xorg or kernel update though.

Yeah have been doing it for about 10 years that way , a little different but none the less manual install .
You can add 3 at boot and it will go directly to init 3 and run sh NVIDIA . I believe there is even a crtl>alt>F3 short cut ?