NVidia 173.14.05 drivers problem on GeForce 6100

Hi all,

I’ve unintentionally upgraded NVIDIA drivers to version 173.14.05 from community repositories on my Lenovo ThinkCentre A60 Desktop PC with integrated GeForce 6100 and running openSuse 10.3.

The result is a complete blank screen and any effort to reconfigure via Sax2 has failed.

I also tried to use the official drivers from NVIDIA site but both 173.14.05 and 173.08 doesn’t run for my card.

I solved by downgrading to 171.06.01 that work perfectly.

I’m not interested in new feature but I’d like just to signal this very annoying problem.

I’ve not tried yet but I think it could be a potential problem also for the upcoming 11.0 release.


I have faced the same problem on my desktop with the same version of drivers (on GeForce 6100, with openSUSE 10.3). The problem is with certain resolutions only; for example on my desktop the resolutions 1024x768 and 800x600 work, but 1280x1024 results in a black screen as Davide mentions.


Similar issues here. GeForce 6200 in my desktop. Using the packages from the repo, SaX2 acted like everything went well, but upon restarting X, the nv driver was loaded. Trying to reconfigure would result in either a failed X session or the nv driver being loaded. I tried using an old xorg.conf (since all the values should be the same; still no dice.

I downloaded the .run from Nvidia, ran their installer, and now everything works.

did u download the latest version, I have this problem as well

looks like nvidia is aware of the problem and version 173.14.19 fixes it and I am going to test it now :slight_smile:

Yes… they are working on the problem… I had the same issue on a Dell D820 w/ NVIDIA NVS110M

I can’t compile it cause the kernel-source package hasn’t been updated for the latest kernel :eek:

Alright so I just compiled version 173.14.19 and they work perfectly.

Need some info though, SUSE is like 1 to 2 days before final release and the drivers in the repo r broken, even though old users like me can compile them but new users won’t be happy about this and trust me, many people I know will be downloading suse 11 on release day.

So any idea when nvidia updates their repo?

Using Dell M65 + Quadro FX350M (with openSUSE 10.3), and having a similar problem: the X server does not start, and attemps to run SaX2 yiels a message like this (from SaX.log):

    NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).
    (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:1:0:0.

The previous version of the driver was 169.12 (rpm: nvidia-gfxG01-kmp-default-169.12_2.6.22.17_0.1-0.1) and worked fine. I had upgraded that using the openSUSE Update Applet to nvidia-gfxG01-kmp-default-173.14.05_2.6.22.18_0.2-1.1.

Perhaps the problem is that the driver appearing on the official NVIDIA repository is compiled assuming a kernel, instead of the current version of openSUSE 10.3. (Note to myself: next time, don’t trust NVIDIA, and before clicking on the “update” button, check a dozen times that the NVIDIA driver is the one compatible with the current system system…:mad:)

Anyways, before I launch myself into compiling by hand the driver for the current kernel (easy as it may be), I’d rather restore the previous version of the driver.

Except that I can’t find it anymore… It seems that NVIDIA just replaces the old version in their repository. Or I am wrong?

By the way, I see here people mentioning version 173.14.19 of the driver. Here, however, the most recent driver listed for Linux IA32 is 173.14.09. Am I checking the wrong place?

I think we made a mistake typing the version number, it is 173.14.09 and nvidia mentions themselves that they r aware of the bug in 173.14.05 and thats why they release 173.14.09 so I doubt opensuse has anything to do with it :slight_smile:

Thanks snakeeyes. Of course I know openSUSE has very little to do with this “snafu” (after all, in my previous post I reminded myself not to trust NVIDIA, not openSUSE…;))

By the way, I’ve checked ftp://download.nvidia.com/opensuse/10.3/i586/, and, alas!, the older, working RPM (169.12) is no more…

So, I guess I have no choice but to compile the new driver by hand. 'Pity I’m leaving for a long business trip in a few days, and I’m swamped with things to do… I suppose I’ll have to stick with the nv driver… (or: anybody has any experience with the nouveau driver with my chip - Quadro FX 350M?)


Hi, I don’t know how the open source driver is sorry and I don’t think version 169.12 works with kernel 2.6.25, but don’t worry installing the driver manually is very easy, I wrote a how to here:

Install Nvidia driver manually! - openSUSE Forums


Luckily I already had kernel-source installed, so it was actually easy.:slight_smile:

Thanks for your help!

no problem :slight_smile:

Had the same problem using a GF6200 AGP card in openSUSE 10.2, being locked out of X after updating to 173.14.05 :mad:

For others wanting to downgrade, old RPM’s can still be found here: Index of /mirrors/opensuse/nvidia/download.nvidia.com/opensuse

Used “rpm -ivh --nodeps” to install both RPM’s manually (YaST will automatically pick the newest version again, putting you back at square one) and have my desktop back up with 169.12 :slight_smile:

Thanks for the info guys.

Yeah but the problem is I don’t think driver 169.12 works on kernel 2.6.25 without a patch or something so its useless for opensuse 11 users.

I hope the nvidia repos get updated soon with driver 173.14.09 otherwise new users will have a horrible time.