nvclock segmentation fault

I’m trying to get nvclock to work but it always crashes, no matter whatever parameters i give it (except for no parameters which brings up the help screen just fine).

I have an 8800 gt with the nvidia drivers installed correctly running opensuse 11.1

Anyone else had this problem?

GNU gdb (GDB; openSUSE 11.1)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i586-suse-linux".
For bug reporting instructions, please see:
(gdb) run -F 60
Starting program: /usr/bin/nvclock -F 60
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x0805a5d0 in load_bios_pramin ()
Current language:  auto; currently asm

Just ad the coolbits option in your device section of the xorg file and
you can use nvidia-settings to tweak/overclock.

Option       "Coolbits" "1"

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 1 day 23:50, 2 users, load average: 0.49, 0.18, 0.23
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Is there a way to change fan speed with nvidia-settings? I didn’t see any options for that, just clock speed.


Ahhh ok, my 8600GT is silent…no fan :wink: I think you will need to use
the beta one from the packman repository.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 2 days 0:40, 2 users, load average: 0.05, 0.08, 0.08
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Yeah, i’m using the latest nvclock from packman. I should probably try some older versions to see if that helps. I don’t know why nvidia sets the default fan speed to 29%. It’s supposed to go up with temperature but the fan speed never changes dramatically, maybe like 10-15% at most.

I just installed on the two machines I have with nvidia cards, it
doesn’t segfault for me. I’m using 180.35 and 180.29 drivers.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 2 days 1:19, 1 user, load average: 0.27, 0.56, 0.53
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

Must be something with the 8800 GT or 8 series.

Well this one is a 6600 and the other is 8600. Wonder if a search or
post over in the nvforums may help?

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 2 days 1:37, 1 user, load average: 0.23, 0.26, 0.31
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

It’s probably just the new nvidia drivers. nvclock worked fine for me in ubuntu 8.10, and that uses the 177 series. I debugged the program further and it’s crashing on this line:

uint32_t vbios_vram = (nv_card->PDISPLAY[0x9f04/4] & ~0xff) << 8;

PDISPLAY isn’t being loaded properly for whatever reason.

Yeah i’ll probably email the author about this.

Hi all!

I installed opensuse 11.1 on my vaio 2 days ago and i used the video drivers 180.29 from the nvidia site. After that I installed nvclock beta 4 for controlling the brightness with the command nvclock -S -X. At the beginning everything was working fine but after an update i did every time I’m using the command nvclock -S -X I’m taking the error: segmentation fault!

linux-yfw5:~ # nvclock -S -10
Segmentation fault
linux-yfw5:~ #

I tried to install again the drivers and nvclock, I also used those from the nvidia repository but without any positive result.
Unfortunately when I did the update I didn’t look what packages i was to update.
Do you have any idea how to fix this?
should I give up and reinstall everything??

Thanks in advance!

Reinstalling won’t help. There’s a bug in nvclock. It doesn’t work with the lastest drivers at least with an 8800gt. Apparently nvclock is dead because the email address won’t work and nobody has replied on the forums.

What video card do you have in your laptop?

Hi Jacky_J!
thanks for you answer.
I have an 8400M GT.
As I said, before the updating it was working and it is working also on Ubuntu.
So are you telling that I should try an older version of the nvidia drivers?
Witch one do you think is better?

My ubuntu 8.10 worked as well because they use the 177* series of nvidia drivers. I can only imagine the new Ubuntu 9.04 will have the 180* drivers and more people with 8 series nvidia cards will have problems with nvclock.

Hi all,
I’ve the same problem with opensuse 11.1 and a GeForce 7400.
For some reason when I downgrade libv4l from version 0.5.9 to 0.4.0
nvclock and smartdimmer get back working.
I didn’t found anything about that in forums…
Hope it helps…