Numpy version in openSUSE

No. You only showed where your python-numpy comes from, but not python-matplotlib!

Unlike mine however, your repo is not
openSUSE-12.3-Oss (the default for Oss), and so I will not close the bug report. It would be interesting to see the
contents of your `zypper lr -d’, to see where your python-numpy did come from.

Well, it is the openSUSE-12.3-Oss repo. I just happened to name it openSUSE-12.3:

wolfi@amiga:~> zypper lr -d
#  | Alias                       | Name                               | Aktiviert | Aktualisieren | Priorität | Typ    | URI                                                                                                   | Dienst                                                                                                                                 
---+-----------------------------+------------------------------------+-----------+---------------+-----------+--------+-------------------------------------------------------------------------------------------------------+-------                                                                                                                                 
 1 | Emulators                   | Emulators                          | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/Emulators/openSUSE_12.3/                                    |                                                                                                                                        
 2 | KDE:Distro:Factory          | KDE:Distro:Factory                 | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Distro:/Factory/openSUSE_12.3/                         |                                                                                                                                        
 3 | KDE:Unstable:Playground     | KDE:Unstable:Playground            | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Unstable:/Playground/openSUSE_12.3_KDE_Distro_Factory/ |                                                                                                                                        
 4 | Packman                     | Packman Repository                 | Ja        | Ja            |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_12.3/                                                           |                                                                                                                                        
 5 | Virtualization              | Virtualization                     | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_12.3/                               |                                                                                                                                        
 6 | devel:languages:misc        | devel:languages:misc               | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/misc/openSUSE_12.3/                       |                                                                                                                                        
 7 | download.opensuse.org-Extra | KDE:Extra                          | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_12.3_KDE_Distro_Factory/                |                                                                                                                                        
 8 | download.opensuse.org-KDE3  | KDE:KDE3                           | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_12.3/                                    |                                                                                                                                        
 9 | download.opensuse.org-Wine  | Wine-CVS-Pakete                    | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_12.3/                              |                                                                                                                                        
10 | download.opensuse.org-games | Spiele                             | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_12.3/                                        |                                                                                                                                        
11 | google-earth                | google-earth                       | Ja        | Ja            |   99      | rpm-md | http://dl.google.com/linux/earth/rpm/stable/x86_64                                                    |                                                                                                                                        
12 | home:FrodeSolheim:devel     | home:FrodeSolheim:devel            | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/home:/FrodeSolheim:/devel/openSUSE_12.2/                    |       
13 | home:adra                   | home:adra                          | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/home:/adra/KDE_Distro_Factory_openSUSE_12.3/                |       
14 | home:wolfi323               | home:wolfi323                      | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/home:/wolfi323/openSUSE_12.3/                               |       
15 | home:ykoba                  | home:ykoba                         | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/home:/ykoba/openSUSE_12.3/                                  |       
16 | multimedia:apps             | multimedia:apps                    | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_12.3/                             |       
17 | multimedia:libs             | multimedia:libs                    | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_12.3/                             |       
**18 | openSUSE-12.3               | openSUSE-12.3                      | Ja        | Nein          |   99      | yast2  | http://download.opensuse.org/distribution/12.3/repo/oss/                                              |       **
19 | opensuse-guide.org-repo     | libdvdcss repository               | Ja        | Ja            |   99      | rpm-md | http://opensuse-guide.org/repo/12.3/                                                                  |       
20 | repo-debug                  | openSUSE-12.3-Debug                | Nein      | Nein          |   99      | yast2  | http://download.opensuse.org/debug/distribution/12.3/repo/oss/                                        |       
21 | repo-debug-update           | openSUSE-12.3-Update-Debug         | Nein      | Nein          |   99      | rpm-md | http://download.opensuse.org/debug/update/12.3/                                                       |       
22 | repo-debug-update-non-oss   | openSUSE-12.3-Update-Debug-Non-Oss | Nein      | Nein          |   99      | rpm-md | http://download.opensuse.org/debug/update/12.3-non-oss/                                               |       
23 | repo-non-oss                | openSUSE-12.3-Non-Oss              | Ja        | Nein          |   99      | yast2  | http://download.opensuse.org/distribution/12.3/repo/non-oss/                                          |       
24 | repo-source                 | openSUSE-12.3-Source               | Nein      | Nein          |   99      | yast2  | http://download.opensuse.org/source/distribution/12.3/repo/oss/                                       |       
25 | repo-update                 | openSUSE-12.3-Update               | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/12.3/                                                             |       
26 | repo-update-non-oss         | openSUSE-12.3-Update-Non-Oss       | Ja        | Ja            |   99      | rpm-md | http://download.opensuse.org/update/12.3-non-oss/                                                     |       
wolfi@amiga:~> 



To second wolfi323 I installed now in a VM a 32bit vanilla openSUSE
12.3 (all updates applied) with matplotlib 1.2 and numpy 1.6 both from
OSS (no extra repositories configured) and it works with that
combination, so it looks as if flymail has matplotlib not from the oss
repo as here the matplotlib from oss correctly depends on the numpy from
oss.
I would be very surprised if it is different for 64 bit, but I am not
going to test that as well now.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.2 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.3 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.2 | GMA4500

On 2013-05-23, Martin Helm <martin_helm@no-mx.forums.opensuse.org> wrote:
> To second wolfi323 I installed now in a VM a 32bit vanilla openSUSE
> 12.3 (all updates applied) with matplotlib 1.2 and numpy 1.6 both from
> OSS (no extra repositories configured) and it works with that
> combination, so it looks as if flymail has matplotlib not from the oss
> repo as here the matplotlib from oss correctly depends on the numpy from
> oss.

Mine was also a vanilla 32-bit installation from an up-to-date VM with no additional repositories.

But since it appears I’m alone on this one (maybe not quite alone e.g.
https://forums.opensuse.org/english/other-forums/development/programming-scripting/486702-python-error-sci-python-help.html
), I’ve closed the bugzilla report. Sorry for spending other people’s time.

Well, that thread was about pylab, and the OP never answered where he got that from.

Your bugreport was about python-matplotlib from OSS being built against python-numpy from a different repo and that’s simply wrong. And, knowing the build process of openSUSE, I would say that it’s impossible either.

The only problem here is that python-numpy-1.6 is not compatible to python-numpy-1.7.
Maybe the package dependencies should be stricter (i.e. requiring the exact version of python-numpy), but that’s not really doable, because you can’t check in the specfile against which python-numpy you’re building. If python-numpy was a normal shared library and not a python module, rpm(build) would take care of this automatically, though.

So just the standard rules apply here: Don’t install packages belonging together from different repositories! :wink: