Numpad Issues

I have a Samsung R610 laptop running openSUSE 11.2 and gnome. Everything has been working fine until recently my numpad decided to call it quits. I know it’s not a hardware failure cause a) it works if I boot out of desktop into pure command line, and b) it works under Windows Vista (my dual-boot). When I try to use the numpad, if I turn numlock off I can still use the directional arrow funcunality however with numlock on it won’t do anything.

Haven’t really tried anything yet as don’t know where to start. As I say it’s not a hardware failure as the numpad works in pure command line and Windows, only fails in desktop.

If you go to system settings - region and language
Have you tried setting different keyboad options there?

Yeah have tried changing all sorts of settings in there. I have tried changing Keyboard Language, the Make/Model, and setting Deafult Keys > Numpad to a variety of things. None worked.

If you create a new user account and log in there, does the problem persist?

Created a new account and it works fine there. It also works fine on the login dialog. I compared all the language and keyboard settings between my main account and the new one and from what I can see they are all the same.

jkraw90 wrote:
> I compared all the language and keyboard settings between
> my main account and the new one and from what I can see they are all the
> same.

what tool did you use for comparison?
diff, BeeDiff or what??


palladium

Now you know it is a setting in your users settings

Any idea of other settings to have a look at? Like I said I have checked Languages, and Keyboard settings and they are the same in both accounts.

@palladium:

I checked them manually.

I could try giving you a command to run that will remove all your user settings. It will be like starting fresh but in your current user account. You can delete the new account if you like now. It has served it’s purpose.

You need to do a console boot, like this
http://public.bay.livefilestore.com/y1pZuZxTopUfJ1g1RmFDKS7jkp6co9ByPsRIVfslRGOc6ZZwxdOHXYJj4aALBXtc6txoith_abN5id_sYgVeHglTA/console.login.png

Now do these

mv .config .config-old
mv .gconf .gconf-old
mv .gconfd .gconfd-old
mv .gnome2 .gnome2-old

now type: **startx
**
It should boot to the desktop
All your old settings will be in the folders we just renamed with the -old, just in case you need something in them, all your documents and the like will still be in place, we only changed config folders.

jkraw90 wrote:
> @palladium:
>
> I checked them manually.

if it were me i would directly compare the two hidden files in the
brokeUser home to the okUser home…

kinda like this:

diff -bBy --suppress-common-lines /brokeUser/* /okUser/* | less

or, in BeeDiff you could do it all with a GUI

unfortunately i can’t tell you which files the problem is likely in…


palladium

I used caf4926’s solution and it worked fine. Obviously had to reconfigure some of my settings but got it working.

Phew!
That’s a relief because I don’t use gnome. Bit of guess work there.
kde has just one folder, so it’s really easy.

Whether it was guess work or not you still managed to solve it. :smiley: Thanks for all your help.

No guess work exactly
Some 17,000 posts down the line, and I have learned some;)

Sorry, I wasn’t implying you had just taken a random guess. It was just a reply to your comment:

Phew!
That’s a relief because I don’t use gnome. Bit of guess work there.

One comment I would make though for anyone else with this problem was that in my system anyway I could get into command line in the way you said as the option for command line wasn’t there. Instead I used Ctrl+Alt+F1, then rebooted the system.

I had the same problem and I was able to narrow this down to ~/.gconf/desktop folder. I couldn’t find an exact file that caused it, but wiping that folder resolved the issue for me.