Numlock

Hi,

In KDE 4.5.2 i can’t find where to lock up NUMLOCK, can you help please ?

How do you do to have numlock on all the time ?

I have /etc/sysconfig/hardware/keyboard/kbd-numlock already on yes.

If i try to change it i have an error : kbd service is not started

see below :

/etc/init.d/kbd restart

Loading console font lat9w-16.psfu -m trivial G0:loadable
setfont: putfont: 256,8x16: failed: -1
putfont: KDFONTOP: Invalid argument
setfont: putfont: 256,8x16: failed: -1
putfont: KDFONTOP: Invalid argument
setfont: putfont: 256,8x16: failed: -1
putfont: KDFONTOP: Invalid argument
setfont: putfont: 256,8x16: failed: -1
putfont: KDFONTOP: Invalid argument
setfont: putfont: 256,8x16: failed: -1
putfont: KDFONTOP: Invalid argument
setfont: putfont: 256,8x16: failed: -1 **
putfont: KDFONTOP: Invalid argument failed **
Loading keymap i386/azerty/fr-latin1.map.gz done
Loading compose table latin1.add done
Start Unicode mode done
linux-alzh:~ # /etc/init.d/kbd status
Keymap /usr/share/kbd/keymaps/i386/azerty/fr-latin1.map.gz is loaded.
linux-alzh:~ # ^C
linux-alzh:~ # numlockx --help
NumLockX 1.1
(C) 2000-2001 Lubos Lunak <l.lunak@kde.org>
(C) 2001 Oswald Buddenhagen <ossi@kde.org>

Usage : numlockx [on|off]
on - turns NumLock on in X ( default )
off - turns NumLock off in X
toggle - toggles the NumLock on and off in X

linux-alzh:~ # exit
logout
fabrice@linux-alzh:~> numlockx on

In KDE system settings > Mouse and Keyboard (or Input Devices>Keyboard>Hardware tab) > Numlock at KDE start.

Can’t see it in system settings , neither in yast, it mentions there system keyboard only (i’m in kde 4.5.2)

It’s here in KDE 4.5.1 system settings (not in yast). Maybe 4.5.2 changed the location. note that I’m translating from Portuguese, so the actual terms may be different.

I’ve tried to post a screen capture but apparently I’m not allowed to do so.

Using imagebam…

System settings:
http://thumbnails32.imagebam.com/10394/d8158f103936381.jpg](http://www.imagebam.com/image/d8158f103936381)
KDE version:
http://thumbnails36.imagebam.com/10394/15b0c1103936412.jpg](http://www.imagebam.com/image/15b0c1103936412)

Note: the above is in openSuse 11.2, if it makes a difference.

Nope. In 11.3 KDE 4.5.2:

Systemsettings - Input Devices - Keyboard.

No dice then. Guess I’ll wait until kde4 stabilizes… Or is it in another submenu? Should be simple.

OK, the system settings input option change this section of the text file ~/.kde4/share/config/kcminputrc:

[Keyboard]
ClickVolume=0
KeyboardRepeating=true
NumLock=2
RepeatDelay=660
RepeatRate=25

So try setting NumLock to 0, 1 or 2

This is also found in /etc/sysconfig/keyboard

Change to KBD_NUMLOCK=“yes”. I would be sure it is set the same in both places. If this does not work, you probably have an issue with your keyboard or bios. You have checked to be sure the correct keyboard layout is installed?

Further note: I have an aggravating problem with numlock. The above command only turns the numlock on when kde boots. During boot my bios turns numlock on as set in bios, but when suse starts to boot numlock is turned off; thus, when it gets to the password prompt numlock is off and you have to turn it on or use the regular keybd keys. Once kde starts it comes back on again. Is there some place to set in boot or bootloader or somewhere to turn in on during boot (or rather, not turn it off)?

Hello there,

To get the numlock on during login I’ve edited the kdmrc file in /usr/share/kde4/config/kdm/

Search for the lines…

# What to do with the Num Lock modifier for the time the greeter is running:
# "Off" - turn off
# "On" - turn on
# "Keep" - do not change the state
# Default is Keep
#NumLock=Off

Just uncomment the last line and change Off to On.

Works for me.

Cheers,

T

Hi,
in fact it was my mistake : i did not see the windows entirely so i missed the hardware part which is at the bottom and was hidden.
Thanks :wink: