number pad not working

Suse 11.0

Standard KB. Number keypad will not work. Tried number lock on and off. No change.

please help. It is driving me nuts.

JHMariscal wrote:
> Suse 11.0
>
> Standard KB. Number keypad will not work. Tried number lock on and
> off. No change.
>
> please help. It is driving me nuts.

Open YaST and go Hardware > Keyboard Layout

Is your keyboard correctly identified by type (mine says Microsoft Natural
Keyboard Pro, even though that is not correct mine works okay).

If yours is not working maybe you can find a type nearer (or exactly) like yours
that will.

And, never forget it might be a hardware issue (that section of the board is
broke–does it work ok with another OS?). Oh, and you say “standard KB” and I
wonder if you consider a USB board “standard” today.

Thank you for the information but still no dice. The interesting thing is that if I log into KDE4, number pad works. Back to Gnome, no worky.

> KDE4, number pad works. Back to Gnome, no worky.

Very strange!

AH! I know what to do: Avoid Gnome.

Sorry :slight_smile:


Bud

Hi,

I know it’s a little bit late but this info may help others. Just start Gnome Configuration Editor and go to:

desktop->gnome->accessbility->keyboard

and disable “mousekeys_enable” feature…

Hope it helps.
Onur

Just wanted to let you know, it was worth putting up the post. It helped me to keep my sanity. (…And my wife from beating me because the numpad didn’t work!)

I must add to your repo… was just getting bonkers why the numpad stopped working all of a sudden, your post saved me! Thanks a ton…

Ok I am little late on the post. I am running opensuse 12.2 gnome running on a HP probook 4525s laptop. I can not find the location that gives you the options to uncheck the mouse controls with the number pad. If any help me with this that would be great. I am a very new user to this OS. It is getting very frustrating not having my number pad. Look forward to understanding this.

Hi, welcome

You reopened a 4 year old thread. Please start a new thread, with a clear title and provide us with information on openSUSE version, desktop used, 32/64bit . That way your chances to find help will be better than in this old thread

System Settings -> Universal Access -> Pointing And Clicking -> Mouse Keys

On 05/21/2013 01:06 PM, SDhiraj wrote:
> System Settings -> Universal Access -> Pointing And Clicking -> Mouse
> Keys

-=WELCOME=- new poster, and thanks for your willingness to be helpful!

but, the question you answered is five years old and the person who
asked it was last here in November 2008.


dd
openSUSE®, the “German Engineered Automobile” of operating systems!