Nuevo VLC en Packman

Hola compi.

Tengo Leap 15.4 y ha actualizar el sistema con zypper up se ha eliminado toda la paqueteria del vetusto VLC para instalar el nuevo VLC, en ingles, todavía no tiene el idioma en castellano.

Información para paquete vlc-beta:
----------------------------------
Repositorio           : Packman
Nombre                : vlc-beta
Versión               : 20240505.3f2959558d-150500.19.pm.1
Arquitectura          : x86_64
Proveedor             : http://packman.links2linux.de
Tamaño de instalación : 25,0 MiB
Instalado             : Sí
Estado                : actualizado
Paquete de fuentes    : vlc-beta-20240505.3f2959558d-150500.19.pm.1.src
URL ascendente        : http://www.videolan.org
Resumen               : Snapshot of vlc.git#master
Descripción           : 
    VLC media player is a highly portable multimedia player for various
    audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...)
    as well as DVDs, VCDs, and various streaming protocols.
    It can also be used as a server to stream in unicast or multicast
    in IPv4 or IPv6 on a high-bandwidth network.

~> vlc --version
VLC media player 20240505 Otto Chriek (revision 3f2959558d)
VLC version 20240505 Otto Chriek (3f2959558d)
Compiled by X on X (Sep 10 2021 13:42)
Compiler: gcc
This program comes with NO WARRANTY, to the extent permitted by law.
You may redistribute it under the terms of the GNU General Public License;
see the file named COPYING for details.
Written by the VideoLAN team; see the AUTHORS file.

1 Like

Hola:
También me hizo lo mismo en la 15.5; debío ser en flat…, había como 32 actualizacionnes, mas o menos, entre ellas instalaba esas y qt6, en snapper solo había 3.
Dado que la anterior me funcionaba bien, y tampoco me interesaba qt6, por ahora, hice un rollback y recupere la antigua (no se si llego a instalarse) ,
Actualmente conservo la de los codecs .
Hoy hubo una actualización de seguridad de flactpack, y ya no me salen las actualizaciones, esas. pero si unas 26 de programas,temas, mesa,gnome,etc (como no uso eso, paso de actualizar por ahí) ; con zypper up, me salen 56 ahora (incluidas las primeras de vlc,qt,etc…
The following item is locked and will not be changed by any action:
Available:
texlive

The following 9 package updates will NOT be installed:
digikam digikam-lang digikam-plugins kvantum-manager kvantum-manager-lang kvantum-qt5 kvantum-themes libass9 showfoto

The following 56 NEW packages are going to be installed:
libQt6Core6 libQt6DBus6 libQt6Gui6 libQt6LabsAnimation6 libQt6LabsFolderListModel6 libQt6LabsQmlModels6 libQt6LabsSettings6
libQt6LabsSharedImage6 libQt6LabsWavefrontMesh6 libQt6Network6 libQt6OpenGL6 libQt6Qml6 libQt6QmlCore6 libQt6QmlLocalStorage6 libQt6QmlModels6
libQt6QmlWorkerScript6 libQt6QmlXmlListModel6 libQt6Quick6 libQt6QuickControls2-6 libQt6QuickControls2Impl6 libQt6QuickDialogs2-6
libQt6QuickDialogs2QuickImpl6 libQt6QuickDialogs2Utils6 libQt6QuickLayouts6 libQt6QuickParticles6 libQt6QuickShapes6 libQt6QuickTemplates2-6
libQt6QuickTest6 libQt6ShaderTools6 libQt6Sql6 libQt6Svg6 libQt6Test6 libQt6WaylandClient6 libQt6WaylandCompositor6
libQt6WaylandEglClientHwIntegration6 libQt6WaylandEglCompositorHwIntegration6 libQt6Widgets6 libQt6WlShellIntegration6 libb2-1 libebur128-1
libfluidsynth3 libfreerdp2 libmodplug1 libnfs14 libshine3 libvncclient1 libwinpr2 qt6-declarative-imports qt6-imageformats qt6-network-tls
qt6-platformtheme-gtk3 qt6-qt5compat-imports qt6-translations qt6-wayland qtdeclarative-imports-provides-qt6 vlc-beta

The following 7 packages are going to be REMOVED:
vlc vlc-codec-gstreamer vlc-codecs vlc-lang vlc-noX vlc-qt vlc-vdpau

56 new packages to install, 7 to remove.
Overall download size: 28.9 MiB. Already cached: 0 B. After the operation, additional 61.6 MiB will be used.

Backend: classic_rpmtrans
Continue? [y/n/v/…? shows all options] (y):

Por ahora no me interesa actualizar (dado que tengo un problema sin solucionar del sistema gráfico del principio) .

Saludos

Hola:
El problema es generado por unas dependencias de una lista de parches, la cual desinstala vlc con sus codecs e instala vlc beta.
La cual usa qt6.
De la cantidad de parches 8 son los que dan error y tienen problemas, en casi todos, la opción 1 podría ser la buena, pero en el nº 8 , la una es la que desinstala vlc , ademas de muchos otros, programas.

Los 8 parches problemáticos son : openSUSE-2023-364(1), openSUSE-SLE-15.5-2023-4145(1), openSUSE-SLE-15.5-2024-1015, de aquí en adelante, son del 2024 y los números son (sin contar el 1015), 1172(1), 1192(1), 1598(1) y el último es openSUSE-SLE-15.4-2024-244(1) .
Lo que he realizado es lo siguiente:
1º actualizo los programas con Yast2.
2º reinicio el ordenador, ya que hubo una actualización del kernel.
3º instalo todos los parches, menos los de la lista.
4º no se si probando los problemáticos, o en la instalación, se instala vlc beta y dependencias de este con qt6.
5º me voy a yast2 (instalación y des instalación ) con las opciones de cambio de proveedor (packman tiene prioridad alta) , marco vlc y vlc codecs, esto desintala vlc beta y elimina dependencias con qt6 (lo desinstala) quedando vlc de packman actualizado y sin qt6.
6º desde consola se lista los parches y se ve que quedan los 8 , pero sin instalación de qt y vlc beta.

mikrios:~ # zypper patch
Loading repository data…
Reading installed packages…
Resolving package dependencies…
8 Problems:
Problem: 1: the to be installed patch:openSUSE-SLE-15.5-2024-1598-1.noarch conflicts with ‘less.x86_64 < 590-150400.3.9.1’ provided by the installed less-590
-150400.3.3.1.x86_64
Problem: 2: the to be installed patch:openSUSE-SLE-15.5-2023-4143-1.noarch conflicts with ‘libharfbuzz-icu0.x86_64 < 3.4.0-150400.3.8.1’ provided by the inst
alled libharfbuzz-icu0-3.4.0-150400.3.6.1.x86_64
Problem: 3: the to be installed patch:openSUSE-SLE-15.5-2024-1172-1.noarch conflicts with ‘libsmartcols1.x86_64 < 2.37.4-150500.9.6.1’ provided by the instal
led libsmartcols1-2.37.4-150500.7.16.x86_64
Problem: 4: the to be installed patch:openSUSE-2023-364-1.noarch conflicts with ‘plasma5-desktop-emojier.x86_64 < 5.27.9-bp155.2.3.1’ provided by the install
ed plasma5-desktop-emojier-5.27.4-bp155.1.7.x86_64
Problem: 5: the to be installed patch:openSUSE-SLE-15.5-2024-1015-1.noarch conflicts with ‘sed.x86_64 < 4.4-150300.13.3.1’ provided by the installed sed-4.4-
11.6.x86_64
Problem: 6: the to be installed patch:openSUSE-SLE-15.5-2023-4439-1.noarch conflicts with ‘w3m.x86_64 < 0.5.3+git20230121-150000.3.6.1’ provided by the insta
lled w3m-0.5.3+git20180125-150000.3.3.1.x86_64
Problem: 7: the to be installed patch:openSUSE-SLE-15.5-2024-244-1.noarch conflicts with ‘libsmartcols1.x86_64 < 2.37.4-150500.9.3.1’ provided by the install
ed libsmartcols1-2.37.4-150500.7.16.x86_64
Problem: 8: the to be installed patch:openSUSE-SLE-15.5-2024-1192-1.noarch conflicts with ‘less.x86_64 < 590-150400.3.6.2’ provided by the installed less-590
-150400.3.3.1.x86_64

Problem: 1: the to be installed patch:openSUSE-SLE-15.5-2024-1598-1.noarch conflicts with ‘less.x86_64 < 590-150400.3.9.1’ provided by the installed less-590
-150400.3.3.1.x86_64
Solution 1: do not install patch:openSUSE-SLE-15.5-2024-1598-1.noarch
Solution 2: remove lock to allow removal of less-590-150400.3.3.1.x86_64

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): c.
Actualmente funciona todo, quedando esos 8 problemas.
Este equipo se deja tal como indico ahora, funcionando todo :
mikrios:~ # inxi -SMCGAIz
System:
Kernel: 5.14.21-150500.55.59-default arch: x86_64 bits: 64
Console: pty pts/1 Distro: openSUSE Leap 15.5
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X299-DELUXE II v: Rev 1.xx
serial: UEFI: American Megatrends v: 3601 date: 09/24/2021
CPU:
Info: 12-core model: Intel Core i9-10920X bits: 64 type: MT MCP cache:
L2: 12 MiB
Speed (MHz): avg: 1335 min/max: 1200/4800:4700:4600 cores: 1: 4451 2: 1200
3: 1200 4: 1200 5: 1200 6: 1200 7: 1200 8: 1200 9: 1200 10: 1200 11: 1200
12: 1201 13: 1201 14: 1200 15: 1200 16: 1200 17: 1200 18: 1200 19: 1201
20: 1200 21: 1200 22: 1201 23: 1200 24: 1200
Graphics:
Device-1: NVIDIA GP104 [GeForce GTX 1070] driver: nouveau v: kernel
Display: x11 server: X.Org v: 1.21.1.4 with: Xwayland v: 22.1.5 driver: X:
loaded: modesetting unloaded: fbdev,vesa dri: swrast gpu: nouveau
resolution: 1920x1080
API: OpenGL v: 4.5 vendor: x.org mesa v: 22.3.5 renderer: llvmpipe (LLVM
15.0.7 256 bits)
API: Vulkan Message: No Vulkan data available.
API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
API: ALSA v: k5.14.21-150500.55.59-default status: kernel-api
Server-1: PulseAudio v: 15.0 status: active (root, process)
Info:
Memory: total: 128 GiB note: est. available: 125.48 GiB
used: 3.39 GiB (2.7%)
Processes: 420 Uptime: 0h 26m Shell: Bash inxi: 3.3.34

Saludos .

PD:
mikrios:~ # zypper ve
Loading repository data…
Reading installed packages…
Dependencies of all installed packages are satisfied.
mikrios:~ # zypper pchk
Loading repository data…
Reading installed packages…

Found 8 applicable patches:
Category | Patches
------------±-------
security | 4
recommended | 4

8 patches needed (4 security patches)