NTP large offset and jitter, ntpd SuSE 11.2

SuSE 11.2 = 2.6.31, ntpd 4.2.4p7. My offset and jitter are large compared to what I see on the internet. I have also been trying to use a GPS+PPS but that doesn’t seem to matter one way or the other. They usually start out with offset and jitter in the single digits and drift / move to something like -400 and 80 over a couple of hours.
I have tried various remedies under ntp.org like HZ=100, setting clocksource to tsc, hpet, or acpi_pm. I do not know what to do with acpi so i didn’t test that. One of my systems has drift of < ±20 which is good. I have tried it on another identical system and also an 11.1 system. One of the systems is not behind my firewall. They do not run a firewall themselves or VM or pretty much anything as they are not being used.
I have used ntp.conf with/without ‘prefer’. Here is a recent ntpq -p:
remote refid st t when poll reach delay offset jitter

xSHM(0) .GPS. 0 l 1 16 377 0.000 508.652 177.858
*SHM(1) .PPS. 0 l 3 16 377 0.000 81.463 13.790
+ .ACTS. 1 u 1 64 373 55.209 107.670 19.061
+saturn.netwrx1. .PPS. 1 u 11 64 377 59.973 100.192 10.695
+tick.usask.ca .GPS. 1 u 9 64 377 81.503 97.608 10.434
-97.f7bed1.clien 2 u 58 64 377 39.804 104.353 11.306
+dev1-c.nym009.i 2 u 23 64 377 46.182 104.460 11.550
+ntp2.Rescomp.Be 2 u 15 64 377 77.153 92.867 14.428
+ds3-us.zagbot.c 2 u 35 64 377 38.797 96.360 9.053
+montblanc.arbor 2 u 26 64 377 34.713 93.690 14.534

what else can i do, should i check. Is there something wrong with 11.1 and 11.2 ?
here is the ntp as run from /etc/init.d/ntp start (also with yast):
21238 ? Ss 0:00 /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp.conf

My initial recommendation is to consider whether your CMOS battery needs to be replaced. If it’s a Lithium-ion (typical OEM), it should be good for about 4 years plus. Sometimes cheapskates replace with NiCads and those will only last 2 plus years.

A bad battery can cause drift and surprisingly in one case it actually resulted in a hard drive failure years ago (yes, it was tied together although I can’t imagine exactly the relationship).


Solution to large jitter and offset with PPS (gpsd + ntpd) on SuSE 11
MUST add ‘disable kernel’ as a line in /etc/ntp.conf
then everything works like magic.

NiCds are not made in the button cell form factor, and besides will require a charging current, something not normally provided to Lithium cells which are not the same as Lithium ion batteries. In fact NiCds haven’t been use on motherboards since the 286s or so. So that’s two misapprehensions there.

Nickel-cadmium battery - Wikipedia, the free encyclopedia
Lithium battery - Wikipedia, the free encyclopedia
Lithium-ion battery - Wikipedia, the free encyclopedia

You’re right, I mis-spoke. CR2032 NiMH batteries should be avoided (not NiCad). Only Li-Ion batteries should be used, and sometimes people change out batteries incorrectly.


Ah no, you’re just putting your foot in it again. The CR2032 is a Lithium cell, not NiMH or LiIon. CR2032s are fine but of course there is a lot of variation in quality depending on the source since they are a mass-produced item.

LiIon is used for high current draw. It is not used for clock cells due to the self-discharge rate. NiMH is yet another battery technology also for high current draw. Though there are low-self discharge versions such as Sanyo’s Eneloop. You will not find LiIon or NiMH in the button cell form factor used for clock cells. Also the voltage is different, Li = 3.6V, NiMH = 1.2V.

Nickel-metal hydride battery - Wikipedia, the free encyclopedia

Taking a spin around the Internet, I cannot find any evidence that a battery exists with the dimensions of a CR2032 that is not some kind of Lithium based battery(Would have to be another designation since CR specifically means Lithium Dioxiide)… I also used Wikipedia to get the dimensions, then took a look around.

So, I assume that I must have been hallucinating (more than once many, many years ago) or that type of battery once existed but doesn’t anymore and information relating to that type of battery died.


Off my rocker,